Page 1 of 2 12 LastLast
Results 1 to 20 of 24

about to do my first mod.... installing an slp lid

This is a discussion on about to do my first mod.... installing an slp lid within the External Engine forums, part of the LSx Technical Help Section category; it's coming in the mail in a few days, and its the first mod im doing to my car so ...

  1. #1
    Super Senior Member derrinx's Avatar
    Join Date
    Feb 2006
    Location
    NYC
    Age
    30
    Posts
    2,712

    Black
    2000 Trans Am WS6

    about to do my first mod.... installing an slp lid

    it's coming in the mail in a few days, and its the first mod im doing to my car so i'm a little nervous.. i know it shouldn't be a hard install, but is there anything i need to know when i am installing it? again its an slp lid. just follow the directions and ill be fine right?

  2. #2
    Member homerunhtr21's Avatar
    Join Date
    Jan 2007
    Location
    Bama
    Posts
    375

    Artic White
    2002 Z28

    VERY EASY....should take about 10-15 minutes..just make sure you push it all the way back, the clamps might not fit right off the bat but work with it and after a while they should work just fine.

  3. #3
    Senior Member splitfinger09's Avatar
    Join Date
    May 2007
    Location
    Bartlesville, Oklahoma, United
    Age
    30
    Posts
    1,264

    Bright Rally Red
    2000 Camaro SS #5075 M6

    My SLP lid is really fitting like crap. I have a K&N filter with the gasket on the lid but it does not seal near as well as the factory lid. Any ideas on how to make a better seal? Also to make install easier you can use a little oil to make the hoses slide in easier.

  4. #4
    Member homerunhtr21's Avatar
    Join Date
    Jan 2007
    Location
    Bama
    Posts
    375

    Artic White
    2002 Z28

    slp lids have a history of not fitting real well it kind of a hit and miss, some do and some dont. You might try a different kind of filter, there all about the same.

  5. #5
    Senior Member
    Join Date
    Apr 2006
    Location
    Colorado
    Age
    36
    Posts
    2,924

    pie
    free

    I installed my lid in the apartment parking lot with just a screw driver. Wished I didn't now since I no longer have a use for it.

  6. #6
    Super Senior Member derrinx's Avatar
    Join Date
    Feb 2006
    Location
    NYC
    Age
    30
    Posts
    2,712

    Black
    2000 Trans Am WS6

    Quote Originally Posted by DanWS6 View Post
    I installed my lid in the apartment parking lot with just a screw driver. Wished I didn't now since I no longer have a use for it.
    shoulda sold it to me!

  7. #7
    Missing 4 Cylinders BULLET_WS6's Avatar
    Join Date
    Apr 2007
    Location
    Denton (Dallas)
    Posts
    10,577

    Silver
    2003 GTI 1.8T :(

    it will fit fine.. most people say some fit some dont... it honestly depends on who is installing it.. i have seen many cases where they say it doesnt fit right.. someone comes in and snaps it in correctly... just take your time.. take the mafs off to slide the intake on better... it helps.. and the little lip in the front has to be BEHIND the lower air box to seal properly.. oh and dont forget to transfer allllll the plugs

    btw... 1700 posts and its your first mod? where have you been? jk jk jk

  8. #8
    Senior Member
    Join Date
    Apr 2006
    Location
    Colorado
    Age
    36
    Posts
    2,924

    pie
    free

    Quote Originally Posted by derrinx View Post
    shoulda sold it to me!
    It's got a few scratches in it from me being careless, no one seems too interested in that. I wonder if they'd sand out...

  9. #9
    Senior Member splitfinger09's Avatar
    Join Date
    May 2007
    Location
    Bartlesville, Oklahoma, United
    Age
    30
    Posts
    1,264

    Bright Rally Red
    2000 Camaro SS #5075 M6

    Quote Originally Posted by BULLET_WS6 View Post
    it will fit fine.. most people say some fit some dont... it honestly depends on who is installing it.. i have seen many cases where they say it doesnt fit right.. someone comes in and snaps it in correctly... just take your time..
    Yeah i messed with that thing quit a bit trying to get it to fit better but it just isn't. What kind of filter are you running?

  10. #10
    Missing 4 Cylinders BULLET_WS6's Avatar
    Join Date
    Apr 2007
    Location
    Denton (Dallas)
    Posts
    10,577

    Silver
    2003 GTI 1.8T :(

    k&n my trick is slide it farrrr back on mafs... and force the lip of the lid in the center front past the bottom section of the intake.. so it should go under it... hard to describe maybe i can find a pic of what i mean

  11. #11
    Missing 4 Cylinders BULLET_WS6's Avatar
    Join Date
    Apr 2007
    Location
    Denton (Dallas)
    Posts
    10,577

    Silver
    2003 GTI 1.8T :(

    hope you can tell what im pointing out and read it as well.. im bored so i drew for you


  12. #12
    Senior Member splitfinger09's Avatar
    Join Date
    May 2007
    Location
    Bartlesville, Oklahoma, United
    Age
    30
    Posts
    1,264

    Bright Rally Red
    2000 Camaro SS #5075 M6

    Yeah that thing was a bitch trying to get the maf into the lid. A pic would be appreciated so i can compare the two. Thanks

  13. #13
    Senior Member splitfinger09's Avatar
    Join Date
    May 2007
    Location
    Bartlesville, Oklahoma, United
    Age
    30
    Posts
    1,264

    Bright Rally Red
    2000 Camaro SS #5075 M6

    Quote Originally Posted by BULLET_WS6 View Post
    hope you can tell what im pointing out and read it as well.. im bored so i drew for you

    Click for full size
    Thats not an slp lid is it? But i see what you mean by having the lid in back of the tray. Im pretty sure mine goes over the the front.

  14. #14
    Missing 4 Cylinders BULLET_WS6's Avatar
    Join Date
    Apr 2007
    Location
    Denton (Dallas)
    Posts
    10,577

    Silver
    2003 GTI 1.8T :(

    its not an slp but i didnt have a pic of mine.. it looks exactly the same...

  15. #15
    Senior Member splitfinger09's Avatar
    Join Date
    May 2007
    Location
    Bartlesville, Oklahoma, United
    Age
    30
    Posts
    1,264

    Bright Rally Red
    2000 Camaro SS #5075 M6

    Thanks for the help, i just went and made the adjustment and it seems to be fitting alot better.

  16. #16
    Missing 4 Cylinders BULLET_WS6's Avatar
    Join Date
    Apr 2007
    Location
    Denton (Dallas)
    Posts
    10,577

    Silver
    2003 GTI 1.8T :(

    good.. glad i can be of help to the ls1 community for once.. i picked up that trick some someone else on here at a meet

  17. #17
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    Only thing I remember about installing the lid was it can be a pain trying to get the iat sensor into the new lid. Think I lubed it with alittle vaseline.

  18. #18
    Super Senior Member derrinx's Avatar
    Join Date
    Feb 2006
    Location
    NYC
    Age
    30
    Posts
    2,712

    Black
    2000 Trans Am WS6

    yeah so obvviously it was real easy, thanks for the input people.. but the one problem im having is removing the 02 sensor from the old one and putting it on slp lid... i was rushed today because i had to go to the homerfest known as the yankee game, so i gave up without trying much... any suggestions for tom when i tackle the problem?

  19. #19
    Senior Member splitfinger09's Avatar
    Join Date
    May 2007
    Location
    Bartlesville, Oklahoma, United
    Age
    30
    Posts
    1,264

    Bright Rally Red
    2000 Camaro SS #5075 M6

    Quote Originally Posted by derrinx View Post
    yeah so obvviously it was real easy, thanks for the input people.. but the one problem im having is removing the 02 sensor from the old one and putting it on slp lid... i was rushed today because i had to go to the homerfest known as the yankee game, so i gave up without trying much... any suggestions for tom when i tackle the problem?
    Thats awesome I love the Yankees. They kicked some ass tonight as well, 5 homers hell yeah. As far as the lid my intake temp sensor pulled right out of my lid and fit perfectly into the slp. Good luck man. You gonna go watch Clemens tomorrow night?

  20. #20
    Super Senior Member derrinx's Avatar
    Join Date
    Feb 2006
    Location
    NYC
    Age
    30
    Posts
    2,712

    Black
    2000 Trans Am WS6

    haha yeah the game was awesome last night..todays was great too, and its too bad they lost it but it was very intense.. so back on topic all i did was wd40 the sensor up and push with a screwdriver... cant wait to start her up and take her for a spin haha

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installing a Cam?
    By Justin23454 in forum Internal Engine
    Replies: 14
    Last Post: 07-01-2010, 10:31 AM
  2. installing lt1 over the top
    By fastlt196 in forum LT1
    Replies: 6
    Last Post: 04-17-2009, 07:13 PM
  3. installing lt1 over the top
    By fastlt196 in forum LT1
    Replies: 0
    Last Post: 03-16-2009, 08:37 PM
  4. installing a cam
    By timd13 in forum General Help
    Replies: 2
    Last Post: 09-10-2006, 04:45 PM
  5. Installing TCS ??
    By Necction in forum General Help
    Replies: 11
    Last Post: 02-09-2006, 09:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •