Results 1 to 6 of 6

98 z28 after header install cec light and missing

This is a discussion on 98 z28 after header install cec light and missing within the External Engine forums, part of the LSx Technical Help Section category; I put mac mid length headers and off road y pipe, and borla car back on the car. After install, ...

  1. #1
    Junior Member
    Join Date
    Jun 2008
    Location
    greenville, texas
    Posts
    16

    black
    98 z28

    98 z28 after header install cec light and missing

    I put mac mid length headers and off road y pipe, and borla car back on the car. After install, misses, runs like total SH&$. Low rpms are hte worst, but when it gets above 2500 rpm it goes ahead and goes. But, can still feel power surge. Like an on/off switch as youre accelerating. Also, it has atarted using oil. The car only has 90k, but I dont understand it. Had the codes checked and it said o2 sensors, and oil leaking in the exhaust. What could this be? Anyone else have simular probs? Thanks JOhn

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    What are the code numbers?
    Did you use 02 extensions or did you splice?
    Break any plugs on the removal or instail?
    Or even chip..
    Melt any plug wires?
    How do you know there is oil in your exhaust?
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Member luvmyz28's Avatar
    Join Date
    Feb 2007
    Location
    Council Bluffs IA
    Posts
    192

    nbm
    99 z28

    Quote Originally Posted by johnshuler08 View Post
    I put mac mid length headers and off road y pipe, and borla car back on the car. After install, misses, runs like total SH&$. Low rpms are hte worst, but when it gets above 2500 rpm it goes ahead and goes. But, can still feel power surge. Like an on/off switch as youre accelerating. Also, it has atarted using oil. The car only has 90k, but I dont understand it. Had the codes checked and it said o2 sensors, and oil leaking in the exhaust. What could this be? Anyone else have simular probs? Thanks JOhn
    I'm guessing you removed the rear o2 sensors to install headers and ory. the o2 code would be because of that. unless you've already deleted them. the missing problem sounds like it would be plugs/wires problem if it ran good before the install.

  4. #4
    Member
    Join Date
    Jul 2008
    Location
    Decatur, IL
    Posts
    150

    red
    00 z28

    my car is doing the exact same thing he has explained with the missing and rpms, make sure your plug wires are away from the headers because they will arc, or melt,,, use some header heat wrap, some plug heat wrap, or buy angled boots... that is if a plug wire arc or melt is your prob.

  5. #5
    Junior Member
    Join Date
    May 2007
    Location
    Bethlehem PA.
    Age
    30
    Posts
    18

    black
    1998 pontiac trans am

    i kinda had the same problem and it was a cracked spark plug

  6. #6
    Junior Member
    Join Date
    May 2007
    Location
    Bethlehem PA.
    Age
    30
    Posts
    18

    black
    1998 pontiac trans am

    you might wanna check and make sure your plug wires are on all way the also...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Install shop or DIY header install?
    By dethinboots in forum External Engine
    Replies: 7
    Last Post: 09-24-2011, 07:35 PM
  2. Post LT header install header issues
    By ob02z28 in forum External Engine
    Replies: 20
    Last Post: 02-18-2010, 05:10 PM
  3. Question: Missing Header Bolt = Engine Noise?
    By David Ray in forum General Help
    Replies: 13
    Last Post: 05-11-2009, 09:57 AM
  4. header install
    By lt1powerdc10 in forum LT1
    Replies: 2
    Last Post: 09-30-2007, 07:21 AM
  5. header install
    By Vertiviper in forum Firebird / WS6
    Replies: 1
    Last Post: 03-17-2006, 06:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •