Results 1 to 9 of 9

whats up ppl???

This is a discussion on whats up ppl??? within the Corvette forums, part of the Vehicle Specific category; i got 1999 corvette with the ls 1 engine but need help rebuilding it, the bottom part of the engine ...

  1. #1
    Junior Member
    Join Date
    Feb 2011
    Location
    hayward ca
    Posts
    3

    red
    1999 corvette

    whats up ppl???

    i got 1999 corvette with the ls 1 engine but need help rebuilding it, the bottom part of the engine has low pressure what should i do???? dont know where to start?
    i live in haryward ca is there same where i can go to get it fix cos i dont have a place to do my self

  2. #2
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    First thing you need to check is your oil pump I would suggest, maybe a oil pressure sensor is going bad also!!

  3. #3
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    engine making any noise? Like was stated....could just be a bad oil pressure sending unit.

  4. #4
    Junior Member
    Join Date
    Feb 2011
    Location
    hayward ca
    Posts
    3

    red
    1999 corvette

    Low piston pressure

    low piston pressure this is what i was told is the problem by a person down the street from my house. engine does make noise and about the pump being bad i dont know how to check for that....
    cos i just bought the car about a 1 month ago and next thing this happens.
    one more question? if i had just sell my car just the way it is right now?
    how much should i ask for i paid 13K when i paid for this car but now i think i would be better off buying a used one from a dealer for how ever much i can sell it for.
    im thinking 8k with the problem that i have
    what you guys think?????

  5. #5
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    Quote Originally Posted by pjs18 View Post
    low piston pressure this is what i was told is the problem by a person down the street from my house. engine does make noise and about the pump being bad i dont know how to check for that....
    cos i just bought the car about a 1 month ago and next thing this happens.
    one more question? if i had just sell my car just the way it is right now?
    how much should i ask for i paid 13K when i paid for this car but now i think i would be better off buying a used one from a dealer for how ever much i can sell it for.
    im thinking 8k with the problem that i have
    what you guys think?????
    I would take it to a reputable shop and drop it off with them and see what they tell you the problem is, cause it could just be something minor!!

  6. #6
    Junior Member
    Join Date
    Feb 2011
    Location
    hayward ca
    Posts
    3

    red
    1999 corvette

    yea iam thinking about doing that also i hope it is something small

  7. #7
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    Quote Originally Posted by pjs18 View Post
    yea iam thinking about doing that also i hope it is something small
    It probably is man, usually people freak out when something goes wrong with their car thinking that its a major malfunction. When 90% of the time it is something inexpensive or easy to do, and will fix the problem right away!!

  8. #8
    Junior Member
    Join Date
    Feb 2011
    Location
    Florida
    Posts
    13

    Blue
    2001 corvette

    Definitely get an accurate diagnosis before you try to sell it and lose a bunch of money.

  9. #9
    Junior Member Heavyvette's Avatar
    Join Date
    Feb 2011
    Location
    Suffolk, Va
    Posts
    23
    Blog Entries
    1

    Sebring Silver
    1998 Corvette

    Common C5 problem

    Hey man it might be the common c5 oil sensor or sender problem. As the other guys have said have that checked first. Mines was broke when I bought the car and pegged at the max. I also heard of them stuck at zero. Also LS1s oil pressure is normal at 20-40-60 psi with the higher usually at warmup. They are located at the rear of the engine, behind the intake on the driver's side. One of the members has a thread on how to replace it. Also another common problem is the gas gage going from full to zero. These are not major problems.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Whats next?
    By zeetwentyeight in forum General Help
    Replies: 4
    Last Post: 03-11-2010, 05:52 PM
  2. Whats up from Tx.
    By yanoZ28 in forum New Member Introductions
    Replies: 6
    Last Post: 10-27-2009, 06:54 PM
  3. whats up everyone!!!
    By enyaw619 in forum New Member Introductions
    Replies: 0
    Last Post: 09-24-2009, 09:54 AM
  4. WHats up!!
    By T-SPOON in forum New Member Introductions
    Replies: 3
    Last Post: 10-21-2006, 03:35 AM
  5. whats up
    By antlop in forum New Member Introductions
    Replies: 3
    Last Post: 10-19-2006, 05:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •