Results 1 to 9 of 9

RPM gauge dont work?

This is a discussion on RPM gauge dont work? within the Corvette forums, part of the Vehicle Specific category; i have a buddy i work with and he has a problem with his RPM gauge not working. His speedometer ...

  1. #1
    Junior Member
    Join Date
    Jul 2007
    Location
    usa
    Posts
    26

    black
    1998 T/A

    RPM gauge dont work?

    i have a buddy i work with and he has a problem with his RPM gauge not working. His speedometer works fine though so why wouldnt the RPM gauge work? he has a 79 vette. he also told me that when he starts his car the RPM needle will max out and stay there???

  2. #2
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Pittsburgh, PA
    Age
    36
    Posts
    21,719

    My life is a
    Ben Stiller movie.

    they are totally seperate entities

    RPM = rotation of the engine
    MPH = rotation of the tires

  3. #3
    NASCAR Go Fast, Turn Left ntimid8r's Avatar
    Join Date
    Aug 2001
    Location
    San Diego, CA
    Posts
    8,048

    383 w/Meth & ProCharger
    2001 Camaro Z28

    The rpm guage is mechanically driven by a plastic gear inside the transmission and a metal cable covered in plastic. Sounds like either the gear is loose/bad or the cable itself is bad.

  4. #4
    car enthusiast djvaly's Avatar
    Join Date
    Nov 2005
    Location
    Philly area
    Posts
    9,863
    +1 I agree. I think the plastic gear may have lost some teeth and is not rotating anymore... just like the plastic gear for the flip headlights on the fbodies, if a few teeth is missing it will get stuck and not work anymore etc...

  5. #5
    Junior Member
    Join Date
    Jul 2007
    Location
    usa
    Posts
    26

    black
    1998 T/A

    thanx guys. i'll let him know

  6. #6
    Member
    Join Date
    Apr 2006
    Location
    North Canton, OH
    Age
    68
    Posts
    385

    Light Metallic Pewter
    2000 Corvette Coupe

    gotta be mechanical on that year........

  7. #7
    Junior Member
    Join Date
    Feb 2007
    Location
    Chattanooga Tn.
    Posts
    2
    i thought the the RPM worked off of the distributer and the speedometer worked off of the plastic gear in the transmission.

  8. #8
    NASCAR Go Fast, Turn Left ntimid8r's Avatar
    Join Date
    Aug 2001
    Location
    San Diego, CA
    Posts
    8,048

    383 w/Meth & ProCharger
    2001 Camaro Z28

    Quote Originally Posted by Jabo View Post
    i thought the the RPM worked off of the distributer and the speedometer worked off of the plastic gear in the transmission.
    You're right. I just realized I replied back too quickly on the original post and was referring to the speedometer cable. It was early in the am.

    Now after thinking about it.... I'd have to say there's a faulty ground behind the dash or possibly one of the metal trace has been worn/damaged. Could also be the tach module inside the distributor has gone bad too.

  9. #9
    Junior Member
    Join Date
    Jul 2007
    Location
    usa
    Posts
    26

    black
    1998 T/A

    Quote Originally Posted by ntimid8r View Post
    You're right. I just realized I replied back too quickly on the original post and was referring to the speedometer cable. It was early in the am.

    Now after thinking about it.... I'd have to say there's a faulty ground behind the dash or possibly one of the metal trace has been worn/damaged. Could also be the tach module inside the distributor has gone bad too.
    thanx for the info. we'll take a look at it on one of our weekend days we gotta work. nothing beats getting paid to do government work

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gauges dont work
    By 02CamaroZ28WithLS1 in forum Stereo and Electronics
    Replies: 0
    Last Post: 05-18-2011, 08:59 PM
  2. Question: Super deal for! But dont know if it would work?
    By tingo99 in forum General Help
    Replies: 5
    Last Post: 08-27-2009, 05:59 AM
  3. signatures dont work
    By Modulistic in forum Request and Feedback
    Replies: 8
    Last Post: 03-30-2007, 12:18 AM
  4. My cd player on my pc dont work:(
    By MarylandMan23 in forum Almost Anything Goes
    Replies: 1
    Last Post: 02-22-2007, 12:46 PM
  5. F@@ing blinkers dont work now
    By gillahoon in forum General Help
    Replies: 2
    Last Post: 09-27-2006, 08:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •