Page 2 of 2 FirstFirst 12
Results 21 to 24 of 24

old vette

This is a discussion on old vette within the Corvette forums, part of the Vehicle Specific category; Originally Posted by pajeff02 I replaced the driver window motor in our car last year. FYI: Autozone had the part ...

  1. #21
    its short but its skinny. jiveass's Avatar
    Join Date
    Oct 2009
    Location
    The Woodlands/spring/houston
    Posts
    2,142

    pewter
    99 trans am

    Quote Originally Posted by pajeff02 View Post
    I replaced the driver window motor in our car last year. FYI: Autozone had the part numbers reversed. I ordered a motor for the driver door, and the part that came in was for the passenger side. Re-ordered the passenger side and received the correct part. Not sure if this has been remedied.

    BTW: Before you rip the motor out - pull the plug off the motor and run a jumper wire to the terminals. You could have a bad switch or a break in the door harness wiring.
    well sometimes the drivers motor freezes up on me and i have to take the panel off and tap on the door right where the motor is with a hammer and it will free up and work again. but i never had to do this with the passenger side. its getting annoying. im learning the hard way that this car is not practical for a daily driver. also sometimes have to remove the window switch and plug it back in in order for them to work. i may just buy new motors like you say and end this problem.

  2. #22
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by needls1again View Post
    well sometimes the drivers motor freezes up on me and i have to take the panel off and tap on the door right where the motor is with a hammer and it will free up and work again. but i never had to do this with the passenger side. its getting annoying. im learning the hard way that this car is not practical for a daily driver. also sometimes have to remove the window switch and plug it back in in order for them to work. i may just buy new motors like you say and end this problem.

    Your car is newer, so it may be a slightly different setup. Under the hood on the firewall is a circuit breaker. Should be on the driver side next to the brake booster. This breaker will temporarily trip if the motor pulls too many amps trying to raise the window.

    It is likely that your window tracks are pretty gummed up from all the crap the gets into the doors over the years. Would not hurt to clean and relubricate the tracks. Also, check out your rollers and squirt a little WD-40 on them.

    As to the wiring, could be a loose or partially corroded connection. You may have a switch that is going bad, or the breaker could be overly sensitive.

  3. #23
    its short but its skinny. jiveass's Avatar
    Join Date
    Oct 2009
    Location
    The Woodlands/spring/houston
    Posts
    2,142

    pewter
    99 trans am

    so after my blowout saturday morning...i got a new tire. fixed my exhaust leak and my passenger window. lubed up the gear and tracks with silicone lubricant...seems to be working nicely. i know im slackin on the pics...ill be sure to have em up by tomorrow.

  4. #24
    its short but its skinny. jiveass's Avatar
    Join Date
    Oct 2009
    Location
    The Woodlands/spring/houston
    Posts
    2,142

    pewter
    99 trans am

    ok so this weekend i will be doing a few things to the vette...brand new dual exhaust with no cat or mufflers, new fan clutch and water pump, new brakes, shocks, and if i feel froggy i may order the cam, but i will not install it until i get a new intake manifold, carb, stall converter and all the gaskets that go along with this. i will try to get some detailed pics posted up of everything on the car so that everyone can see what kind of shape its really in. im kinda curious as to what lies beneath..(under the car that is).

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New vette!!!
    By REVNORR82 in forum Almost Anything Goes
    Replies: 26
    Last Post: 06-07-2011, 07:35 PM
  2. My day in the vette!
    By brendan.9 in forum Almost Anything Goes
    Replies: 8
    Last Post: 10-03-2010, 10:35 AM
  3. vette vs 5.0
    By brendan.9 in forum Kill Stories
    Replies: 7
    Last Post: 09-17-2010, 10:40 AM
  4. 99 FRC Vette or 01 Z06?
    By Roastem in forum Corvette
    Replies: 14
    Last Post: 07-22-2008, 06:54 PM
  5. 07 vette vs. me
    By SuPeRmAn23 in forum Kill Stories
    Replies: 28
    Last Post: 06-16-2007, 09:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •