Results 1 to 13 of 13

no turn signals! need help!

This is a discussion on no turn signals! need help! within the Corvette forums, part of the Vehicle Specific category; okay Im new to corvettes just bought my first an 01. so I just put it on the road and ...

  1. #1
    Nik
    Join Date
    Mar 2007
    Location
    elmira, new york
    Age
    33
    Posts
    128

    red
    2001 corvette

    no turn signals! need help!

    okay Im new to corvettes just bought my first an 01. so I just put it on the road and the blinkers stop working as well as 4 ways. checked fuses all are good played with hazard switch and actually managed to play with it enough to get the 4 ways to work. now the signals work when they want to but speratically. so far ive diagnosed it to the flasher/blinker and four way switch because they are one in the same. also because its only a 30$ part and causes me to tear into my dash. so hopefully one of you wonderfull jents has had the same problem and could give some advice or atleast point me in the right direction.

  2. #2
    Iraq money well spent. TRY ME GT's Avatar
    Join Date
    Mar 2007
    Location
    Quantico Virginia
    Age
    35
    Posts
    327

    Black on Black
    2000 Camaro SS M6

    I just changed my corner lights and had a similar problem. i pulled all my bulbs and found one of the turn signal lights was in backwards. your problem sounds slightly different than mine though. good luck!

  3. #3
    Nik
    Join Date
    Mar 2007
    Location
    elmira, new york
    Age
    33
    Posts
    128

    red
    2001 corvette

    oh and the only thing i have done prior to all of this was installed a sets of black covers on the rear lights which screw on with the stock lens covers using the stock screws but I dont know or think that could or should cause a problem i hope

  4. #4
    Iraq money well spent. TRY ME GT's Avatar
    Join Date
    Mar 2007
    Location
    Quantico Virginia
    Age
    35
    Posts
    327

    Black on Black
    2000 Camaro SS M6

    maybe one of the bulbs are loose in the back from the vibrations. if the problem started after that install, i would check that. (im no expert though)

  5. #5
    Junior Member Lethal Tendencies's Avatar
    Join Date
    Jan 2007
    Location
    Lake Geneva, Wisconsin
    Posts
    37

    millenium yellow
    2000 corvette

    It sounds like the hazard switch.I have the same problem on my '00 coupe. I take my knuckle and hit the hazard switch and that usually works. So I eventually will replace the switch.I have heard alot of other complaints on the same issue,so it is a common problem.Heres a write up on replacing the switch.http://myweb.cableone.net/kd5fx/HSwitch/HSwitch.htm

  6. #6
    Junior Member
    Join Date
    Mar 2007
    Location
    washington
    Posts
    3

    torch red
    2001 c5

    anyone else having (service active handling) lights and warning intermitently?
    usually after driving 10 miles or so. (2001 c5

  7. #7
    Aw shucks. bluefields88's Avatar
    Join Date
    Jul 2006
    Location
    Berkeley, CA
    Posts
    3,619

    Red
    2000 Camaro SS #3574 A4

    I'm not sure how the Corvettes work compared to Camaros, but my blinker stopped working and I couldn't figure out why, turns out my front bulb burnt out and it stopped my blinker from blinking. just had to change a bulb and it worked again. might be able to help you, might not.

  8. #8
    Senior Member Z06-Goose's Avatar
    Join Date
    Jul 2005
    Location
    Colorado
    Posts
    3,276

    Avus Silver
    2007 Audi RS4

    Move to Colorado. Nobody here uses turn light signal, it seems
    2007 Audi RS 4

  9. #9
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Pittsburgh, PA
    Age
    36
    Posts
    21,719

    My life is a
    Ben Stiller movie.

    Quote Originally Posted by Lethal Tendencies View Post
    It sounds like the hazard switch.I have the same problem on my '00 coupe. I take my knuckle and hit the hazard switch and that usually works. So I eventually will replace the switch.I have heard alot of other complaints on the same issue,so it is a common problem.Heres a write up on replacing the switch.http://myweb.cableone.net/kd5fx/HSwitch/HSwitch.htm
    WHAT A P.I.T.A!

  10. #10
    Junior Member
    Join Date
    Mar 2007
    Location
    washington
    Posts
    3

    torch red
    2001 c5

    Thanks, i will try that

  11. #11
    Member
    Join Date
    Aug 2005
    Location
    Sugar Land, Texas
    Posts
    115

    Supersonic Blue
    2012 Z06

    Could also be your turn signal module. It was located under the dash in my 98 Camaro. Black box with approximately 10 wires coming out of it. Controls turn signals and flashers.

  12. #12
    Junior Member
    Join Date
    Mar 2007
    Location
    washington
    Posts
    3

    torch red
    2001 c5

    Thanks Larry,but i followed Lethal Tendecies directions and voila no more problem. So thanks to all

  13. #13
    Nik
    Join Date
    Mar 2007
    Location
    elmira, new york
    Age
    33
    Posts
    128

    red
    2001 corvette

    no more problems changed the flasher unit! thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. turn signals
    By pewterz55 in forum Stereo and Electronics
    Replies: 15
    Last Post: 06-24-2010, 06:17 PM
  2. turn signals
    By pewterz55 in forum Camaro / SS
    Replies: 1
    Last Post: 08-11-2009, 07:12 PM
  3. Turn signals!!
    By youngun67 in forum General Help
    Replies: 5
    Last Post: 02-17-2009, 10:09 AM
  4. Turn Signals
    By bb4ninja in forum General Help
    Replies: 14
    Last Post: 04-16-2008, 05:17 PM
  5. Help: turn signals
    By joker in forum Stereo and Electronics
    Replies: 2
    Last Post: 04-12-2008, 01:18 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •