Results 1 to 2 of 2

C5 Auto question/problem, please chime in...

This is a discussion on C5 Auto question/problem, please chime in... within the Corvette forums, part of the Vehicle Specific category; I have an 04' C5 Auto and just recently replaced the fuel pump. Here is the question/problem. With the traction ...

  1. #1
    Junior Member
    Join Date
    May 2008
    Location
    Elmhurst, IL
    Posts
    1

    Silver
    04' Corvette

    C5 Auto question/problem, please chime in...

    I have an 04' C5 Auto and just recently replaced the fuel pump. Here is the question/problem. With the traction control on, if I floor it from a dead stop, the traction control activates and prevents the tires from spinning (this is what it is suppose to do). However with the traction control off, I can floor it, the tires will spin for about half way through first gear, then it "bogs" almost like it is cutting fuel. I have talked to a few other guys (all with mods) and they say their cars will spin the tires through the first 3 gears. Is this normal on a bone stock C5 or do I have problems else where? The car did this before I had the fuel pump replaced, and the dealership said they "fixed" the problem (the fuel pump was blowing fuses) thus they replaced the fuel pump, but I have a feeling this is something else like a PCM, or something more complex and I don't think the dealer wanted to deal with it because this is under warranty. Thnaks in advance for all your input!!!

  2. #2
    Junior Member
    Join Date
    Aug 2005
    Location
    SoCal
    Age
    40
    Posts
    83

    Mag Red
    '98 C5

    Try holding down the traction control button for more than 5 seconds to turn off active handling.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Auto tans problem.
    By Sarge91 in forum Drivetrain
    Replies: 14
    Last Post: 11-26-2008, 10:35 PM
  2. auto shifting problem
    By craZ28y dave in forum Drag Racing
    Replies: 5
    Last Post: 03-05-2007, 02:47 AM
  3. 94 z28 auto-transmission problem
    By tds1213 in forum Automatic Transmission
    Replies: 2
    Last Post: 07-19-2006, 11:05 AM
  4. shifter problem with auto
    By got-a-ls1 in forum General Help
    Replies: 6
    Last Post: 04-09-2006, 05:08 PM
  5. Auto Tranny Problem
    By iceman504 in forum Automatic Transmission
    Replies: 5
    Last Post: 03-01-2006, 03:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •