Results 1 to 8 of 8

Z28 won't start after being parked for a year

This is a discussion on Z28 won't start after being parked for a year within the General Help forums, part of the LSx Technical Help Section category; Hello everyone, I have a 1996 Z28. I parked the car a year ago and now it won't start. When ...

  1. #1
    Junior Member chadz28's Avatar
    Join Date
    Aug 2008
    Location
    Indianapolis
    Posts
    2

    Red
    1996 Camaro Z28

    Z28 won't start after being parked for a year

    Hello everyone,

    I have a 1996 Z28. I parked the car a year ago and now it won't start. When I parked the car it was real low on gas, so I thought that there wasn't enough gas to be picked up from the fuel pump, so I put in a half a tank of gas and the car still just turns over and won't start. Could the fuel filter be gummed up from letting it sit? I am going to start driving it again it only has 24,000 miles on it. I thought I was I was taking care of it by not driving (it is going to be a gift for my son when he get his liscense), however I have been told not driving it is not good for it. When it was parked it ran fine. Ant advice will be appreciated.

    Thanks, Chad.

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    certainly wouldn't hurt to pull that fuel filter and replace it. All the crap settles to the bottom of the tank and then gets picked up by the fuel pump. Swap that filter and check your fuel pressure at the rail.

  3. #3
    Senior Member TransAm11973's Avatar
    Join Date
    Nov 2007
    Location
    in my Trans Am
    Posts
    2,630

    Black
    2000 Trans Am WS6

    Quote Originally Posted by 0rion View Post
    certainly wouldn't hurt to pull that fuel filter and replace it. All the crap settles to the bottom of the tank and then gets picked up by the fuel pump. Swap that filter and check your fuel pressure at the rail.
    agreed, also does it turn over at all? Did you do a load test on the battery? what do your spark plugs look like? Whats ur oil level and what does it look like?

  4. #4
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    I just noticed you have an LT-1. Verify spark as the optisparks on those cars are prone to failure. Might have gotten moisture into it.

  5. #5
    Junior Member chadz28's Avatar
    Join Date
    Aug 2008
    Location
    Indianapolis
    Posts
    2

    Red
    1996 Camaro Z28

    Thanks guys for all your advice and quick replies. The battery is turning the car over good, but I have not load tested it. The oil & oil level is good. I pulled one plug and it didn't look bad, however I need to look at the rest. I have never heard of an optispark, so I googled it to see what it looks like. I found a picture on ebay, so now I know what it looks like, but I don't know where it is on the car or how to test the spark on one. Is there a certain fuel pressure tester that you guys reccomend. Thanks again and sorry for not knowing to much about the mechanics of these cars.

  6. #6
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    Quote Originally Posted by chadz28 View Post
    Hello everyone,

    I have a 1996 Z28. I parked the car a year ago and now it won't start. When I parked the car it was real low on gas, so I thought that there wasn't enough gas to be picked up from the fuel pump, so I put in a half a tank of gas and the car still just turns over and won't start. Could the fuel filter be gummed up from letting it sit? I am going to start driving it again it only has 24,000 miles on it. I thought I was I was taking care of it by not driving (it is going to be a gift for my son when he get his liscense), however I have been told not driving it is not good for it. When it was parked it ran fine. Ant advice will be appreciated.

    Thanks, Chad.
    Quote Originally Posted by TransAm11973 View Post
    agreed, also does it turn over at all? Did you do a load test on the battery? what do your spark plugs look like? Whats ur oil level and what does it look like?








    Opti spark is located behind the water pump....
    To verify spark, get a spark tester (Should be readily available at local parts store) and use it per instructions ( pull a plug wire, install tester in line, ground and have someone turn it over while you watch the tester... ) then let us know

  7. #7
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    Quote Originally Posted by chadz28 View Post
    I don't know where it is on the car or how to test the spark on one. .
    See Above



    Quote Originally Posted by chadz28 View Post
    Is there a certain fuel pressure tester that you guys reccomend. .
    I believe the O.E.M. pump puts out between 45-60 PSI, Any tester rated for that range should work.




    Quote Originally Posted by chadz28 View Post
    Thanks again and sorry for not knowing to much about the mechanics of these cars.
    You'll never know if you don't ask...

  8. #8
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    just sell it to me! $100

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Official crappy parked thread!
    By Dzel in forum Almost Anything Goes
    Replies: 65
    Last Post: 07-27-2014, 03:58 PM
  2. I start my senior year tomorrow
    By EnjoiJoe in forum Almost Anything Goes
    Replies: 28
    Last Post: 09-03-2010, 06:42 PM
  3. f-body going to be parked for a while
    By 95Firebirdred in forum LT1
    Replies: 5
    Last Post: 03-05-2009, 08:16 PM
  4. Question: Where should a 16 year old start...
    By Zaccagnini in forum Firebird / WS6
    Replies: 60
    Last Post: 07-27-2008, 09:37 AM
  5. Not the way I wanted to start my new year...
    By Tayktez in forum New Member Introductions
    Replies: 2
    Last Post: 01-09-2007, 06:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •