Results 1 to 5 of 5

Yep I broke the oil pressure sensor Thx Orion

This is a discussion on Yep I broke the oil pressure sensor Thx Orion within the General Help forums, part of the LSx Technical Help Section category; Damn it Orion you jinx me. 2 guesses what I broke today. FML!! The oil pressure sensor. I did my ...

  1. #1
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,509

    Navy Blue Metallic
    98 T/A w/a little mods...

    Yep I broke the oil pressure sensor Thx Orion

    Damn it Orion you jinx me. 2 guesses what I broke today. FML!! The oil pressure sensor. I did my best watching out for it and one quick twist of the old intake and dink off it came. What really sucks is that I think I have take the intake back off to get to it and also wait till Monday to get the part. Because it's at the warehouse and nobody has it in stock.

    Orion in case you forgot what I mean:LS6 Intake? Need a Quick answer ASAP!

    Now is there any tips or tricks to getting this fix without taking the intake off or I'm just screwed and have to do it.

  2. #2
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Well...if the metal piece with the nut is exposed, then you shouldn't have to take the intake off again.

  3. #3
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    good luck getting your hand to it.....much easier to pull the intake back off. I tried to warn you.

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,509

    Navy Blue Metallic
    98 T/A w/a little mods...

    yeah I know you warned me......still doesn't make me feel better.

    It broke I think above the nut, because the piece I have in hand is plastic. About the top 3".

    I'm going to get everything off tomorrow so that when I get it Mon all I have to do is install everything back on. Well that's my plan.

    I got lucky in noticing it because as I was leaving the driveway I always have a habit of looking at my gauges. That's when I saw the OPG out. I said to myself - shit I bet I broke what Orion told me to be careful about. I popped the hood and saw it and said shit! Started calling all the stores, only one had it in their warehouse and that was an hr away and their was no way I could get to it prior to close. So I'm stuck till Monday. My only consolation prize is that the couple of minutes I had it running it sounded real good and it seem to fix a minor back fire when I let off from a high rpm.

  5. #5
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    That is the one drawback about our motors. Almost NO parts stores keep our pressure switches/sensors in stock. When mine went, I had to order it through my old job's parts supplier...which took a day.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil Pressure sensor
    By mrpckrb in forum External Engine
    Replies: 7
    Last Post: 06-24-2008, 08:40 AM
  2. HELP! broke a sensor
    By rajiv1998 in forum Firebird / WS6
    Replies: 7
    Last Post: 05-09-2007, 04:49 PM
  3. Oil Pressure Sensor
    By CWW17 in forum General Help
    Replies: 5
    Last Post: 04-20-2007, 08:06 AM
  4. Knock Sensor/Oil Pressure Sensor Issue
    By Slow '99 in forum External Engine
    Replies: 1
    Last Post: 04-04-2007, 09:28 AM
  5. Oil pressure sensor
    By blomeup647 in forum General Help
    Replies: 5
    Last Post: 04-03-2007, 04:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •