Results 1 to 10 of 10

Yankk SS3200 Just installed

This is a discussion on Yankk SS3200 Just installed within the General Help forums, part of the LSx Technical Help Section category; I just installed my Converter I have to drive 150 miles before loading it or going WOT that will be ...

  1. #1
    BLKHWK Durango's Avatar
    Join Date
    Oct 2008
    Location
    New Brunswick Canada
    Age
    47
    Posts
    881

    Black
    BLK TA modded 12.2@113mph

    Yankk SS3200 Just installed

    I just installed my Converter I have to drive 150 miles before loading it or going WOT that will be a long haul When I first started the car after the converter installed at Idle I reved up the engine and I could hear the clutch rattle inside the converter then when the tranny warmed up kit stopped Is it something you guys experience with a stall

    Second thing I find it a little sligish a low speed or less peppy I guess it feels like I have to push more on the gas and the rpm is a little higher for it to move no spipping but almost like a little more load on it just a little different feeling I just did 10 miles the computer hasn't even had time to learn itself yet

  2. #2
    Junior Member ATI347's Avatar
    Join Date
    Dec 2007
    Location
    Iowa
    Posts
    10
    90 Mustang GT x2

    It will "Feel" less peppy untill you reach a higher rpm somewhere close to the 3200 rating. When you lay into it however it will feel quite a bit different. I am not really sure on the noise at initial startup? Possibly untill the fluid filled the converter? Does it do it all the time or just the first time?

  3. #3
    BLKHWK Durango's Avatar
    Join Date
    Oct 2008
    Location
    New Brunswick Canada
    Age
    47
    Posts
    881

    Black
    BLK TA modded 12.2@113mph

    It does it very rarely

    It does it at 50 to 55 mph a rattle sound when the rpm is very low 15 to 1700 rpm I think I'll call Yank tomorrow

  4. #4
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    did you fill the converter up with fluid prior to installing it? Not good on them to start them dry. Not sure on your rattle but the first thing I would check is heat shields and things like that. Are you sure it's coming from the stall?

    It will feel sluggish to you at first but that's what it's supposed to do. Wait until you drop the hammer on it the first time.....it'll take sand paper to get the smile off your face.

  5. #5
    Senior Member Z28Thunder's Avatar
    Join Date
    Dec 2006
    Location
    Broken Arrow, Ok
    Age
    52
    Posts
    4,542

    Arctic White
    2000 Z28

    Quote Originally Posted by 0rion View Post
    did you fill the converter up with fluid prior to installing it? Not good on them to start them dry. Not sure on your rattle but the first thing I would check is heat shields and things like that. Are you sure it's coming from the stall?

    It will feel sluggish to you at first but that's what it's supposed to do. Wait until you drop the hammer on it the first time.....it'll take sand paper to get the smile off your face.
    It will fell like that to you for awhile. You will get use to it after a week or so. You notice big time now because of how the stock converter drove. I would say come back in a week or so and say how you feel then.

  6. #6
    BLKHWK Durango's Avatar
    Join Date
    Oct 2008
    Location
    New Brunswick Canada
    Age
    47
    Posts
    881

    Black
    BLK TA modded 12.2@113mph

    LOL I hope so

    I just googled it and I guess on a low load or low RPM some of them you hear the plates rattle and yes My guy did I had a list for hime he smiled and said I do big time he was the head transmission guy at GM for 30 years and now he has a performance shop He owns a Corvette with a Yank SS3600 but his doesn't seem to do it

    It's only at low rpm on the hgw at around 1500rpm I hope it goes away kinda of anoying

  7. #7
    BLKHWK Durango's Avatar
    Join Date
    Oct 2008
    Location
    New Brunswick Canada
    Age
    47
    Posts
    881

    Black
    BLK TA modded 12.2@113mph

    That's a great line

    Quote Originally Posted by 0rion View Post
    did you fill the converter up with fluid prior to installing it? Not good on them to start them dry. Not sure on your rattle but the first thing I would check is heat shields and things like that. Are you sure it's coming from the stall?

    It will feel sluggish to you at first but that's what it's supposed to do. Wait until you drop the hammer on it the first time.....it'll take sand paper to get the smile off your face.
    Hhahaha ok I can't wait it's going to be nice tomorrow I have ohhh 40 miles on it now I'm filling up and going for a drive and when I see 150 miles guess what I'm testing this baby out

    No more squeaks in the T Top with the sfc, lca ,phb, relocation brackets can't wait :-)

  8. #8
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    have you been tuned for the stall yet? If not you really should get it tuned. The 3200 you might be able to slide by but I was banging the rev limiter with my 3500 on shifts and it would lock/unlock due to misfire codes they can make the car throw. Not too mention it'll feel really soft until you get the line pressures cranked up a little either with tuning or a shift kit.

  9. #9
    BLKHWK Durango's Avatar
    Join Date
    Oct 2008
    Location
    New Brunswick Canada
    Age
    47
    Posts
    881

    Black
    BLK TA modded 12.2@113mph

    Yes I did

    Quote Originally Posted by 0rion View Post
    have you been tuned for the stall yet? If not you really should get it tuned. The 3200 you might be able to slide by but I was banging the rev limiter with my 3500 on shifts and it would lock/unlock due to misfire codes they can make the car throw. Not too mention it'll feel really soft until you get the line pressures cranked up a little either with tuning or a shift kit.
    I appreciate the responses Orion and everybody
    I'm a little nervous I see a lot of issues with TC that rattle on line and I sure hope it's tuning I really don't want to ruin my tranny after spending $2000 with tuning for this TC it's a lot of money
    Especially that I saved up for 3 years to finally get what I wanted a car that I knew that was babied never saw the track with 34 000 miles I'm not sure the guy brought it over 100mph He's a computer guy that just bought the car because he liked the look and drove it like a Corolla lol

    I have a Frost mail order Tune with a pcm I bought from him so it works great except that 50 t 55 mph rattle and a bit slugish But that sounds normal

    Man I hope it works out for me The car looks amazing and with the sfc phb lca and relocation bracket it feels nice on the road no more T Top squeak either :-) Now I'll call Dave at Yank and hope he is nice I see horror stories on line there too !!

  10. #10
    BLKHWK Durango's Avatar
    Join Date
    Oct 2008
    Location
    New Brunswick Canada
    Age
    47
    Posts
    881

    Black
    BLK TA modded 12.2@113mph

    Ok I called Dave at Yank

    I called Dave at YANK and the guy waqs very pleasant on the phone and super knowledgable He says that it is definetly a PWM wathever that means lol
    My car feels like a standard that is in 4th when it's suppose to be in 3rd and it's causing it to rattle so I need to change something in the tuning Line pressure I think so it's a good thing that I have 2 pcm I'm wainting for a reply from Steve Williams I had his phone # but lost it :-( anyway I'll keep u guys posted I was going to go see my local tuner but I already paid once I really don't feel like spending more money this was very expensive and I did spend at least a grand more than expected my slush fund is loooooonnnnngggg gone No headers and y pipe for me this year or cam :-(

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installed Cam
    By oharam in forum Internal Engine
    Replies: 15
    Last Post: 03-31-2011, 04:50 PM
  2. Yank ss3200
    By Durango in forum Automatic Transmission
    Replies: 24
    Last Post: 02-19-2011, 09:43 AM
  3. TSS kit installed
    By KC4x4 in forum Firebird / WS6
    Replies: 16
    Last Post: 09-18-2008, 06:07 AM
  4. PHB installed
    By Formula Dave in forum Suspension and Handling
    Replies: 18
    Last Post: 01-21-2008, 10:11 AM
  5. HSW kit installed. - Need some help.
    By WinSomeLoseNone in forum Nitrous
    Replies: 1
    Last Post: 04-06-2006, 04:11 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •