Results 1 to 10 of 10

WTF is wrong with my car???

This is a discussion on WTF is wrong with my car??? within the General Help forums, part of the LSx Technical Help Section category; I have a 99 TA with 67K on her. Nearly everytime I start the car my trip resets and the ...

  1. #1
    Rice Hungry GottaHaveLS1's Avatar
    Join Date
    Oct 2005
    Location
    Connecticut
    Age
    29
    Posts
    1,316

    Black
    1999 Trans Am M6

    WTF is wrong with my car???

    I have a 99 TA with 67K on her. Nearly everytime I start the car my trip resets and the gauges fly up. My turn signals are also acting weird. When i have them on it flashes once and then flickers the second time.

    I checked the battery and the red connector was corroded a little, so i cleaned it up with water and baking soda. Plugged it back in, same prob. I'm pretty sure the alternators fine, cuz i got the computer scanned and it only showed !CAGS. could this problem be due to fried fuses? any ideas?

    I'll get a new battery if i have to but me and my dad don't think it's the problem
    1999 Trans Am M6
    SLP Short Throw, Lid and CAI, BMR STB and SFC, UMI PHB, Pacesetter LT's and ORY, Magnaflow Catback, DMH 3" E-Cutout, LS7 Clutch, Motive 4.10, 160 T-Stat, MSD, !AIR, !EGR, 17x9.5 Chrome C6's wrapped in Hankook 275/40/17

    Tuned at Mongillo Motors in New Haven, CT

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Did you get the battery tested yet?

  3. #3
    Senior Member 1MileCrash's Avatar
    Join Date
    Mar 2007
    Location
    Wisconsin Rapids, WI
    Posts
    2,849

    Black
    1999 Z/28 M6

    i had the sweeping gauges and trip reset to zero each time that i turned the car on as well and i replaced the battery as everyone on here said to do.

    a week or so later i'm having no problems. new battery cleared it up for me...although i did not have anything goin on with turn signals.

  4. #4
    2002 Formula Firehawk 96z28's Avatar
    Join Date
    Jul 2005
    Location
    San Diego CA
    Age
    34
    Posts
    1,321

    Black
    2002 Formula Firehawk

    yes i would check your terminals again and then the battery

  5. #5
    Rice Hungry GottaHaveLS1's Avatar
    Join Date
    Oct 2005
    Location
    Connecticut
    Age
    29
    Posts
    1,316

    Black
    1999 Trans Am M6

    I also forgot to mention that my keyless entry barely works. I changed the battery and that didn't help, so i tested my old one and its good, so i put that back in. I have a feeling these problems are all related.

  6. #6
    Rice Hungry GottaHaveLS1's Avatar
    Join Date
    Oct 2005
    Location
    Connecticut
    Age
    29
    Posts
    1,316

    Black
    1999 Trans Am M6

    Quote Originally Posted by 2001NBMZ28 View Post
    Did you get the battery tested yet?
    I went to autozone to get it tested. This dumb 16 year old girl hooked it up and really couldn't give me an answer, so i didn't buy a battery. i think i'm gonna go to advance auto parts and see if they have anyone knowledgeable there.

  7. #7
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Got to get that battery load tested, if for no other reason just to eliminate it as being the problem. When my stock Delco completely died my first indication was keyless entry wouldn't work one morning, hatch had popped by itself, and not even a click when turning the key on. After opening the car with the key popped the hood and the green eye was black. Weird things can happen with battery problems.

  8. #8
    Rice Hungry GottaHaveLS1's Avatar
    Join Date
    Oct 2005
    Location
    Connecticut
    Age
    29
    Posts
    1,316

    Black
    1999 Trans Am M6

    Quote Originally Posted by 2001NBMZ28 View Post
    Got to get that battery load tested, if for no other reason just to eliminate it as being the problem. When my stock Delco completely died my first indication was keyless entry wouldn't work one morning, hatch had popped by itself, and not even a click when turning the key on. After opening the car with the key popped the hood and the green eye was black. Weird things can happen with battery problems.
    I'm not sure what the green eye is, but i saw what i think ur talking about on top of the battery. Looked green to me. what does it indicate?

  9. #9
    Catfish for Breakfast Bobby97SS's Avatar
    Join Date
    Jan 2007
    Location
    Austin, TX
    Age
    60
    Posts
    574

    white
    97 SS

    Green eyes, same as the dumb 16 yearold girl that doesnt know how to load a battery.

  10. #10
    Catfish for Breakfast Bobby97SS's Avatar
    Join Date
    Jan 2007
    Location
    Austin, TX
    Age
    60
    Posts
    574

    white
    97 SS

    Seriously, everyone that messes with cars should invest in a digital multimeter and a battery load tester. Voltage drop test, cranking voltage alternator output and anything else you need to know can be easily determined with $100 worth of tools. You will wonder how you lived without a meter.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 Arctic White Trans Am Street/Race Car
    By Hodgesz28 in forum Vehicles For Sale / Trade
    Replies: 15
    Last Post: 04-17-2007, 06:18 PM
  2. basically all new 95 z28 auto 12 second car 200o miles since rebuild
    By eddies26 in forum Vehicles For Sale / Trade
    Replies: 2
    Last Post: 12-04-2006, 04:26 AM
  3. Bad engine noise need help car wont run
    By bernieblackbird3 in forum General Help
    Replies: 13
    Last Post: 05-09-2006, 05:11 PM
  4. can you beat this
    By ls1 = slow in forum Almost Anything Goes
    Replies: 46
    Last Post: 03-23-2006, 09:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •