Results 1 to 7 of 7

WTF

This is a discussion on WTF within the General Help forums, part of the LSx Technical Help Section category; ok i put a poly tranny mount in my bird an now not only do i feel more vibration but ...

  1. #1
    Member 2000dreambird's Avatar
    Join Date
    Jun 2009
    Location
    Mass
    Posts
    618

    silver/black
    00 trans am,SLP,Ws6

    WTF

    ok i put a poly tranny mount in my bird an now not only do i feel more vibration but it seems like it rev's up and down slower an seems slugish under 2500 rpm

  2. #2
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    The vibration is/should be expected. Sluggish? I dont see how a poly mount could have anything to do with it feeling sluggish. Its probably in your head cause your not pissed about feeling those extra vibrations

  3. #3
    Member 2000dreambird's Avatar
    Join Date
    Jun 2009
    Location
    Mass
    Posts
    618

    silver/black
    00 trans am,SLP,Ws6

    i knew the extra vib was going to happen cause the new mount has very little give to it,maybe the sluggish is in my head but i swear it even rev's down slower.and it doesn't seem to have as much balls under 2500 RPM

  4. #4
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    No chance you installed a new cam as well is there?

    I dont see how installing a mount has any effect on low RPM.

  5. #5
    Member 2000dreambird's Avatar
    Join Date
    Jun 2009
    Location
    Mass
    Posts
    618

    silver/black
    00 trans am,SLP,Ws6

    Question

    i wouldn't even know what to put in for a cam i haven't looked into them yet i love the rumble at a idle when you have one in thou,any advice you can give me on a cam.an the whole tranny mount thing is there a chance i'm putting pressure on something i shouldn't be.

  6. #6
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by 2000dreambird View Post
    i wouldn't even know what to put in for a cam i haven't looked into them yet i love the rumble at a idle when you have one in thou,any advice you can give me on a cam.an the whole tranny mount thing is there a chance i'm putting pressure on something i shouldn't be.
    I was just kidding with you.

    The tranny mount install is fairly simple. Which one did you go with? Energy suspension? If so, some have claimed they had to grind down the two nubs on top to help with installations and bad vibrations. I did not. I have next to zero vibration.

    Do some general maintance and your slightly sluggish behavior might go away.
    370 CI - Twin 6766 Turbo - Jakes stage 5 4L80E - MWC 9" - Holley Dominator

    Build in progress...

  7. #7
    Member 2000dreambird's Avatar
    Join Date
    Jun 2009
    Location
    Mass
    Posts
    618

    silver/black
    00 trans am,SLP,Ws6

    it was just a basic poly mount from summit an it was more then simple to do the install but it was the only thing i did to it when i noticed the issue

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •