Results 1 to 10 of 10

WTF!!!

This is a discussion on WTF!!! within the General Help forums, part of the LSx Technical Help Section category; A symbol that looks like a radiator with an arrow inside of it pointing down came on my guages.. anyone ...

  1. #1
    Junior Member -Hot Sause-'s Avatar
    Join Date
    Feb 2009
    Location
    San Jose,Ca
    Posts
    70

    Pewter
    1999 Camaro

    WTF!!!

    A symbol that looks like a radiator with an arrow inside of it pointing down came on my guages.. anyone tell me what that it???

  2. #2
    Member Eric1987's Avatar
    Join Date
    Jun 2008
    Location
    Long Beach, California
    Posts
    853

    Black
    1999 Z28 Convert

    Low on coolant if it is the right thing im thinking of. My sensor went out so mine comes on all the time.

  3. #3
    Member camaross19973's Avatar
    Join Date
    Mar 2007
    Location
    Los Angeles
    Age
    44
    Posts
    238

    blue
    1999 camaro ss #976

    it happens u need to replace it or just unplug it .that is if ur full of coolant

  4. #4
    Junior Member -Hot Sause-'s Avatar
    Join Date
    Feb 2009
    Location
    San Jose,Ca
    Posts
    70

    Pewter
    1999 Camaro

    yeah i just did a complete flush of all my fluids last week so it must be a bad sensor?
    "BOATS & HOES"

  5. #5
    Member ebdboudreaux's Avatar
    Join Date
    Nov 2008
    Location
    Tampa, Fl
    Age
    31
    Posts
    206
    99' 30th Ann TA

    Quote Originally Posted by -Hot Sause- View Post
    yeah i just did a complete flush of all my fluids last week so it must be a bad sensor?
    open up the cap and look... I did a flush on mine, and still had to add just a little bit of water the next day cause the light came on... haven't seen it since..

  6. #6
    Junior Member -Hot Sause-'s Avatar
    Join Date
    Feb 2009
    Location
    San Jose,Ca
    Posts
    70

    Pewter
    1999 Camaro

    ive been checking all the fluids every morning just to make sure.. i cant seem to figure it out.. and just tonight my "check engine soon" light came on... MY BABYS TURNING INTO A NIGHTMARE!!! HELLLLLPPP!!! haha

  7. #7
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Quote Originally Posted by -Hot Sause- View Post
    ive been checking all the fluids every morning just to make sure.. i cant seem to figure it out.. and just tonight my "check engine soon" light came on... MY BABYS TURNING INTO A NIGHTMARE!!! HELLLLLPPP!!! haha


    calm down all this shit is simple as hell.

    Get the codes checked somewhere.

    Come back and well tell you whats up.

    The coolant sensor is known to corrode and set the light off. Its just a light...

    Unplug or replace the sensor.

  8. #8
    Junior Member -Hot Sause-'s Avatar
    Join Date
    Feb 2009
    Location
    San Jose,Ca
    Posts
    70

    Pewter
    1999 Camaro

    yeah so i just checked the codes and nothing came up so it must be a bad sensor or something but i thought that if it was a sensor then it would show up on the computer?

    also i cant seem to figure out this damn annoying "bird chirping noise" coming from the pulley area.. i took some degreaser to it but it didnt do anything.. the noise starts immediatly when the car starts and even goes louder when im driving.. any guesses to what it could be?

    on a good note my " check engine soon" light went away!

  9. #9
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Quote Originally Posted by -Hot Sause- View Post
    yeah so i just checked the codes and nothing came up so it must be a bad sensor or something but i thought that if it was a sensor then it would show up on the computer?

    also i cant seem to figure out this damn annoying "bird chirping noise" coming from the pulley area.. i took some degreaser to it but it didnt do anything.. the noise starts immediatly when the car starts and even goes louder when im driving.. any guesses to what it could be?

    on a good note my " check engine soon" light went away!
    It will store a code for the light.

    The chirping noise is a idler pulley or a tensioner most likely. Take off the belts and spin each by hand and listen.

  10. #10
    Junior Member -Hot Sause-'s Avatar
    Join Date
    Feb 2009
    Location
    San Jose,Ca
    Posts
    70

    Pewter
    1999 Camaro

    ok thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •