Page 1 of 2 12 LastLast
Results 1 to 20 of 23

ws6 seems to hesitate

This is a discussion on ws6 seems to hesitate within the General Help forums, part of the LSx Technical Help Section category; i have a 99 ws6, i seem to be having some problems. when i take off from a light, it ...

  1. #1
    my ws6 eats rice gokillyourself's Avatar
    Join Date
    Apr 2009
    Location
    virginia
    Posts
    177

    sexy
    1999 trans am ws6

    Exclamation ws6 seems to hesitate

    i have a 99 ws6, i seem to be having some problems. when i take off from a light, it has a bad hesitation as i accelerate. as the rpm go up it picks back up with horse power, its a manual 6 speed, it does it from 1st though 3rd. i have use throtle body cleaner to clean the maf, throtle body and iac. not sure what it could be. please help.

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    I wouldn't use regular tb cleaner on the maf. They sell a maf cleaner that's residue free. TB cleaner will leave a residue on the MAF wires. Is it a hesitation or is it missing?

  3. #3
    my ws6 eats rice gokillyourself's Avatar
    Join Date
    Apr 2009
    Location
    virginia
    Posts
    177

    sexy
    1999 trans am ws6

    Unhappy

    it seems to hesitate, as i take off, it takes off normally then all of a sudden it drops power bad then picks up again (a drop for about a second or two). it seems to happen between 1500-3000 rpms. the thing is it does not do it when i use the engine to slow down.

  4. #4
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    Quote Originally Posted by gokillyourself View Post
    it seems to hesitate, as i take off, it takes off normally then all of a sudden it drops power bad then picks up again (a drop for about a second or two). it seems to happen between 1500-3000 rpms. the thing is it does not do it when i use the engine to slow down.
    I'd stick it on a dyno and see exactly what's going on with it.

  5. #5
    Member War Theory's Avatar
    Join Date
    Jan 2008
    Location
    brooklyn
    Posts
    228

    Black
    2001 Ws6

    This might sound silly but did you take off track control?
    Last edited by War Theory; 05-04-2009 at 09:12 PM.

  6. #6
    my ws6 eats rice gokillyourself's Avatar
    Join Date
    Apr 2009
    Location
    virginia
    Posts
    177

    sexy
    1999 trans am ws6

    this is a new issue that just started recently, maybe a tune up is what's needed. i don't have access to a dyno. traction control is off.

  7. #7
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Plugs wires pcv valve fuel filter clean maf and TB.

    Should cure it.

  8. #8
    my ws6 eats rice gokillyourself's Avatar
    Join Date
    Apr 2009
    Location
    virginia
    Posts
    177

    sexy
    1999 trans am ws6

    Quote Originally Posted by JoshieDoom View Post
    Plugs wires pcv valve fuel filter clean maf and TB.

    Should cure it.
    IF YOU CHENK MY FIRST POST YOU WILL SEE THAT I ALREADY DID MAF, IAC AND TB, ALSO I DID THE PVC BUT I DIDN'T POST THAT.

  9. #9
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Spark plugs and fuel filter then.

  10. #10
    Give me a place to stand. levityinc3's Avatar
    Join Date
    Jul 2008
    Location
    Jacksonville, FL
    Posts
    1,449

    Red
    2000 SS '89 IROC-Z

    Quote Originally Posted by gokillyourself View Post
    IF YOU CHENK MY FIRST POST YOU WILL SEE THAT I ALREADY DID MAF, IAC AND TB, ALSO I DID THE PVC BUT I DIDN'T POST THAT.
    Someone's a little angry.

  11. #11
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Quote Originally Posted by levityinc3 View Post
    Someone's a little angry.
    That comment ought to sooth the beast

  12. #12
    my ws6 eats rice gokillyourself's Avatar
    Join Date
    Apr 2009
    Location
    virginia
    Posts
    177

    sexy
    1999 trans am ws6

    Quote Originally Posted by levityinc3 View Post
    Someone's a little angry.
    NAH NOT ANGRY, JUST LETTING THEM KNOW THAT I HAD ALREADY TRIED THAT

  13. #13
    my ws6 eats rice gokillyourself's Avatar
    Join Date
    Apr 2009
    Location
    virginia
    Posts
    177

    sexy
    1999 trans am ws6

    Quote Originally Posted by gokillyourself View Post
    nah not angry, just letting them know that i had already tried that
    can't get angey for free help, lol

  14. #14
    my ws6 eats rice gokillyourself's Avatar
    Join Date
    Apr 2009
    Location
    virginia
    Posts
    177

    sexy
    1999 trans am ws6

    Can a fuel filter really make that much of a difference? I mean, it really has a baddddd hesitation? I think i will try the plugs though.

  15. #15
    Give me a place to stand. levityinc3's Avatar
    Join Date
    Jul 2008
    Location
    Jacksonville, FL
    Posts
    1,449

    Red
    2000 SS '89 IROC-Z

    Quote Originally Posted by gokillyourself View Post
    can't get angey for free help, lol
    Haha, I think it was the CAPS LOCK that made it seem angry.


  16. #16
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Quote Originally Posted by gokillyourself View Post
    Can a fuel filter really make that much of a difference? I mean, it really has a baddddd hesitation? I think i will try the plugs though.
    Doubt it, but the plugs and wires might be probable cause, also bad o2 sensors can cripple a car in the worst way. Did you go back and use the maf cleaner instead of throttle body cleaner? And is it throwing the ses light, you might be able to get a code and tell you what's wrong.

  17. #17
    my ws6 eats rice gokillyourself's Avatar
    Join Date
    Apr 2009
    Location
    virginia
    Posts
    177

    sexy
    1999 trans am ws6

    Quote Originally Posted by c5z28 View Post
    Doubt it, but the plugs and wires might be probable cause, also bad o2 sensors can cripple a car in the worst way. Did you go back and use the maf cleaner instead of throttle body cleaner? And is it throwing the ses light, you might be able to get a code and tell you what's wrong.
    i haven't had the chance to get any maf cleaner, its not throwing any codes, how can you tell if the o2's are on their last leg? i wonder if they make 8.8 wires for the ls1, i have never seen any, also what are some good plugs to use? before i got my ws6 i had an 88 irocz conv. that i just use normal autolite plugs. thank you guys for all the help, i really do apreciate it.

  18. #18
    my ws6 eats rice gokillyourself's Avatar
    Join Date
    Apr 2009
    Location
    virginia
    Posts
    177

    sexy
    1999 trans am ws6

    before i started having problems, i noticed it was sucking up a bunch of oil into the tb, i took off the oil cap and replaced it with a breather, cleaned the maf, iac(didn't remove it though), and tb. i also took out the baffles in the hood, modified the air box(cut out the little spuares on the bottom), and i cut off the pipe that sticks down in the middle of the intake behind the tb. i got that info from installuniversity.com

  19. #19
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    I don't remember what plugs I got I just remembered middle of the road not the cheapest or most expensive. o2's might be your next bet then, they aren't cheap so you might try and have a buddy swap w/ you real quick and see if that clears it up, on those bosch and a/c delco are the normal w/ bosh generally being cheaper and come w/ extensions for when you have long tubes. It could also be bad cat's and bad rear o2's behind the cats. Take out the iat sensor from the lid and give it a once over to see i it is coated since it measures incoming air at idol.

    You might take it to a tuner and have him run it around for you if all that fails.

  20. #20
    BLKHWK Durango's Avatar
    Join Date
    Oct 2008
    Location
    New Brunswick Canada
    Age
    47
    Posts
    881

    Black
    BLK TA modded 12.2@113mph

    I was having the same problemn and I cleaned the maf and it helped. Right now I'm getting a ses light and it says o2 sensor and I'm getting hesitation but not as bad as you and they are telling me that it's the catalityc converter that's going or gone. Keep us posted

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •