Page 1 of 2 12 LastLast
Results 1 to 20 of 27

Windows and Locks don't Work?

This is a discussion on Windows and Locks don't Work? within the General Help forums, part of the LSx Technical Help Section category; My friend's bird is having issues. Windows and Locks have quit working. We changed out the passenger motor a week ...

  1. #1
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,505

    Navy Blue Metallic
    98 T/A w/a little mods...

    Windows and Locks don't Work?

    My friend's bird is having issues.

    Windows and Locks have quit working. We changed out the passenger motor a week ago and it just quit working the next day. I checked the fuses and the one that came with the window fix kit had blown. Replaced it, window still doesn't work. I've checked all fuses and do not see any more that have blown. Pulled door panel off no connects have come lose.

    No sure what else it could be.


    Any suggestions?

    Could it be the switch at the drivers side?

  2. #2
    Member
    Join Date
    Mar 2007
    Location
    NC
    Posts
    421

    NBM
    1998Z28

    Well the window and door locks on the drivers side are 2 switches not 1. So they shouldn't go out all at once. I just replace my drivers side because I couldn't roll down the pass. window. But I still could roll the pass. window from the pass door switch when the drivers side was broke.
    You might have just got a bad replacement motor.
    TSP 347 SB, TSP Stage 2.5 PRC LS6, TSP MS4, Performabuilt Stage 2 4L60E, Yank PT4000, 4.11s, Fast 90/90, FTRA Cold air intake+all the free mods, Dynatech Supermaxx Exaust System, DMH Cutouts, Hooker Catback/FTRA Tips. Tuned by RPM/Garner NC. 11.28@119

  3. #3
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    You are saying all windows and locks, right? I don't think the drivers side switch has nothing to do with it. The system is parallel not in series. Have you check for 12 volts at the end of the connectors? If you haven't get a voltmeter and put the lead at the connector if you get 12v when you holfd the switch down then is the motor. If you don't get 12v then put one lead on the 12v pin at the connector and the other lead at ground on chassis(not the connector) while holding the leads in place press and hold the switch that corresponds to that connector and see if you get 12v at the voltmeter. If you do then you have an open ground somewhere.
    Last edited by JayTA98; 02-24-2011 at 11:16 AM.

  4. #4
    Junior Member
    Join Date
    Feb 2011
    Location
    TRNC
    Posts
    8
    2002 VX M6

    Smile

    Sounds like,

    The BCM connection needs to be checked or at least re-set.

    Try a search for BCM re-set, it must be here somewhere, and give that a go first.

  5. #5
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Quote Originally Posted by SMWS6TA View Post
    My friend's bird is having issues.

    Windows and Locks have quit working. We changed out the passenger motor a week ago and it just quit working the next day. I checked the fuses and the one that came with the window fix kit had blown. Replaced it, window still doesn't work. I've checked all fuses and do not see any more that have blown. Pulled door panel off no connects have come lose.

    No sure what else it could be.


    Any suggestions?

    Could it be the switch at the drivers side?
    Did anything happen proir to them going losing power? (ie nasty bump in the road)

    Are those the only components out?

    There might be a relay blown, but I think there would be more components out.

    If the door panel is still off, unplug the window motor and test the harness to make sure your getting power there.

    And I'm pretty sure it could be the switch.

  6. #6
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by Sid447 View Post
    Sounds like,

    The BCM connection needs to be checked or at least re-set.

    Try a search for BCM re-set, it must be here somewhere, and give that a go first.
    BINGO!

    click here for the BCM fix

  7. #7
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,505

    Navy Blue Metallic
    98 T/A w/a little mods...

    Well just did the bcm fix and nothing changed. Need more ideas

  8. #8
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    One question for you. Do the windows and locks not work from either of the door switches and the key FOB?
    The locks and windows share the same ground. The service manual describes its location as "Near the left A-pillar, bolted to the instrument panel mounting stud behind the kick panel."

  9. #9
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by SMWS6TA View Post
    Well just did the bcm fix and nothing changed. Need more ideas
    Did you check what i posted?

  10. #10
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,505

    Navy Blue Metallic
    98 T/A w/a little mods...

    Quote Originally Posted by Cutlass View Post
    One question for you. Do the windows and locks not work from either of the door switches and the key FOB?
    The locks and windows share the same ground. The service manual describes its location as "Near the left A-pillar, bolted to the instrument panel mounting stud behind the kick panel."
    Left = drivers side correct?

    Quote Originally Posted by JayTA98 View Post
    Did you check what i posted?
    I do not have a multi-meter locating one as we speak

  11. #11
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by SMWS6TA View Post
    Left = drivers side correct?
    yes. also what year is your friends Firebird?

  12. #12
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,505

    Navy Blue Metallic
    98 T/A w/a little mods...

    Its a 99 and also when we push the window buttons I can hear a click sound in the middle of the car, like behind the radio.
    Last edited by SMWS6TA; 02-27-2011 at 07:58 PM.

  13. #13
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Could be a relay kicking on? Isn't that wear the BCM is?

    Are you getting power at the window motor?

  14. #14
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,505

    Navy Blue Metallic
    98 T/A w/a little mods...

    yes on both windows.

    I ppulled the bcm and saw no cracks. I solder them anyways and still no change.

    I read that there is a window control module in the same area that is close to the radio. Could that have gone bad?



  15. #15
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by SMWS6TA View Post
    I read that there is a window control module in the same area that is close to the radio. Could that have gone bad?
    That module would only affect the driver's window.

  16. #16
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,505

    Navy Blue Metallic
    98 T/A w/a little mods...

    OK, I hope I have time tomorrow to check the ground that you talked about Cutlass

  17. #17
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    If the ground is good, you could try and use a jumper to getthe window to open/close to see if the switch is faulty.

  18. #18
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,505

    Navy Blue Metallic
    98 T/A w/a little mods...

    Ok, back to this problem child. It's been a busy week for me.

    It has power to the harness on both sides (drivers and passenger)

    The ground looks ok, not broken.

    The key FOB will set the alarm but will not unlock the car doors.

    I'm suspecting the BCM has just completely gone bad.

  19. #19
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Does the bcm control the wireless signal from the fob? Or does it control all operations of the door locks?

    Have you ruled out the switch yet?

  20. #20
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,505

    Navy Blue Metallic
    98 T/A w/a little mods...

    Quote Originally Posted by KMdef9 View Post
    Does the bcm control the wireless signal from the fob? Or does it control all operations of the door locks?

    Have you ruled out the switch yet?
    Switches have been check out. I pulled his and put in my car and they both work, also used mine in his and they don't work.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: 1998 Camaro electric windows and door locks illumination
    By Ted Von Kampen in forum Stereo and Electronics
    Replies: 3
    Last Post: 02-14-2012, 10:37 AM
  2. fixed my intermittent windows, radio and locks
    By Firebirdformula in forum Stereo and Electronics
    Replies: 0
    Last Post: 06-06-2010, 09:36 AM
  3. Power door locks deciding not to work
    By 98ls1t/a in forum General Help
    Replies: 6
    Last Post: 02-22-2010, 06:23 PM
  4. Electric Locks Wont work
    By ilikeppie in forum Stereo and Electronics
    Replies: 0
    Last Post: 12-18-2007, 08:54 PM
  5. Getting rid of the power windows and locks....
    By xinthenight in forum General Help
    Replies: 8
    Last Post: 08-25-2007, 11:18 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •