Results 1 to 9 of 9

with wifes 2005 grand am....

This is a discussion on with wifes 2005 grand am.... within the General Help forums, part of the LSx Technical Help Section category; Well it's a 2005 Grand Am GT with ram air.........and every once in a while the car while hot and ...

  1. #1
    Senior Member clg82's Avatar
    Join Date
    Feb 2007
    Location
    California
    Age
    35
    Posts
    2,453
    2000 Trans Am

    with wifes 2005 grand am....

    Well it's a 2005 Grand Am GT with ram air.........and every once in a while the car while hot and while we are decelerating will surge, you can feel it and see it on the tac.....why is it doing this and what should I check first? any help would be appreciated ~Chris
    2000 Arctic White trans am, ws6 hood, ws6 air box, slp lid, slp smooth bellows, slp loudmouth exhaust,shift kit, rebuilt trans, LS6 intake, 3.73 gears, Shaner S3 p/p throttle body, and a tune . SFC. C6 ZO6 rims 18" in back 17" in front. Drilled and slotted rotors.

  2. #2
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Mine does it too.

    Upped the line pressure on the tranny, and it went away. There is some module (costs like $25, but labor is $600) inside the tranny that starts to go out.
    Although mine does the surging under light load...like up a hill or something.

  3. #3
    Senior Member clg82's Avatar
    Join Date
    Feb 2007
    Location
    California
    Age
    35
    Posts
    2,453
    2000 Trans Am

    Quote Originally Posted by Mr. Luos View Post
    Mine does it too.

    Upped the line pressure on the tranny, and it went away. There is some module (costs like $25, but labor is $600) inside the tranny that starts to go out.
    Although mine does the surging under light load...like up a hill or something.
    would this module be easy to replace myself? Also does this mean that module is actually going out?

  4. #4
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Not necessarily.

    And the tranny has to be removed (hence the $600 labor) to get to that module.
    http://www.gaownersclub.com/forum/index.php

  5. #5
    Senior Member clg82's Avatar
    Join Date
    Feb 2007
    Location
    California
    Age
    35
    Posts
    2,453
    2000 Trans Am

    Quote Originally Posted by Mr. Luos View Post
    Not necessarily.

    And the tranny has to be removed (hence the $600 labor) to get to that module.
    http://www.gaownersclub.com/forum/index.php
    Freaking engineers at gm........thanks for the info luos.

  6. #6
    Member Mieux97's Avatar
    Join Date
    Dec 2007
    Location
    Chicago
    Posts
    614

    White
    99 Pontiac Trans Am #2466

    Quote Originally Posted by Mr. Luos View Post
    Mine does it too.

    Upped the line pressure on the tranny, and it went away. There is some module (costs like $25, but labor is $600) inside the tranny that starts to go out.
    Although mine does the surging under light load...like up a hill or something.

  7. #7
    Member
    Join Date
    Dec 2005
    Location
    Cedar Rpaids,IA
    Age
    37
    Posts
    354

    Red
    1998 Camaro SS

    My wifes 05 grand am se was doing that and on hers it turned out to be a bad fuel injector, weird because it never threw any codes or ever detected a misfire.
    1998 Camaro SS Hard Coupe Bright Red #1593
    Mods: Lots!!, still my daily driver except for winter
    383rwhp 370rwft/lbs

    1979 Corvette
    Mods Lots!!, weekend cruiser
    325rwhp and 320rwft/lbs

    2007 Dodge Ram 1500 4x4 (Yes its got a HEMI)
    Mods: Catback, BFI CAI, Winter daily driver

  8. #8
    Senior Member clg82's Avatar
    Join Date
    Feb 2007
    Location
    California
    Age
    35
    Posts
    2,453
    2000 Trans Am

    Quote Originally Posted by vetteemt View Post
    My wifes 05 grand am se was doing that and on hers it turned out to be a bad fuel injector, weird because it never threw and codes or ever detected a misfire.
    I was thinking maybe a fuel injector, that is what it feels like. Maybe some fuel injector cleaner will fix it right up. Mr Luos, how did you up the line pressure, i'm assuming you need have to have hptuners or something correct?

  9. #9
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Quote Originally Posted by clg82 View Post
    Mr Luos, how did you up the line pressure, i'm assuming you need have to have hptuners or something correct?


    And probably isn't the best fix either.
    It will just continue to get worse, until I have to replace it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS/FT: 2005 Jeep Grand Cherokee
    By bigpappy in forum Vehicles For Sale / Trade
    Replies: 0
    Last Post: 02-19-2009, 12:52 PM
  2. 1975 Pontiac Grand Am - Grand Am Grand Slam
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 12-03-2007, 07:30 PM
  3. 2005 Pontiac GTP Grand Prix issues
    By 98-LS1 in forum General Help
    Replies: 5
    Last Post: 08-21-2006, 10:35 PM
  4. Replies: 18
    Last Post: 03-29-2006, 09:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •