Results 1 to 10 of 10

Whole suspensoin sqeuaks like a car from the 60's

This is a discussion on Whole suspensoin sqeuaks like a car from the 60's within the General Help forums, part of the LSx Technical Help Section category; Car is only 11 years old but the whole suspension has been squeaking bad lately. like even when i get ...

  1. #1
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    32
    Posts
    72

    Black
    1999 Camaro SS

    Whole suspensoin sqeuaks like a car from the 60's

    Car is only 11 years old but the whole suspension has been squeaking bad lately. like even when i get in and out of the car it squeaks. is there some sort of special lubricant i need to put somewhere in the suspension ? Thanks.
    1999 Camaro SS 6 Speed

  2. #2
    NY Representative basballny2's Avatar
    Join Date
    Aug 2007
    Location
    NeW YoRk
    Posts
    3,393

    Red
    2001 ws6

    the "whole suspension" is very vague.....find out where the squeek is coming from and spray some CRC on there or some white lithium greese

  3. #3
    Member
    Join Date
    Jun 2009
    Location
    coon rapids, MN
    Age
    52
    Posts
    404

    red
    2000TA

    how many miles?spray some JB80 at suspension bushing.maybe you need new shocks.

  4. #4
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    590

    Black
    2000 Camaro SS Conv.

    Yes, locate the squeak fist, then you can determine how to adress it.

  5. #5
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    rubber does not last forever..........dry rots really bad.....change over to poly

  6. #6
    NY Representative basballny2's Avatar
    Join Date
    Aug 2007
    Location
    NeW YoRk
    Posts
    3,393

    Red
    2001 ws6

    Quote Originally Posted by sjsingle1 View Post
    rubber does not last forever..........dry rots really bad.....change over to poly
    not everything on a suspension should be poly.......if the rubber isnt dry rotted you can eliminate the squeeks but you need to find out what exactly is squeeking first

  7. #7
    Retired NOT tired SteveC's Avatar
    Join Date
    Jul 2005
    Location
    Poway, Ca
    Posts
    1,126

    SOM
    2001 Z28 (Sara)

    My entire rear suspension is polyurathane, and I get "squeaking" also, I use a special synthetic grease (do not use regular grease on poly), and it will quiet it down a bit.

    SteveC

  8. #8
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    32
    Posts
    72

    Black
    1999 Camaro SS

    120k miles. The squeaking isn't ALWAYS there, it kind of shows up after driving the car for 20-30 minutes. It's hard to locate but i would say it is coming from both the rear and front near the shocks/springs. I do have subframe connectors and LCA's, could this be the problem?

  9. #9
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    590

    Black
    2000 Camaro SS Conv.

    Quote Originally Posted by chris5 View Post
    120k miles. The squeaking isn't ALWAYS there, it kind of shows up after driving the car for 20-30 minutes. It's hard to locate but i would say it is coming from both the rear and front near the shocks/springs. I do have subframe connectors and LCA's, could this be the problem?
    There are multiple thinks that can squeak front and rear but shocks and springs are least likely. In the rear there are the lower control arm bushings, sway bar links and sway bar bushings. In the front upper controla arm bushings, lower control arm bushings sway bar bushings, sway bar end links upper ball joints, lower ball joints.

    You might start with a good quality silicone spray and shoot all the bushings well on both sides.

  10. #10
    Senior Member Ramairgod84's Avatar
    Join Date
    Aug 2008
    Location
    peoria, az
    Posts
    1,017

    Black
    2001 WS6

    ive got a bad squeak comin from my rear. It started after the accident. I'm hoping its a shock or spring or lca...hopefully it'll be gone after replacing all that stuff

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •