Results 1 to 8 of 8

Whats with this? Electrical?

This is a discussion on Whats with this? Electrical? within the General Help forums, part of the LSx Technical Help Section category; Sorry in advance if this is posted somewhere, the search function isn't working. I'll break this down simple and easy. ...

  1. #1
    I need it for fiber! Y2KBird's Avatar
    Join Date
    Dec 2005
    Location
    Tri-Cities, Washington
    Age
    37
    Posts
    131

    Navy Blue
    2000 Firebird

    Whats with this? Electrical?

    Sorry in advance if this is posted somewhere, the search function isn't working.

    I'll break this down simple and easy.

    Last night I attempted to start my '00 Friebird. The domelights, dashlights all came on, as soon as I turned the ignition, everything went dead. No lights no nothing. After a couple turns, everything started up fine.

    Tonight, It started until I flipped the headlights and everything died again. Restarted, everything was fine.

    I later stopped, shut everything off, turned the key and nothing. no dome light, no radio, no nothing, like the battery wasnt there. The speedo and tach guages shot all the way up and were twitching even though I had no power and the motor wasnt running.

    I did notice a ticking sound coming from the left front (under the headlight). There is NO ticking inside the car. As soon as the ticking stopped, everything came back on.


    BCM maybe?
    Last night is the first time it started and it seems to be getting bad quickly.

    Any suggestions would be awesome or throw me a link. Search is making me very very angry at the moment.

    Thanks
    Last edited by Y2KBird; 10-02-2007 at 01:48 AM.

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Check your battery terminals, make sure there good and tight and clean.
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Member 89LX's Avatar
    Join Date
    May 2006
    Location
    East Coast North Carolina
    Posts
    429

    Navy
    2000 Z28 M6

    Battery

    +1 on battery.

  4. #4
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    +2 on battery/connections

  5. #5
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    check your battery, also, is it the sound of relays clicking? when the ecm died in my moms truck all the relays were clicking on and off. it would not be yor bcm

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    Quote Originally Posted by sunsetorangess View Post
    Check your battery terminals, make sure there good and tight and clean.
    J
    +3

  7. #7
    I need it for fiber! Y2KBird's Avatar
    Join Date
    Dec 2005
    Location
    Tri-Cities, Washington
    Age
    37
    Posts
    131

    Navy Blue
    2000 Firebird

    Silly enough, I checked out the battery, everything was squeaky clean. The positive side post was a hair, I mean just a hair loose. I thightened it by just that hair and PRESTO!!

    Started it up several times with no issues. Hopefully that was all it was. Thanks for your help. I'll let you guys know if it does anything else weird.

    Thanks again

  8. #8
    Member jamessr's Avatar
    Join Date
    Jan 2007
    Location
    Newport News, VA
    Posts
    266

    White
    2000 Trans AM

    Its funny how that pfm shit works. I bought a 90 Firebird cheap due to a "wicked electrical problem"
    All it was the lead going to the altenator was hanging by 1 strand and sparking thus draining the battery over night.
    Weird shit huh? Glade your issue is fixed

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help Electrical...
    By ra84y in forum General Help
    Replies: 22
    Last Post: 07-19-2010, 07:36 PM
  2. ATV Electrical help!
    By ssgtcarroll in forum Almost Anything Goes
    Replies: 4
    Last Post: 06-05-2009, 03:22 AM
  3. electrical?
    By stangnightmare in forum General Help
    Replies: 7
    Last Post: 03-05-2007, 01:58 PM
  4. Electrical HELP!!! PLEASE
    By TimC in forum General Help
    Replies: 0
    Last Post: 05-26-2006, 09:39 AM
  5. Electrical Help
    By dlcully in forum General Help
    Replies: 4
    Last Post: 05-02-2006, 12:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •