Results 1 to 4 of 4

What rpm does your 99 trans am idle when cold and warmed up?

This is a discussion on What rpm does your 99 trans am idle when cold and warmed up? within the General Help forums, part of the LSx Technical Help Section category; need to know at what rpm does your 99 or newer trans am idle.Reason why I am asking is because ...

  1. #1
    Member
    Join Date
    Oct 2005
    Location
    Vicksburg. Ms.
    Posts
    433

    pewter
    99 Trans Am

    What rpm does your 99 trans am idle when cold and warmed up?

    need to know at what rpm does your 99 or newer trans am idle.Reason why I am asking is because I posted some time ago about my 99 trans being taken to a dealer and they installed a new pcm, they said,but the car have not ran right since.I checked the IAC valve was getting votage so I installed a new one but the car still will not idle right, it will start out at about 600 rpms an start going up to about 2000 or higher if I don't shut it off, in order to drive the car I have unplugged the IAC valve and idle the car by hand . I know this is not to be done, but I can't fine anyone in town that can fix it.some say it's in the pcm others just don't know.My car was in the shop two weeks and the dealer installed the pcm because they said that my alternator shorted it out.is there some way or where I can have this pcm checked?The car run great before I took it to them just wouldn't charge even after I installed a new alternator.I have done all I can to find broken or leaking air lines but can't fine any.
    Last edited by Street Fighter; 02-26-2016 at 03:03 AM.

  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Usually for:

    M6: 700-900
    A4: 900-1200

    Any codes popping up?

    You need to check the thin wire that comes off the alternator. Somethings they break or the connector get's damage when the alternator is dropped (removed). This thin wire talks to the ecm to let it know that the alternator is charging. It's very possible that the the wire is shorting out.

    Not saying this is it but a possibility: If the ecm detects a charge not quite enough into the charging perimeters, it will go into limp mode. Limp mode is when the ecm will ramp up the rpms to 2500-3000 rpms in an attempt to charge the battery.

    Had this happen to mine, that is why I know about this.

  3. #3
    Member
    Join Date
    Oct 2005
    Location
    Vicksburg. Ms.
    Posts
    433

    pewter
    99 Trans Am

    I replaced the alternator and it charges, it shows a little over 14 volts but I still have this idling problem. I have checked the voltage at the iac valve and it shows good but, I still have no idle. How do a
    engine act if the mass airflow is bad? I did break the red wire on the alternator did not know it was there until I mounted it and there was no charge. repaired it and all seems well with the charging, or could it be that there is still something going on with it? like I said new iac valve and it still does the same thing.The only code I have popping up is one telling me that the mass airflow is out of adjustment and that's due to me manually adjusting it.

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Have you cleaned it recently?

    If MAF is bad it will throw a code. It either works or it doesn't. If it get's dirty they don't necessary throw a code. Use MAF cleaner, I did mine every 2 months when I had a MAF.


    How did you manually adjust the maf?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cold idle problems
    By WHITE TA in forum General Help
    Replies: 8
    Last Post: 02-18-2012, 07:57 PM
  2. Question: Low Idle when cold
    By jfl330 in forum Computer & Tuning
    Replies: 0
    Last Post: 04-08-2011, 05:53 AM
  3. low idle when cold
    By northslider in forum General Help
    Replies: 2
    Last Post: 01-16-2010, 10:58 PM
  4. Cold idle tick?
    By WS6ICK2K in forum General Help
    Replies: 7
    Last Post: 04-09-2008, 05:38 AM
  5. Rough Idle When Cold
    By mdezie06 in forum General Help
    Replies: 9
    Last Post: 12-07-2005, 07:41 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •