Results 1 to 16 of 16

What the hey!!!!!

This is a discussion on What the hey!!!!! within the General Help forums, part of the LSx Technical Help Section category; What is the deal with these sun visors? They break for no reason. I'm going on my fourth visor now ...

  1. #1
    Junior Member
    Join Date
    Jun 2006
    Location
    Las Vegas, NV
    Posts
    4

    Red
    2000 Formula

    Angry What the hey!!!!!

    What is the deal with these sun visors? They break for no reason. I'm going on my fourth visor now at $50.00 a pop. You can't tell when it's broken until it falls in your lap while you're doing a leisurely 80+ in traffic.

  2. #2
    Junior Member
    Join Date
    Jun 2006
    Location
    Las Vegas, NV
    Posts
    4

    Red
    2000 Formula

    The sun visors are breaking for no reason.

  3. #3
    Junior Member
    Join Date
    Jun 2006
    Location
    Las Vegas, NV
    Posts
    4

    Red
    2000 Formula

    Take a look at your visor. On the other side of the mount, there's a post, and spring that's held in place with a washer. The end of the post is flared open like a copper tube. Thats where it's breaking. There's no way to fix it because the parts will fall inside the fender. I'm not the only one with this problem. My co-worker has the same problem with his SS Camaro. Maybe it's the Vegas heat.

  4. #4
    Impounded YoMommasTA's Avatar
    Join Date
    Jan 2006
    Location
    ne pa
    Posts
    532
    very easy to fix,1st thing i did when i bought mine was put a flat washer and screw in the end.

  5. #5
    Senior Member 02z28ls1's Avatar
    Join Date
    Sep 2005
    Location
    near St. Louis
    Posts
    1,205

    navy blue
    2002 Z-28 Camaro M6

    I've never had one break or saw one that was broken around here-could be a hot climate thing. Somebody post pics?

  6. #6
    Senior Member 02z28ls1's Avatar
    Join Date
    Sep 2005
    Location
    near St. Louis
    Posts
    1,205

    navy blue
    2002 Z-28 Camaro M6

    There's also the door panel cracking thing that I've never seen around here but some people claim is common place on F-bodies. I'm guessing this is one of those things.

  7. #7
    Member DragonsPhyre's Avatar
    Join Date
    Sep 2005
    Location
    Yuma, AZ
    Age
    46
    Posts
    178

    Black
    2000 Firebird Formula WS6

    happened to me too. I would come up with a way to fix it permanantly and post the steps here. It seems to be a problem that is not uncommon.

  8. #8
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    68
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    Quote Originally Posted by YoMommasTA View Post
    very easy to fix,1st thing i did when i bought mine was put a flat washer and screw in the end.

  9. #9
    TMF
    TMF is offline
    MY SON'S A RICER! TMF's Avatar
    Join Date
    Aug 2005
    Location
    Colorado
    Age
    56
    Posts
    1,125

    Arctic White
    2000 TransAm

    Quote Originally Posted by YoMommasTA View Post
    very easy to fix,1st thing i did when i bought mine was put a flat washer and screw in the end.
    I'm gonna try that tonight, mine broke on the way in and I dont think I've ever even used it. WTF
    2000TA, ARCTIC WHITE, 6 SPD
    ALL THE USUAL STUFF
    A MILE HIGH & A SECOND SLOWER

  10. #10
    Out in the garage...
    Join Date
    Aug 2005
    Location
    Lakeland, FL
    Age
    38
    Posts
    77

    Sebring Silver
    2000 Camaro SS (R.I.P.)

    Both of mine fell off. I never used them so they're sitting in the workshop now.

  11. #11
    TMF
    TMF is offline
    MY SON'S A RICER! TMF's Avatar
    Join Date
    Aug 2005
    Location
    Colorado
    Age
    56
    Posts
    1,125

    Arctic White
    2000 TransAm

    It looks like the post is either aluminum, or pot metal and the flare just wore off, but I never even use the passenger side and no one is ever in that seat, I just dont get it ? what a POS!

  12. #12
    Senior Member 440 rwhp trans am's Avatar
    Join Date
    Jun 2006
    Location
    houston, tx
    Age
    32
    Posts
    2,045

    red ta orange gto
    97 trans am 06 gto

    i have never heard of this. and its not the heat. it gets really hot here in houston

  13. #13
    TMF
    TMF is offline
    MY SON'S A RICER! TMF's Avatar
    Join Date
    Aug 2005
    Location
    Colorado
    Age
    56
    Posts
    1,125

    Arctic White
    2000 TransAm

    It's not the heat, it's just shit metal

  14. #14
    TMF
    TMF is offline
    MY SON'S A RICER! TMF's Avatar
    Join Date
    Aug 2005
    Location
    Colorado
    Age
    56
    Posts
    1,125

    Arctic White
    2000 TransAm

    Fixed it with a flat washer, lock washer and sheet metal screw. Good as new and fully functional. No need to buy a new one. I think the problem is too much spring tension wears off the flare.

  15. #15
    Junior Member
    Join Date
    Jun 2006
    Location
    Las Vegas, NV
    Posts
    4

    Red
    2000 Formula

    Cool. I'll try that this week. I can't beleive the dealer wanted $100.00 for that! Thanks TMF!!

  16. #16
    My other car is a cop car
    Join Date
    Aug 2006
    Location
    Texas
    Posts
    11

    White
    1998 T/A

    dealers suck wind. They are three times as high as anyone else, try ebay

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •