Results 1 to 12 of 12

weird steering problems......solutions?

This is a discussion on weird steering problems......solutions? within the General Help forums, part of the LSx Technical Help Section category; ok, the ss has been having some rly weird steering problems. i have subframe connectors and a strut tower brace ...

  1. #1
    Member
    Join Date
    Jun 2008
    Location
    ohio
    Posts
    393

    black
    1998 Camaro SS

    weird steering problems......solutions?

    ok, the ss has been having some rly weird steering problems. i have subframe connectors and a strut tower brace installed. i had to put a new tie rod end on last summer so i still have to get it aligned but whats weird is that the steering wheel just started shaking back in forth while i drive and sometimes the car drifts to the right and sometimes it drifts to the left. im thinking theres something else wrong with it other than just needing aligned. i know nothing about steering compononents really so any help is great. Thanks

  2. #2
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    it sounds normal to me for a car needing an alignment personally..i would get an alignment first and see if it fixes the problem before we even address a "possible" problem

  3. #3
    Member
    Join Date
    Nov 2009
    Location
    Norfolk, Nebraska
    Posts
    124
    2002 Camaro Z28

    Sounds like a bad tire. At what speeds does it start?

  4. #4
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Rotate your tires see if it goes away. If it does then I'd say bad tire. Usually it's wise to replace tierod ends in pairs of 2, for best results replacing them all is proper imho but I know not eveyone has the cash to do so.. Usually when a tire wears from poor alignment the effected tire/s will still continue to wear unevenly even WITH an alignment.
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  5. #5
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Just tossing this out there.....wheel bearings? I had one go out on a DD long time ago and it shook the hell out of my steering wheel.

  6. #6
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Thumbs up

    Quote Originally Posted by SMWS6TA View Post
    Just tossing this out there.....wheel bearings? I had one go out on a DD long time ago and it shook the hell out of my steering wheel.
    Yes, this too..

  7. #7
    Member jb3golf's Avatar
    Join Date
    Jan 2007
    Location
    Zona
    Posts
    600

    Red
    1998 Camaro Z28 Conv. M6

    Quote Originally Posted by jmatt07 View Post
    ok, the ss has been having some rly weird steering problems. i have subframe connectors and a strut tower brace installed. i had to put a new tie rod end on last summer so i still have to get it aligned but whats weird is that the steering wheel just started shaking back in forth while i drive and sometimes the car drifts to the right and sometimes it drifts to the left. im thinking theres something else wrong with it other than just needing aligned. i know nothing about steering compononents really so any help is great. Thanks
    OK EASY FIX HERE: YOU NEED AN ALIGNMENT ASAP!!!! Have you gotten one yet??? If not your totally WEARING OUT your tires!!!!! Your symptoms are EXACTLY what my car did after I installed new tie rods, rotors and sway bar......as soon as I got an alignment, it drove like a dream. DO IT ASAP......

  8. #8
    Member jb3golf's Avatar
    Join Date
    Jan 2007
    Location
    Zona
    Posts
    600

    Red
    1998 Camaro Z28 Conv. M6

    I'm willing to bet your computer angle numbers will be WAY OFF!! Mine weren't even within the applicable range..........

  9. #9
    Member importhater81's Avatar
    Join Date
    Oct 2009
    Location
    chicagoland,Il
    Age
    36
    Posts
    333

    black
    02 ss camaro

    Sounds like a belt separation in one of the front tires....rotate to the back and if it goes away replace suspect tire asap....Alignment issues don't go back and forth between pulling to one side then the other

  10. #10
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    The wandering could be a toe issue requiring an alignment. Shaking could be from a shifted belt on a tire or out of balance tires.

  11. #11
    the cake is a lie twozs's Avatar
    Join Date
    Sep 2005
    Location
    hopewell jct, ny
    Posts
    489

    black 01 red 73
    01 z28 and 73 z28

    i was wearing my left front tire pretty bad and the car was hopping in reverse when the wheel was full cut to the left. wandering on the groves bad too . i thought it was a bad tie rod end but 4 new skins.. and an alignment cleared it up. alignment guy said a lot of tow in the front left
    Last edited by twozs; 03-12-2010 at 09:39 PM.

  12. #12
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Yup. Too much positive/negative toe will cause wandering and irregular tire wear. When I aligned my car, the computer read -0.15 on the left front and the right front was spot-on. The steering wheel was at 10 and 4 when driven straight, but if the wheel was completely at 9 and 3 the car wanted to pull right. After the alignment all is good.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. weird electrical problems??
    By wsickk in forum Stereo and Electronics
    Replies: 4
    Last Post: 09-09-2010, 08:12 PM
  2. Common Code List - Problems and Solutions Here
    By Hi-Po in forum General Help
    Replies: 5
    Last Post: 01-26-2010, 10:12 AM
  3. weird power steering fluid leak...
    By Spaz in forum General Help
    Replies: 22
    Last Post: 07-02-2009, 02:24 AM
  4. Weird feeling in my steering
    By ichliebecamaro in forum General Help
    Replies: 2
    Last Post: 01-10-2008, 09:11 AM
  5. 3 Problems........3 Solutions.
    By FSANE in forum Almost Anything Goes
    Replies: 9
    Last Post: 01-30-2007, 09:18 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •