Page 4 of 5 FirstFirst 12345 LastLast
Results 61 to 80 of 96

Weird smell when I park the TA in the garage

This is a discussion on Weird smell when I park the TA in the garage within the General Help forums, part of the LSx Technical Help Section category; Yes I did. I don't see anything on the passenger side area. I guess I can do a piece of ...

  1. #61
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Yes I did. I don't see anything on the passenger side area. I guess I can do a piece of hose to isolate the heater hoses and try it out.

  2. #62
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    I checked the level of the radiator today. It was normal. The level in the reservoir was the same but I can see the fluid went up by looking at the dipstick. I haven't got the thermostat yet. Every one around here wants to sell me the whole assembly. I just want the Tsat. I have to cheack the GM dealer and see if they sell it separate.

  3. #63
    Member blackcar's Avatar
    Join Date
    Oct 2005
    Location
    Arkansas
    Posts
    1,234

    2000 Camaro SS
    '02 Z28 parting-out

    I've got the stock one from my wrecked Camaro. I sell the whole assembly for $20 including shipping.

  4. #64
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Jay - Rockauto sells just the T-stat for $6, with the housing $17

  5. #65
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    yeah i noticed they sell the tstat by itself. i might order one when i place the order for my shocks. Thanks.

  6. #66
    Junior Member psycho_puppies's Avatar
    Join Date
    Jul 2009
    Location
    New Mexico
    Posts
    64

    White
    2002 TA

    I had the same problem with my 02 Trans AM. I could smell it but no leaks could be found. It turned out it was the water pump gasket, it developed a small crack and allowed the fluid to escape so slow that that you could never see it. The fix cost me $12.00 and about 2 hours with of time.

  7. #67
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by psycho_puppies View Post
    I had the same problem with my 02 Trans AM. I could smell it but no leaks could be found. It turned out it was the water pump gasket, it developed a small crack and allowed the fluid to escape so slow that that you could never see it. The fix cost me $12.00 and about 2 hours with of time.
    I had bad gaskets before and I changed the pump for a new ones with new gaskets last year. I really don't see anything in that area but I will check after i shut the engine off. I could redo the gaskets again but I want to make sure is the issues before I satrt to pull stuff out. Thanks Psycho.

  8. #68
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    You might have to replace those gaskets if the smell is still persisting.

  9. #69
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by cammed goat View Post
    You might have to replace those gaskets if the smell is still persisting.
    Even if I don't see a leak? I haven't smell the anitfreeze in a while. the main issue is the level going down when I check it.

  10. #70
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Just to be safe, I would change them. Another thing, clean your engine with water to see if the smell goes away.

  11. #71
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    you mean degrease the engine? wash it? I have done it so maybe that's why it stopped smelling.

  12. #72
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Ah. Okay. You already did that.

  13. #73
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Try having a buddy rev the engine a little while you look for leaks and or steam from coolant being possibly flash burned my your headers/ exhaust manifolds.

    Could be comming out of your rad cap or over flow and slashing your headers/manis'.

    Hopefully it's not the engine burning it cause you know what that means..ugh

  14. #74
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    I hope is not the engine. i mean it hasnt overheated since I own it. It has a new radiator cap and same issue. I checked the reservoir and pulled it out. It was not cracked and the aluminum piece is intact. Does the reservoir cap has to seal tight? i don't think it need to be.

    I constantly check the engine oil dipstick and transmision dipstick. If it was mixing it i think i would noticed by now. this issue is going almost 2 months now. could it be burning it straight into the exhaust? It might sound stupid but what else could it be. I checked everywhere and unless is burning up that i can't see it. i pressurized the system and found a couple of leaks. i fixed those and the pressure was still dropping but no leak anywhere...

  15. #75
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    The rad cap HAS to seal tight. It is under constant pressure. I had to change mine because the original went caput, then I ordered a NAPA replacement, and it also allowed coolant to escape from the recovery tank. Sent that back and got a different one from NAPA and all is good.

  16. #76
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by cammed goat View Post
    The rad cap HAS to seal tight. It is under constant pressure. I had to change mine because the original went caput, then I ordered a NAPA replacement, and it also allowed coolant to escape from the recovery tank. Sent that back and got a different one from NAPA and all is good.
    I just got this cap new from the dealer like 3-4 weeks ago. I guess I can try another cap to compare. The gaskets look good and I cleaned the neck of the radiator.

  17. #77
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Now I'm wondering if the dealer is ordering the cap from an outside vendor other than GM direct.

  18. #78
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Even if it is OEM acdelco? I mean I bought brand new in the box.

  19. #79
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Maybe faulty. I would still check the entire engine bay or put the car on a lift to see if there is any wetness under the car somewhwere.

  20. #80
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    I will check again tomorrow. I think the I can get a pressure tester to test the cap. Or i might just get a cheap one. If it is the cap i'm going to be mad because I think i don't have the receipt no more. I kinda hate the cheap ones because they don't look like they are well constructed but who knows!

Page 4 of 5 FirstFirst 12345 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel smell in the garage
    By JayTA98 in forum General Help
    Replies: 25
    Last Post: 09-13-2013, 01:06 PM
  2. Weird smell under hood
    By nichoLaS1 in forum General Help
    Replies: 12
    Last Post: 03-09-2011, 12:04 PM
  3. I got some weird crap happening in my garage, I need your help.
    By fast droptop in forum Almost Anything Goes
    Replies: 14
    Last Post: 12-10-2007, 12:36 PM
  4. getting a gas smell out of the garage...
    By 0rion in forum General Help
    Replies: 9
    Last Post: 09-28-2007, 01:53 PM
  5. Replies: 1
    Last Post: 08-28-2006, 01:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •