Page 2 of 5 FirstFirst 12345 LastLast
Results 21 to 40 of 96

Weird smell when I park the TA in the garage

This is a discussion on Weird smell when I park the TA in the garage within the General Help forums, part of the LSx Technical Help Section category; Okay so I check the reservoir and radiator levels this morning and they were normal. As soon as I pulled ...

  1. #21
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Okay so I check the reservoir and radiator levels this morning and they were normal. As soon as I pulled out of my street the low coolant light came on. I stopped on the side and with the engine running I took the cap off. There was a little overflow (due to pressure I will think) but the radiator level was full. Everytime I turn park the car, let sit for a bit, then start the car and drive the low coolant light comes back on. Im starting to think that I might have a defective sensor. i know I have a leak but the light is coming on to quick and the radiator level is still full. I bought a brand new GM radiator cap. Im going to replace it once the engine cools down. I hope that takes cares of the issue. Tomorrow I will spend some time looking at the reservoir, cleaning the engine and start to look for possible leaks.

  2. #22
    Senior Member wileyCoyote's Avatar
    Join Date
    Oct 2005
    Location
    Centerville OH
    Posts
    1,591

    blue
    1999 TransAm

    could be evaporating ouf of the radiator cap, or the overflow reservoir cap...

  3. #23
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Quote Originally Posted by wileyCoyote View Post
    could be evaporating ouf of the radiator cap, or the overflow reservoir cap...
    ^^this

  4. #24
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    update. I changed the radiator cap with a new one and so far everytime I check the level when is cold is been normal. i will keep an eye this week to make sure its not leaking. You guys mentioned the reservoir cap. Does this cap has to be sealed? my main thing was that when I found the level was low in the radiator the level on the reservoir never went down, like it was not sucking from it. I might have to check the piece of tube that goes in the plastic reservoir tank and make sure is there and its not gone.

    The low coolant light is still on, so im suspecting a bad sensor. I unpluged it for now. I will pull it out and clean it.

  5. #25
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    just to add that I replaced both O2 sensors with bosch 13111's. The OEM ones were 115k and I wasn't proud of myself for that. Im sure Scott will be happy lol. I also upgrade my alternator to the AD244 (new) and had seen an improvement with my voltage at idle and with full load. Thanks to Sjsingle for the sticky.

  6. #26
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    ^^




    Jay hope the new cap fixes the issues.


    Did you make a thread on how to fix the gas cap? mine is giving me the evap code.

  7. #27
    Junior Member
    Join Date
    Jul 2007
    Location
    Vero Beach Florida
    Posts
    6

    Mystic Teal Blue
    2000 Z28 Convertible

    I had the same anitfreeze smell on my 00Z28, it had around 45k and it was the water pump. It was still under warranty, I also had the oil pump replaced around 15k miles.

  8. #28
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by SMWS6TA View Post
    ^^




    Jay hope the new cap fixes the issues.


    Did you make a thread on how to fix the gas cap? mine is giving me the evap code.
    I never had the evap code with any of my cars. The radiator level has been so far normal. I'm going to keep checking it but it looks like i had a bad radiator cap. I need to get a new low coolant sensor.

    Did you tried a new gas cap? Most people that get it the 1st thing they do is to replace the cap if it is old.

  9. #29
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    hope it's not rear gear fluid you smell...

  10. #30
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by Spaz View Post
    hope it's not rear gear fluid you smell...
    I was thinking the same but it really smelled like antifreeze. The gear oil leaks on the exhaust pipe (small leak) all the time so I think I will be smelling it everyday. The smell is once in a while. I will keep an eye on the rear as well to make sure it's full.

    I will update weekly but so far it's looks like it stopped leaking.

  11. #31
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    Quote Originally Posted by JayTA98 View Post
    I was thinking the same but it really smelled like antifreeze. The gear oil leaks on the exhaust pipe (small leak) all the time so I think I will be smelling it everyday. The smell is once in a while. I will keep an eye on the rear as well to make sure it's full.

    I will update weekly but so far it's looks like it stopped leaking.
    if you can get under the car check the input shaft on the pumpkin... sometimes the seals go and a little bit of rear fluid leaks out and the DS sligs it all over... it could get a few drops on the exhaust...

  12. #32
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by Spaz View Post
    if you can get under the car check the input shaft on the pumpkin... sometimes the seals go and a little bit of rear fluid leaks out and the DS sligs it all over... it could get a few drops on the exhaust...
    yeah i do have a leak in the rear end in that area.

  13. #33
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    update. the radiator was down some again today. The smell is back. Im not saying is related to my leak but I really smell it on the rear driver tire. no smell on the rear passenger or in the front tires. no smell in the engine bay area. I try to stick my head in the fender well and i can feel heat and the smell. I checked the exhaust and it has some rea end fluid burnt on it. I scraped some of it out but I doesn't smell like it. I checked the fuel cap and I can see some moisture in the area. i took the cap off and it smell like gasoline(of course) but the neck was wet. I got underneath the car and I can't get the same scent in the rear end area. I can smell it if i stick my head high like in the fuel tank area. I'm not sure if I'm smelling fuel vapors or i have a leak in the fuel pump gasket. I kinda running out of ideas besides besides getting a hound to sniff the scent and locate it for me.

    as far as the radiator leak i will have to pressurize the system and see if it leaks. Last option will be to get the dye and check with UV light.

  14. #34
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    I can't remember at the moment, but maybe there is a leaky gasket where the filler neck meets the tank?


    extreme dimensions, driveshaft shop, harrop, hid(35watt/6k) lows, hurst, k&n, led fogs, maverick man, mishimoto, nitto, revshift, slp, stern st-1, smoked sidemarkers, whiteline poly radius rod bushings

  15. #35
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by cammed goat View Post
    I can't remember at the moment, but maybe there is a leaky gasket where the filler neck meets the tank?
    I don't see any leaks there but I'm starting to think that my radiator might be the issue. I can't see any leaks any other place. What about the inner gasket seal inside the thermostat housing? If its leaking, could it cause the radiator level to go down?

  16. #36
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Quote Originally Posted by JayTA98 View Post
    I don't see any leaks there but I'm starting to think that my radiator might be the issue. I can't see any leaks any other place. What about the inner gasket seal inside the thermostat housing? If its leaking, could it cause the radiator level to go down?
    The thermo gasket could be twisted and causing a leak, or you could have a split in the side of the radiator that could cause a leak that is so small, it won't leave any puddles. When my radiator split, I didn't have any puddles on the ground. You could also have a water pump gasket leak and the coolant is burning off the block.

  17. #37
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by cammed goat View Post
    The thermo gasket could be twisted and causing a leak, or you could have a split in the side of the radiator that could cause a leak that is so small, it won't leave any puddles. When my radiator split, I didn't have any puddles on the ground. You could also have a water pump gasket leak and the coolant is burning off the block.
    I replaced the water pump with new leaks about 5 months ago because of that reason. Is kinda hard to tell if it leaking from there anymore but it looks clean. there issome stains but they look more oil type. I think i will get the dye and check with that to be sure.

    the thermo gasket, is the one inside the thermostat housing? the one around the thermostat itself?

  18. #38
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    The one around the thermostat itself. It could be tweaked a little and causing a leak.

  19. #39
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by cammed goat View Post
    The one around the thermostat itself. It could be tweaked a little and causing a leak.
    ok, but where is the coolant going to? and what about the coolant that I add? I might have to check the gasket to make sure.

  20. #40
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Quote Originally Posted by JayTA98 View Post
    ok, but where is the coolant going to? and what about the coolant that I add? I might have to check the gasket to make sure.
    Check the gasket first. I still think the coolant is being burned off somewhere.

Page 2 of 5 FirstFirst 12345 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel smell in the garage
    By JayTA98 in forum General Help
    Replies: 25
    Last Post: 09-13-2013, 01:06 PM
  2. Weird smell under hood
    By nichoLaS1 in forum General Help
    Replies: 12
    Last Post: 03-09-2011, 12:04 PM
  3. I got some weird crap happening in my garage, I need your help.
    By fast droptop in forum Almost Anything Goes
    Replies: 14
    Last Post: 12-10-2007, 12:36 PM
  4. getting a gas smell out of the garage...
    By 0rion in forum General Help
    Replies: 9
    Last Post: 09-28-2007, 01:53 PM
  5. Replies: 1
    Last Post: 08-28-2006, 01:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •