Results 1 to 13 of 13

Weird smell under hood

This is a discussion on Weird smell under hood within the General Help forums, part of the LSx Technical Help Section category; I have a very distinct smell coming from the indicated area in the below image.. About the best way to ...

  1. #1
    Member nichoLaS1's Avatar
    Join Date
    Jul 2010
    Location
    Charlotte
    Posts
    330

    Sunset Orange
    '01 SOM ws6

    Weird smell under hood

    I have a very distinct smell coming from the indicated area in the below image.. About the best way to describe it is that it smells like a burnt up motor, i.e. hot metal/burnt rubber, or if you were to burn up a small motor in a dremel for instance. I can smell it all the time (as of yesterday) so not only when I try to use my wipers or washer fluid etc. Any suggestions, or indication as to what components are in this area (up against the firewall between the brake fluid reservior and the fender).. i havent had much time to look at it since I dropped it off this morning to get 2 new tires, but I am trying to get an idea as to what it may be first.

    the only thing I could see looking at it quickly was some brake fliud along the firewall coming from the reservior when it was removed to replace the front shocks. Maybe its dripping on the exhaust?? i dunno if it would give off the smell though please help!!

    Last edited by nichoLaS1; 03-09-2011 at 10:22 AM.

  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    you will know if its brake fluid. All of the paint in that area would be gone. Brake Fluid is some nasty stuff. Never let it sit on paint or any part of your body. Only thing in that area is the break and clutch reservoirs. If you still have the Air Pump hooked up and working that will be the black hose running along the fender wall going back behind the reservoirs. If fluid has been puddle and is dripping on the headers then yes it will burn and smell.

    A pic of your engine would help.

  3. #3
    Member nichoLaS1's Avatar
    Join Date
    Jul 2010
    Location
    Charlotte
    Posts
    330

    Sunset Orange
    '01 SOM ws6

    yeah the air pump hose is still there. I'm thinking it may have to do with the clutch/ clutch fluid since the smell is strongest near the clutch reservior but am not sure what exactly it could be causing it there. I noticed it after doing a very small burnout yesterday, which makes me think clutch. I'll try to snap a pic of the engine bay tonight when I get home from work

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Have you ever flushed the DOT III Break Fluid in your clutch? If it is still the same fluid since it came from the factory then you are long over due for a change of fluid.

  5. #5
    Member nichoLaS1's Avatar
    Join Date
    Jul 2010
    Location
    Charlotte
    Posts
    330

    Sunset Orange
    '01 SOM ws6

    It should be be new fluid.. The clutch was replaced around 45k miles (before I got the car) it now has 61k

  6. #6
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Is the smell problem just recently or has it been since the clutch was replaced?


    i had a nightmare senerio last summer. I took my car to a Nation wide shop (Midas) to bleed my clutch while I was at work. I normally would have done this myself but needed it done and didn't have the time off to do it. I find out later that a dumbass put in ATF instead of DOT III Break Fluid like the cap tells you. It cost me a lot of $$$ at first. I had to replace the Master and Slave and the Hydraulic hose that connects the two. I went round and round with the shop manager, raised holly hell in the lobby in front of customers too. Got the Nation HQ involved. Shop mgr ended up paying for the parts. He wanted to do the labor but told him do you honestly expect me to let you touch my car again

    Now to tell if you have this screw up is real simple. The rubber boot will expand and will not fit in the reservoir besides have shifting problems.

  7. #7
    Member nichoLaS1's Avatar
    Join Date
    Jul 2010
    Location
    Charlotte
    Posts
    330

    Sunset Orange
    '01 SOM ws6

    Car shifts fine and clutch engages/disengages fine so I think (pray) that the fluid is correct.. I just noticed the smell yesterday after spinning the tires for approx 2 sec and pulling in aparking lot. It smelled strongly in the car and then when I got out I could still smell it and narrowed it down to the reservoir area. Sill smells today, maybe not quite as strong but defintiely still there.

  8. #8
    Senior Member 2001camaroSS's Avatar
    Join Date
    Feb 2010
    Location
    Greenwood, IN
    Posts
    3,508

    Light Pewter Metallic
    2001 Camaro SS

    Quote Originally Posted by nichoLaS1 View Post
    Car shifts fine and clutch engages/disengages fine so I think (pray) that the fluid is correct.. I just noticed the smell yesterday after spinning the tires for approx 2 sec and pulling in aparking lot. It smelled strongly in the car and then when I got out I could still smell it and narrowed it down to the reservoir area. Sill smells today, maybe not quite as strong but defintiely still there.
    are u sure you didnt just burn up the clutch a little bit? my buddy did this and it smelt pretty strongly for a couple days.

  9. #9
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Quote Originally Posted by 2001camaroSS View Post
    are u sure you didnt just burn up the clutch a little bit? my buddy did this and it smelt pretty strongly for a couple days.
    most likely this

  10. #10
    Member nichoLaS1's Avatar
    Join Date
    Jul 2010
    Location
    Charlotte
    Posts
    330

    Sunset Orange
    '01 SOM ws6

    Quote Originally Posted by 2001camaroSS View Post
    are u sure you didnt just burn up the clutch a little bit? my buddy did this and it smelt pretty strongly for a couple days.
    theres a good chance i did, it grabbed pretty hard after spinning.. I just didnt think it would linger for a couple days. but if you say your buddys did for a few days, I'll take your word on it. As long at its nothing electrical, which my intial concern, I'm ok with alittle burnt clutch

  11. #11
    Senior Member 2001camaroSS's Avatar
    Join Date
    Feb 2010
    Location
    Greenwood, IN
    Posts
    3,508

    Light Pewter Metallic
    2001 Camaro SS

    Odds are that is the culprit. The smell is pretty distinctive. I'd say you are fine just check your fluid. If its still there in a couple days you may have a problem but I highly doubt it.

  12. #12
    She-Member jrbonds's Avatar
    Join Date
    Mar 2006
    Location
    Central OK
    Posts
    782

    2002 WS6
    1965 Mustang

    After I left the track, I smelled burnt clutch for days and days. So a quick burnout is probably the culprit and that smell to me is horrible.

  13. #13
    Member nichoLaS1's Avatar
    Join Date
    Jul 2010
    Location
    Charlotte
    Posts
    330

    Sunset Orange
    '01 SOM ws6

    Quote Originally Posted by jrbonds View Post
    After I left the track, I smelled burnt clutch for days and days. So a quick burnout is probably the culprit and that smell to me is horrible.
    Its a pretty distinct smell. Like I said, def like something buring: plastic, metal etc. Hopefully just the clutch, but I'll keep an eye (nose?) on it over the next few days..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Weird smell when I park the TA in the garage
    By JayTA98 in forum General Help
    Replies: 95
    Last Post: 07-11-2012, 07:58 AM
  2. I smell gas
    By northslider in forum General Help
    Replies: 17
    Last Post: 01-28-2010, 05:18 PM
  3. Getting rid of gas smell?
    By MagicMan in forum Almost Anything Goes
    Replies: 12
    Last Post: 05-28-2008, 04:42 AM
  4. Gas smell
    By Chad97z in forum LT1
    Replies: 27
    Last Post: 03-12-2008, 08:16 PM
  5. Gas Smell
    By Rare99Firehawk in forum General Help
    Replies: 7
    Last Post: 10-01-2007, 05:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •