Results 1 to 6 of 6

weird radio turning off

This is a discussion on weird radio turning off within the General Help forums, part of the LSx Technical Help Section category; I cant remember when it all started. But i took my car to best buy to get a cd player ...

  1. #1
    Member
    Join Date
    Sep 2006
    Location
    ohio
    Posts
    213
    98 Z28 M6

    weird radio turning off

    I cant remember when it all started. But i took my car to best buy to get a cd player put in. come to find out with the monsoon its not that simple for them to do. so i say ok and they put the stock one back it. then when im putting my LTs and ORY on my friend sets off the alarm and unplugs the bat which cause the radio to lock. i got it unlocked and since those 2 things it will randomly turn off and i cant roll down my windows. ill press unlock and it will turn on and stay on then sometimes it will turn on and off again real quick and will keep doing that. My security light will blink as if the car is not even on. any idea with might be causing this? could it be that best buy didnt put the radio back in right and i should check all the connections? I wasnt sure what section for this to go in. if it needs to be moved to the radio section please move it. Any ideas of what might be causing this would be great it is really starting to piss me off.

  2. #2
    Senior Member 35thAnniZ28's Avatar
    Join Date
    Mar 2007
    Location
    Texas
    Posts
    1,809

    eating bulldog
    son of biscuit

    check the fuses

  3. #3
    Member
    Join Date
    Sep 2006
    Location
    ohio
    Posts
    213
    98 Z28 M6

    ill do that but if a fuse was out i thought it would cause the radio to not work at all... ill still check it out though. Thanks for the idea and any other input?

  4. #4
    Senior Member 35thAnniZ28's Avatar
    Join Date
    Mar 2007
    Location
    Texas
    Posts
    1,809

    eating bulldog
    son of biscuit

    i remember when i had my alero...i was at the border of mexico...i beeped at this stupid cavalier who never hurried up....n the beeped never stopped...ended up being a stupid fuse....well hehe sorry for the story..but start off little and work your way up to electrical connections touching ground..lil shit like that

  5. #5
    Member Since 1998 Mecinoid's Avatar
    Join Date
    May 2007
    Location
    Livermore, Ca.
    Posts
    498
    '98,'00 Bird '03, 14 Vets

    Low battery / Battery going bad has cause me a little problem. Make sure you battery is new / newer and has a strong charge on it. If my car sits for a couple of weeks. I have to drive it for 5-10mins before the dash lights & head lights stops dimming/while hitting the brakes and the radio volume control responds correctly. It's just that the deep charge has gone a little weak for my car and it takes a few minutes at road speed to get everything back to a good state.

  6. #6
    Member
    Join Date
    Sep 2006
    Location
    ohio
    Posts
    213
    98 Z28 M6

    Nope not a fuse. Ater looking on ls1tech it seems the BCM needs replaces...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Weird noise when turning
    By flybird in forum General Help
    Replies: 12
    Last Post: 05-24-2012, 06:56 PM
  2. turning .avi into a .jpg
    By NE98LS1 in forum Almost Anything Goes
    Replies: 0
    Last Post: 05-07-2010, 03:42 PM
  3. Turning off T/C on a '95 z28
    By manarth5103 in forum Camaro / SS
    Replies: 2
    Last Post: 04-10-2010, 06:14 PM
  4. turning 30
    By chuck4345 in forum Almost Anything Goes
    Replies: 40
    Last Post: 10-03-2008, 06:58 AM
  5. Weird Radio display...
    By chad3113 in forum Stereo and Electronics
    Replies: 3
    Last Post: 07-04-2007, 09:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •