Results 1 to 2 of 2

weird hesitation.please advise

This is a discussion on weird hesitation.please advise within the General Help forums, part of the LSx Technical Help Section category; hello.i have a 2000 ws6 a4 with a built motor.i have had the car about 3 weeks now and i ...

  1. #1
    Member Leeroyws6's Avatar
    Join Date
    Feb 2010
    fort worth

    2000 trans am ws6 a4

    weird hesitation.please advise

    hello.i have a 2000 ws6 a4 with a built motor.i have had the car about 3 weeks now and i havent put 1500 miles onit yet.i did a mobile one oil change and changed the fuel filter but since then,it seems to have a weird hesitation.seems to be very obvious right before my transmission shifts gears.but if i blip the throttle a few times,it usually clears up.did it to me pretty good tonight.i know my fule filter isnt leaking,i sprayed for vaccuum leaks today.i couldnt find any.i fixed the vaccuum line connecting my 2 pvc hoses on the back side of the intake.and also i took my maf off to clean it and noticed the screen had a bad spot in it like someone got it with a screwdriver or going to check fuel pressure when i get a guage and hose.but do you think it could be the maf?i got a high voltage reading on my map sensor according to the ses light.could that be it?i thinki it might be a fule prump problem.
    here is a list of mods
    wild cam(unknown specs)
    241 heads ported
    slp lid
    kooks LTs
    borla ory and cat back
    ls6 intake
    z06 fuel injectors(supposedly)someone help me with this^^^
    tb bypass,
    aftermarket tranny cooler,
    built tranny
    this thing runs hard,but has a weird hesitation that seems to clear up when the throttle is played with.please feel free to chime in.thanks

  2. #2
    Member bobbyd's Avatar
    Join Date
    Apr 2008
    try this when the car is warmed up disconnect the sensor going to the maf and drive and see if it drives better. if it does then its your maf.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. little weird
    By 74batmobile in forum General Help
    Replies: 7
    Last Post: 02-26-2008, 04:29 PM
  2. Weird sound in rear?
    By 01ws6er in forum Drivetrain
    Replies: 15
    Last Post: 12-09-2007, 06:46 PM
  3. Weird noise
    By 2fast2blegal in forum General Help
    Replies: 14
    Last Post: 08-29-2007, 12:52 PM
  4. weird.. stuck in fourth gear???
    By DW2000TA in forum Manual Transmission
    Replies: 2
    Last Post: 06-14-2007, 04:08 PM
  5. weird grinding
    By noriceinside in forum Manual Transmission
    Replies: 10
    Last Post: 03-01-2006, 04:21 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts