Page 1 of 3 123 LastLast
Results 1 to 20 of 51

Weird Electrical Problem...need Help.

This is a discussion on Weird Electrical Problem...need Help. within the General Help forums, part of the LSx Technical Help Section category; Electrical experts, this one's for you... I have a 2000 Z28 and just recently it started doing something weird; I ...

  1. #1
    Loudmouth!! seasponge's Avatar
    Join Date
    Nov 2005
    Location
    Hanford
    Age
    46
    Posts
    123

    Black
    2000 Z28

    Weird Electrical Problem...need Help.

    Electrical experts, this one's for you... I have a 2000 Z28 and just recently it started doing something weird; I must point out that all electrical equipment works just fine. A couple of instances this happens are as follow:

    Sometimes while driving, the stereo turns off on its own and at the same time, both windows will not lower or raise. If I wait about 2-3 minutes, the stereo will come back on and I can then lower or raise the windows.

    Another time this happens is when I stop the car, turn of the engine but turn on my ACC to listen to the stereo while pumping gas for example; as soon as I open the door, the stereo will turn off and the windows won't work; sometimes I can open the door, close it and everything will keep working fine but as soon as I open the door again, the stereo and windows won't work.

    I don't have a clue what this could be; its not a fuse obviously, maybe a relay? Thanks for your help in advance!
    Camaro Z28/SS...40+ years of mustang humiliation.
    View my garage: http://www.fquick.com/Y2KBlackZ28

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    sounds like maybe a bad ground or short somewhere. Where you ask?? I have no idea.

  3. #3
    Loudmouth!! seasponge's Avatar
    Join Date
    Nov 2005
    Location
    Hanford
    Age
    46
    Posts
    123

    Black
    2000 Z28

    Exactly!...where!...if it is a short...

  4. #4
    Member ultra_badass's Avatar
    Join Date
    Mar 2007
    Location
    Corpus Christi
    Posts
    257

    navy blue matallic
    2000 WS6 trans am M6

    could be the ignition switch going out...had it happen on my other car

  5. #5
    Loudmouth!! seasponge's Avatar
    Join Date
    Nov 2005
    Location
    Hanford
    Age
    46
    Posts
    123

    Black
    2000 Z28

    You think so?...I don't know....how would the ignition switch cause a power block to the stereo and windows?

  6. #6
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,328

    BLACK
    Z/28 LS1

    Well I am not positive BUT the ign switch does control power to radio/windows etc. when the car isnt started and you turn the key slightly.

  7. #7
    Loudmouth!! seasponge's Avatar
    Join Date
    Nov 2005
    Location
    Hanford
    Age
    46
    Posts
    123

    Black
    2000 Z28

    Well, I know it controls the power for ign and acc. The weird thing is that it only happens every once in a while while driving but almost all the time if I park, put it on acc then open the door...the stereo turns off then the windows won't work...but then once I start and wait about 2 minutes, it works again...

  8. #8
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,328

    BLACK
    Z/28 LS1

    That is weird- I thought my radio was fked up because it would turn itself up. Come to find out it does that if there is road noise. LOL

  9. #9
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    I would say its your ingnition switch, the contaccts may not be fully catching, that would explain the intermitant problems and the loss of the acessories. Esspecially, then shutting off when you put the key in the ACC position. THe computer isn't catching the key position so when you open the door your still on the prigramed courtisy power that is on after yu shut the car off.

  10. #10
    Loudmouth!! seasponge's Avatar
    Join Date
    Nov 2005
    Location
    Hanford
    Age
    46
    Posts
    123

    Black
    2000 Z28

    Interesting... Any idea how much a new ign switch will run me? And is it easy to install? Thanks.

  11. #11
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    I really dont know how much or how hard, I haven't even seem one off a F-body yet. But if theya re like the earlier ones the actual switch might be at the bottom of the columb under the dash and is operated bya rod and cam set from the key switch.

  12. #12
    Junior Member
    Join Date
    Sep 2007
    Location
    belton Mo.
    Posts
    2

    pewter gray
    1999 Cheverolet Z28

    Probably is the body control module. Roofer

  13. #13
    Loudmouth!! seasponge's Avatar
    Join Date
    Nov 2005
    Location
    Hanford
    Age
    46
    Posts
    123

    Black
    2000 Z28

    Roofer,
    The body control module? Where is that at and how would that cause the problem?

    Thanks in advance.

  14. #14
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    The body controle module or BCM is what the ECM has evolved to, nearl;y every thing now runs through the BCM. If it wer that there would be other problems and its expensive to replace, I would start with the simple stuff first like the ignition switch and any connectors first before going that route.

  15. #15
    Loudmouth!! seasponge's Avatar
    Join Date
    Nov 2005
    Location
    Hanford
    Age
    46
    Posts
    123

    Black
    2000 Z28

    Thanks Orcus79. I've heard the ignition switch a few times...although, I'm confused as to how it would do that intermittently since my car has no problem starting at all. I don't think its a connection issue because I'm guessing that if I hit bumps, it would cut off but never. I can be on the smoothest road and all the sudden it will happen.

  16. #16
    Junior Member
    Join Date
    Mar 2007
    Location
    Northern Colorado
    Posts
    69

    Black
    1999 Z28

    I'm having the same problem, sort of.

    I'll start my car and the windows and stereo will work for literally a second and then they have no power. I found that if I roll down the window in that second time period that they have power, everything will work fine for a few days.

    My security light is also staying on intermittently now too.

  17. #17
    Member
    Join Date
    Aug 2005
    Location
    Virgina
    Posts
    224

    Black
    98 Trans Am

    Same problem here. Whats also got me baffled about it, is that when it does it at night when the dash lights are on...just the sound and channel display on the radio goes out (along with the windows), the buttons and stuff stay lit up....drives me crazy!! No problem with the security light though.
    Last edited by IronBird; 09-21-2007 at 10:44 AM. Reason: more info

  18. #18
    Junior Member
    Join Date
    Mar 2007
    Location
    Northern Colorado
    Posts
    69

    Black
    1999 Z28

    Well sweet, we all have the same problem. Somebody swap out their ignition switch and let us know if it solves the problem. We won't pay you for your trouble but you'll have the satisfaction of knowing you helped.

  19. #19
    Loudmouth!! seasponge's Avatar
    Join Date
    Nov 2005
    Location
    Hanford
    Age
    46
    Posts
    123

    Black
    2000 Z28

    Well, I'm going to order the ign switch and try it out. $12 won't kill me but I do have to say...now that the temperatures are dropping, 2 days have gone without my stereo or windows acting up....hmm...BUT, it can't be that...has to be something else so I'll start with the ign switch then move on..I'll report the outcome.

  20. #20
    Member jimmy77611's Avatar
    Join Date
    Feb 2007
    Location
    Here
    Age
    41
    Posts
    156

    Red
    2000 Z28

    I think it has something to do with the RAP system. That is the system that allows the radio and windows to continue to work after you turn the car off until you open the door. I think there is a RAP relay. Maybe it's going out. Just a thought, since the things affected just so happen to be the same things tied into the RAP circuit.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Weird Engine/Electrical Problem
    By Shudson105 in forum General Help
    Replies: 10
    Last Post: 06-05-2012, 03:34 PM
  2. weird electrical problem (must be a chevy thing)
    By camaroluvr447 in forum General Help
    Replies: 8
    Last Post: 06-02-2010, 09:59 AM
  3. Weird electrical problem
    By silplu83 in forum General Help
    Replies: 5
    Last Post: 08-31-2008, 11:31 AM
  4. Weird Electrical problem
    By richard head in forum General Help
    Replies: 4
    Last Post: 11-17-2007, 06:51 PM
  5. Weird Electrical problem
    By richard head in forum Stereo and Electronics
    Replies: 0
    Last Post: 11-16-2007, 01:24 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •