Results 1 to 5 of 5

Weird Electrical problem

This is a discussion on Weird Electrical problem within the General Help forums, part of the LSx Technical Help Section category; Few days ago I was redoing my cutout switch and, like my absent-minded self, I forgot to pull the fuse... ...

  1. #1
    Member
    Join Date
    Feb 2007
    Location
    austin
    Posts
    524

    Black/Black
    '00 Firebird WS6 T/A

    Weird Electrical problem

    Few days ago I was redoing my cutout switch and, like my absent-minded self, I forgot to pull the fuse... wires connect, sound like a fuse blowing is heard, and I get the job done, tie up all of the wires...etc and go back to my life. Today, I get in the car and start it up and drive to HEB, and along the way I realized my tach was reading 0 as were the speedo, the fuel gauge and the temperature gauge. The radio wouldn't turn on either but I had expected that. Also, the trunk latch release button is no longer working either. I pulled over and looked at each fuse but they all look fine, I swap ones that are known to be working with others and nothing changes. Help!

  2. #2
    Member
    Join Date
    Feb 2007
    Location
    austin
    Posts
    524

    Black/Black
    '00 Firebird WS6 T/A

    guys i have no radio, no trunk open and no gauges. WTF could be causing this? is there another fuse somewhere?

  3. #3
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Why were you replacing the switch? Did you connect the wires correctly? Where do you have your hot wire coming from? What circuit? Recheck your fuses again, If you need to, sometimes fuses look good although if you check them with a mulimeter and check them for cont. They may not have it.
    J
    2001 SS, Its not the car its the Driver that matters....

  4. #4
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    Ditto, also if you dead shorted the switch, check the fuses under the hood, sound like you blew the gauges or the acc fuse.

  5. #5
    Junior Member
    Join Date
    Sep 2007
    Location
    AL
    Posts
    74

    Black
    2002 Camaro Z-28

    Could it be a fuseable link? Not sure if the F-body has them.....pleny of them on a Fix Or Repair Daily.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Weird Engine/Electrical Problem
    By Shudson105 in forum General Help
    Replies: 10
    Last Post: 06-05-2012, 03:34 PM
  2. weird electrical problem (must be a chevy thing)
    By camaroluvr447 in forum General Help
    Replies: 8
    Last Post: 06-02-2010, 09:59 AM
  3. Weird Electrical Problem...need Help.
    By seasponge in forum General Help
    Replies: 50
    Last Post: 02-24-2009, 10:18 PM
  4. Weird electrical problem
    By silplu83 in forum General Help
    Replies: 5
    Last Post: 08-31-2008, 11:31 AM
  5. Weird Electrical problem
    By richard head in forum Stereo and Electronics
    Replies: 0
    Last Post: 11-16-2007, 01:24 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •