Results 1 to 5 of 5

weird ccoincidence

This is a discussion on weird ccoincidence within the General Help forums, part of the LSx Technical Help Section category; I started up my Camaro yesterday. It hasn't been driven in a couple of months. The fuel gauge and the ...

  1. #1
    Junior Member sweet ss's Avatar
    Join Date
    Mar 2007

    2000 Camaro SS

    weird ccoincidence

    I started up my Camaro yesterday. It hasn't been driven in a couple of months. The fuel gauge and the air conditioning went out at the same time.

    The blower works but the compressor doesn't come on. Also the gas gauge is showing full when I know that it is empty. in fact the gauge went so far to the right that it is completely off the full mark.
    I check the fuses, they were all okay.
    Can somebody please tell me what is going on.?

  2. #2
    Join Date
    Feb 2007

    99 TA

    <gazes into crystal ball>I see a dealer visit in your future.

  3. #3
    Veteran 0rion's Avatar
    Join Date
    Aug 2005

    98 Formula
    06 duramax

    first knock out all the easy stuff you can get to easily. Check grounds, battery cable, wires around the engine bay to make sure a mouse or something didn't make a nest out of them. The fuel gauge sounds like a grounding issue to me. I'm not 100% sure if the 00's ground in the same place as my 98 but the 98's ground is on the drivers side rear brake line bracket.
    Here's a pic I have uploaded of my 98's when I was pointing out wires and locations to someone during their racetronix install. The ground is on the left of the picture behind the racetronix relay box.

    That may not be your problem but it sounds like a ground issue or it could just be the sending unit is bad.
    The A/C problem could be a leak and your out/low on freon from a pinhole or something. Check the freon in the system.

  4. #4
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Westchester, NY

    1996 Camaro Z28 vert

    does your fuel gauge move down as you use gas, or does it just stay pegged above full?

  5. #5
    Ricekiller z28punk's Avatar
    Join Date
    Nov 2006
    Maple Grove, MN

    2002 Camaro Z28

    when the sensors have a problem, they show full. sounds like a mouse had lunch on your wiring. have fun!!!!! and good luck

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Weird Electrical Problem...need Help.
    By seasponge in forum General Help
    Replies: 50
    Last Post: 02-24-2009, 09:18 PM
  2. Weird noise
    By 2fast2blegal in forum General Help
    Replies: 14
    Last Post: 08-29-2007, 12:52 PM
  3. weird.. stuck in fourth gear???
    By DW2000TA in forum Manual Transmission
    Replies: 2
    Last Post: 06-14-2007, 04:08 PM
  4. Ever have a weird car dream?
    By Spaz in forum Almost Anything Goes
    Replies: 18
    Last Post: 05-06-2007, 08:56 AM
  5. weird grinding
    By noriceinside in forum Manual Transmission
    Replies: 10
    Last Post: 03-01-2006, 04:21 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts