Results 1 to 6 of 6

Voltage Drop issue

This is a discussion on Voltage Drop issue within the General Help forums, part of the LSx Technical Help Section category; Hello everyone, I just had a question that I am quite condused about. I have a red-top battery for my ...

  1. #1
    Junior Member HottNixLS1's Avatar
    Join Date
    Oct 2005
    Location
    El Paso, Texas
    Age
    35
    Posts
    13

    Met. Blue w/gold Flakes
    1998 Camaro Ultra-Z

    Voltage Drop issue

    Hello everyone, I just had a question that I am quite condused about. I have a red-top battery for my 1998 Camaro Z28, how I dont think it has any problems, it is new. When I drive, the voltage charge of my car is fine, pointing straight up on my guage. However, when I come to a stop and I hold the break during a red light for example, the charge declines greatly, under 10A or more. It also has a low charge after driving for a while. Nothing works, my power windows wont go up, I have to wait and press the gas to charge up a little just put up my windows. Does any one have any idea what is causing this/ or what I can do to fix it? Thanks, Richard

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Bring it back to wherever you bought it and have them test it for you, just to eliminate it as being the cause. Could be the alternator...

  3. #3
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    68
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    Sounds like a charging issue

  4. #4
    Junior Member
    Join Date
    Oct 2005
    Location
    Houston
    Posts
    79

    Sebring Silver
    98 Z28

    Quote Originally Posted by rbob93 View Post
    Sounds like a charging issue
    loosen the positive battery terminal , start car , let run, remove + terminal, if car dies it's alternator, which in turn hasen't charged your batt for crap, but it could be the batt they do go bad i've heard of redtops going bad in a year. i have one and i hope it lasts, i'm sick of all the f-body quirks damn i wish i could afford a vette

  5. #5
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    68
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    Quote Originally Posted by CDS98Z28 View Post
    loosen the positive battery terminal , start car , let run, remove + terminal, if car dies it's alternator, which in turn hasen't charged your batt for crap, but it could be the batt they do go bad i've heard of redtops going bad in a year. i have one and i hope it lasts, i'm sick of all the f-body quirks damn i wish i could afford a vette
    Great way to fry your electronics!
    This is NOT a 1960's electrical system!

  6. #6
    Nitrous Tuner LS2Tuner's Avatar
    Join Date
    Aug 2006
    Location
    WestCoast AZ-CALI
    Posts
    4,763

    Silver
    05 Goat SMASHED

    Pulleys.................

    DID YOU BUT IT NEW?????? IF NOT A COMBO OF BAD CABLES/UNDER DRIVE PULLEYS WILL MAKE WEAK CHARGE AT IDLE!!!!

    YOU NEED TO DO A "VOLTAGE DROP" ON THE + BATT. CABLE!!!
    Don't be afraid of the bottle!!! Be afraid of your tune!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •