Results 1 to 2 of 2

valves rattle when hot

This is a discussion on valves rattle when hot within the General Help forums, part of the LSx Technical Help Section category; I can't figure this out, lately untill I took the thermostat out my car has been pinging really loud and ...

  1. #1
    Hemi Destroyer 98-LS1's Avatar
    Join Date
    Oct 2005
    Location
    Knoxvegas, Vol country Tennessee
    Posts
    1,112

    Sebring Silver
    98 Z-28 camaro

    valves rattle when hot

    I can't figure this out, lately untill I took the thermostat out my car has been pinging really loud and falling on it's face at WOT. I run 93 in it all the time, it ran at about 210 then I bought a 160* thermostat to cool it down some. It helped but still rattled at WOT so I said fuck it and took the thermostat out completely. Now that I'm not running a thermostat at all it runs great, doesn't get hot, doesn't ping and pulls like a pissed off bitch on steroids. Could this be a problem with detonation? Spark retard causing it to cut back the timing at WOT? It's going to the dealership tomorrow to get a service and get the few problems it has fixed. Also, there is a popping sound in the front suspension and it pulls to the right. Kinda seems like a busted shock, I checked for anything broken or loose and found nothing. It's a 98 Z-28 camaro with the slushbox POS A4. Thanks

  2. #2
    Junior Member
    Join Date
    Jun 2006
    Location
    GA
    Posts
    38

    Maroon
    86 Trans Am

    ping happens for two reasons timing and detination (spelling) timing to far advanced will do it and to low octane will do it.


    hope that gives some help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •