Results 1 to 3 of 3

Valve train noise after head cam install

This is a discussion on Valve train noise after head cam install within the General Help forums, part of the LSx Technical Help Section category; I just had a set of Patriot stage 2 heads and a 226/226 112 cam that I bought w/ the ...

  1. #1
    Junior Member
    Join Date
    Aug 2006
    Location
    Florida
    Posts
    4

    Black
    94 Mazda RX7

    Valve train noise after head cam install

    I just had a set of Patriot stage 2 heads and a 226/226 112 cam that I bought w/ the heads installed on my '99 LS-1. Swapped over the stock lifters and rockers but bought new 7.40 push rods. The shop that did the work is owned by a friend of mine and I trust the quality of his work, though his experience with LS-1s is very limited. The car is a '94 Mazda RX7 w/ a T56
    and 3.90 rear. It has long tube headers and a cold air intake . (didn't mean to ramble, sorry ) After all that, the cars valve train is very noisy, and seems to have less power than before the install. I'm going to have it dyno tuned tomorrow at 'Mikes Next Level Performance' and hope he can get the car to idle smoothly. The car pulled 328rwhp before the swap and I was hoping to get in the low 400's but w/ the low power and valve-train noise I'm a little worried. After tomorrows dyno tune I'll know more. Is the top end noise normal w/ those heads and cam ? I read that some people have hp drops before dyno tuning after the same installation.

  2. #2
    Senior Member Redphoenix1998's Avatar
    Join Date
    Apr 2002
    Location
    NorCal
    Age
    35
    Posts
    1,876

    RED
    1998 Pontiac Trans AM

    valvetrain noise is pretty normal, but if I were, I'd check your valvetrain geometry. ushrods may be a little long because you're running stage 2 heads meaning they most likely have been decked (material taken off) so you may need a short pushrod

  3. #3
    Member SSpdDmon's Avatar
    Join Date
    May 2006
    Location
    Farmington, MI
    Age
    36
    Posts
    332

    SOM
    '01 Camaro SS

    Rather than typing everything out, you should read this thread...

    http://www.ls1tech.com/forums/showthread.php?t=97586

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •