Results 1 to 5 of 5

Update-Engine Prob

This is a discussion on Update-Engine Prob within the General Help forums, part of the LSx Technical Help Section category; ...

  1. #1
    Justin
    Join Date
    Mar 2006
    Location
    Ann Arbor
    Age
    36
    Posts
    172

    Black
    2002 WS6

    Update-Engine Prob

    I said I would let everyone know what the cause of my engine problem was, once I brought it to the dealer. If you don’t remember my 02 -WS6(26,000 miles) suddenly started idling high around 2500 rpm’s and then idled low at 500 rpm’s. It smelled kinda bad once back in the garage, jerked while driving, it also almost cut off at every light.
    The dealership found out that a pressure sensor-(MAP Sensor) had gone bad along with a very dirty fuel injector that caused “Engine Misfire”, both of which contributed to my sudden problems on the road.
    They also replaced my monsoon system head unit since the volume seemed to “Go up” a little before it would actually “Go down”. They also replaced a pinion seal that was leaking underneath- all free of charge since I had a 2 year extended warranty- huge relief.

  2. #2
    Member Bandit1's Avatar
    Join Date
    Dec 2005
    Location
    Philly PA
    Age
    33
    Posts
    348

    black
    2002 TA WS7

    when did u get this work done cause i called the dealer about a monsoon head unit (i needed a new one) for my 02 TA and they said i couldnt get one cause they were discontinued

  3. #3
    Member Bandit1's Avatar
    Join Date
    Dec 2005
    Location
    Philly PA
    Age
    33
    Posts
    348

    black
    2002 TA WS7

    im glad to hear ur baby is back to normal and free of charge!!

  4. #4
    Justin
    Join Date
    Mar 2006
    Location
    Ann Arbor
    Age
    36
    Posts
    172

    Black
    2002 WS6

    Reply Engine prob

    Thats extremely weird. I just got the work done this past Friday. The monsoon was brand spankin new with the sticker still on the visual display. The guy at the service shop was cool as hell. He said they might not replace it under warranty if the only problem was the volume control, so he wrote in the official report that the volume didnt work , but that the channels werent functioning properly either. This definately meant GM had to replace the unit. He also told me he wanted the old monsoon they took out of my car , but that GM informed him that there was a CORE charge of 750.00$, due to the fact that GM wanted the old headunit so they could fix and recondition it. Go figure.

    JR.

  5. #5
    Member Bandit1's Avatar
    Join Date
    Dec 2005
    Location
    Philly PA
    Age
    33
    Posts
    348

    black
    2002 TA WS7

    i wonder y those punks at the dealer told me i couldnt get one anymore im gonna have to call em up and raise hell

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •