Results 1 to 5 of 5

u joint??

This is a discussion on u joint?? within the General Help forums, part of the LSx Technical Help Section category; Ok, so I'm driving along and everything is fine, and I'm going like 60-70 and I let off the has ...

  1. #1
    Junior Member Karczewski's Avatar
    Join Date
    Oct 2011
    Location
    Alabama
    Posts
    34

    u joint??

    Ok, so I'm driving along and everything is fine, and I'm going like 60-70 and I let off the has and if I push it again ill hear this rattle or grinding sound.. its not my cats or trans mount, just replaced all of that. My mechanic thinks it might be my u joint.. opinions?? Driving a 2001 trans am btw

  2. #2
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Are you experiencing any vibrations? When was the last time you serviced the rear end? It could be a number of things. Torque arm, U-joint, rear end, etc. You also mentioned you replaced the trans mount. Did you tighten the crossmember?

  3. #3
    Junior Member Karczewski's Avatar
    Join Date
    Oct 2011
    Location
    Alabama
    Posts
    34
    Yeah, I did. It sounds like its coming from up front tho.

  4. #4
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    And the shifter isn't moving at all. Correct?

    Also, are you running headers? If not, check your manifold heat shields. They could have rusted off the bolts and are rattling.

  5. #5
    Junior Member Karczewski's Avatar
    Join Date
    Oct 2011
    Location
    Alabama
    Posts
    34
    I'll have To check that then, ill let you know later today, thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. u joint help
    By SilverBulletLS1 in forum Drivetrain
    Replies: 4
    Last Post: 01-16-2014, 08:06 AM
  2. So tell me about my u-joint
    By goof4080 in forum Drivetrain
    Replies: 3
    Last Post: 07-03-2012, 04:44 PM
  3. Question: Bad u-joint???
    By joedude02 in forum General Help
    Replies: 2
    Last Post: 11-02-2008, 10:09 PM
  4. U-Joint
    By 01CalgarySS in forum Drivetrain
    Replies: 3
    Last Post: 09-18-2008, 06:43 PM
  5. U-joint squeaking?
    By B200 in forum Drivetrain
    Replies: 0
    Last Post: 08-10-2007, 07:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •