Results 1 to 15 of 15

Turn Singals

This is a discussion on Turn Singals within the General Help forums, part of the LSx Technical Help Section category; When i use the turn signal to make a right it will not flash just stays on in the rear ...

  1. #1
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    Turn Singals

    When i use the turn signal to make a right it will not flash just stays on in the rear fronts is normal it just stays on like normal and on the dash the light comes on to turn right but doesnt blink. I checked both front and rear bulbs and nothings wrong with them. I even replaced them with working ones testing them first and still couldnt get it fixed.

    I cant imagine it being a fuse because i dont think they would even turn on if the fuse is burned but i tried looking for the fuse but had no luck finding it under the hood or inside the car were they usually go but couldnt really locate the exact one for the turn signals. If its not the fuse the only other thing im thinking is maybe some wires are bad but i doubt that or maybe there is something wrong at the steering column, also i changed the front bumper signals and the one on the right side passenger side has condensation in it which i was thinking that could've been the cause but after replacing the bulb it didnt fix the problem. What might you guys think?

  2. #2
    Junior Member alex 00.SS's Avatar
    Join Date
    Oct 2010
    Location
    Costa Mesa C.A
    Posts
    9

    Red
    2000

    hey i have that same problem with my signals, i check my bolt there are OK for some reason i cant find the problem ether.

  3. #3
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    Hopefully someone can help us out

  4. #4
    Auto Painter RyanJM's Avatar
    Join Date
    Dec 2007
    Location
    Houston, TX
    Age
    41
    Posts
    2,002

    White
    1998 Trans Am

    Only thing I can think of is try swapping out the flashed since the bulbs are good. Can get a electronic flashed for a couple bucks at the auto store and it's right under the dash turn on you left blinker and follow the sound.
    1998 Trans Am 85k miles.
    Bolt ons, MS3 113LSA cam, Circle D Stall, Tune, Modified WS6 style hood, Full Suspension, 6000k HID's, Clear Side Markers w/ Leds, Led 3rd Brake Light and 18" AR Staggered Killer Wheels w/ BFG KDW NT's.- Weekend Toy/DD
    02 Trailblazer -Sold
    09 Ram 1500 CC - Sold
    09 Cobalt SS/TC - Sold
    13 ram 1500 LoneStar CC 4x4 - Magnaflow, K&N,and more to come-DD/Toy

  5. #5
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    sounds like it could be your flasher relay or possibly a corroded socket.

  6. #6
    Member
    Join Date
    Jul 2010
    Location
    Pittsburgh, PA
    Posts
    138

    Navy Blue
    1999 Camaro Z28

    Quoting from my Chiltons:


    Turn signal flasher
    1. The turn signal flasher, a small canister-shaped unit located under the dash, in a clip to the left of the steering column, flashes the turn signals.
    2. When the flasher unit is functioning properly, an audible click can be heard during its operation. If the turn signals fail on one side or the other and the flasher unit does not make its characteristic clicking sound, a faulty turn signal bulb is indicated.
    3. If both turn signals fail to blink, the problem may be due to a blown fuse, a faulty flasher unit, a broken switch or a loose or open connection. If a quick check of the fuse box indicates that the turn signal fuse is blown, check the wiring for a short before installing a new fuse.
    4. To replace the flasher, simply unplug it and pull it out of the clip.
    Well... for what it's worth, that will help you find the flasher unit.

  7. #7
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    does anyone know where the fuse is for the turn signals ? when i replaced my bulbs i looked inside the sockets and they were in good shape. No residue or dirt and looked very clean.

  8. #8
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    I would almost bet money that it's your flasher relay. Check the post above yours for the info on it. Cheap and will take 5 minutes to swap out.

  9. #9
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    Thanks guys for the help, got it fixed it was the flasher

  10. #10
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    just checked it one last time and the rear signals turn on just the front bumper signal on the passenger side doesnt flash now just stay on. Before the flasher the rear would just stay on and not flash. Ill try again and swap out the front bulb and see if that helps.

  11. #11
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    check that specific socket over really well too.....does it look like moisture has gotten inside the lens?

  12. #12
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    I bet it is a bulb/wiring/socket issue.

    Here's an easy way to check the lights to see where the problem is:

    Turn on the four way flashers (hazards).
    Walk around the car, noting the side that flashes the turn signals normally, counting how many bulbs front and rear on that side flash.
    Now compare it to the side that does not flash the turn signal normally, and you will see which bulb is not flashing. From there, check the bulb/socket/wiring.

    You can also turn on the parking lights, the hazards should all flash the same time, not "backwards." What I mean by backwards is if there is a wiring/ground wire issue, one side would flash dim and opposite the side normal intensity.

    A lot of times there are 2 bulbs that are supposed to flash in the back, only one does, and that is why one turnsignal side flashes and the other side does not.
    Does your Camaro have 2 bulbs in the back for the signal?

  13. #13
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    camaro just has one turn signal in the back, also when i have the hazards on all the lights flash except passenger side bumper signal. When i put the flasher to turn right the passenger side front does not flash but the same side rear does now were before changing the flasher it would just stay on front and rear.

  14. #14
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    "Passenger side bumper signal".

    By that, do you mean the front, or side marker does not flash?

  15. #15
    Junior Member DMAN's Avatar
    Join Date
    May 2009
    Location
    OKC, OK
    Posts
    35

    White
    2001 Camaro

    i had your exact same problem today i changed the flasher and the back started to flash but not the front so i took out the front bulb and put it back in and now they both work! i don't know if it had to reset or what but try taking out the bulb that doesn't flash and just put it right back in. i did it while the right signal was on don't know if that matters. good luck!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I can't turn my TCS on? does anyone know how to fix it?
    By Ryanater in forum Firebird / WS6
    Replies: 37
    Last Post: 03-25-2009, 04:29 PM
  2. When you turn 18...
    By Frazier in forum Almost Anything Goes
    Replies: 4
    Last Post: 03-17-2009, 07:25 PM
  3. How to turn off DRL
    By kool-aide in forum Stereo and Electronics
    Replies: 3
    Last Post: 08-05-2008, 03:29 PM
  4. Turn on FX right now!!!!!
    By 99blueZ in forum Almost Anything Goes
    Replies: 4
    Last Post: 03-23-2007, 10:37 AM
  5. Help? Can someone turn off my SES?
    By BlackHawk#36 in forum Western Members
    Replies: 8
    Last Post: 01-04-2007, 01:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •