Results 1 to 2 of 2

turn signals don't work

This is a discussion on turn signals don't work within the General Help forums, part of the LSx Technical Help Section category; For some reason my turn signals aren't working. The arrows don't light up on the dash and the tail lights ...

  1. #1
    Rice Hungry GottaHaveLS1's Avatar
    Join Date
    Oct 2005
    Location
    Connecticut
    Age
    30
    Posts
    1,316

    Black
    1999 Trans Am M6

    turn signals don't work

    For some reason my turn signals aren't working. The arrows don't light up on the dash and the tail lights don't do anything. all the lights are fine. i noticed my turn signals were blinking very slow for a while. I checked every damn fuse on the car and they look good and are the right "ampage".

    is there anything else i can do?

  2. #2
    Member
    Join Date
    Jun 2006
    Location
    USA
    Age
    37
    Posts
    202
    2001 WS6, 2003 SRT4(sold)

    Pull your turn signal bulbs and clean off all corrosion buildup. I recommend using PB Blaster, but if you don't have any, simply wiping them off will help. Put them back in and see if anything changes. If they work, take them back out once more and slather up the connecting pieces with dieletric grease. Replace again. You should be set for a while.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. turn signals don't work
    By GottaHaveLS1 in forum Stereo and Electronics
    Replies: 11
    Last Post: 04-01-2014, 05:03 PM
  2. help ....my turn signals dont work
    By Speedy_Gonzales in forum General Help
    Replies: 19
    Last Post: 03-21-2010, 09:15 AM
  3. Turn signals and brake lights don't quite work..HELP!!
    By Kaution vBi in forum General Help
    Replies: 1
    Last Post: 08-05-2007, 10:45 AM
  4. Turn signals wont work but hazards do??
    By Toneloc71sr in forum General Help
    Replies: 5
    Last Post: 05-31-2007, 01:48 AM
  5. Help with my Turn Signals
    By mustngdave in forum General Help
    Replies: 3
    Last Post: 05-05-2007, 11:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •