Results 1 to 4 of 4

Turn signal/hazard issue (left side out).

This is a discussion on Turn signal/hazard issue (left side out). within the General Help forums, part of the LSx Technical Help Section category; This is for a '99 Camaro... When attempting to operate the left turn signal...the left turn indicator in the dash ...

  1. #1
    Junior Member tyler durden's Avatar
    Join Date
    Aug 2009

    Turn signal/hazard issue (left side out).

    This is for a '99 Camaro...

    When attempting to operate the left turn signal...the left turn indicator in the dash stays lit and neither bulb functions. The bulb for the left rear indicator/hazard works for the hazards, but not the turn indicator. The front left bulb is out...period. I've already replaced both of the bulbs. The turn signal and hazard function for the right side of the vehicle is fine.

    According to the Haynes manual...the turn signal switch functioning for the right side indicator, but not the left indicates a bad bulb. As I've replaced both of the bulbs in question...I'm at a loss at the moment.

    I've spent a couple hours going through the dozens of threads with nearly identical issues, but mine seems to be just a bit different. I appreciate any input you can offer.

  2. #2
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Raleigh NC

    1999 Trans Am

    Mines doing the exact same thing...... subscribed.

  3. #3
    Member RealLiveMD's Avatar
    Join Date
    Feb 2006

    2002 WS6

    check for corrosion. there is a bad connection somewhere. perhaps you didn't seat the bulb all the way in the socket. If its a trans am I'm will to bet that you need to replace the socket whick you can do for five dollars from oreilly or autozone.

  4. #4
    Junior Member
    Join Date
    Feb 2007

    2001 WS6 T/A

    Had the same problem with my 01 t/a, it was corrosion in the light socket
    up front. purchased two new pig tail sockets and repaired. works great now

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Driver side turn signal no working? WTF!
    By bgable in forum Firebird / WS6
    Replies: 16
    Last Post: 09-17-2007, 07:20 PM
  2. left and right side 01 camaro headlight capsules
    By FreakV6 in forum Parts For Sale / Trade
    Replies: 5
    Last Post: 09-14-2006, 05:28 AM
  3. Pass the Dutchie on the left hand side...
    By CaptainCaveMan in forum Almost Anything Goes
    Replies: 4
    Last Post: 06-20-2006, 06:24 PM
  4. Loud noise when I turn Left?
    By 97BlackT/A in forum Wheels and Tires
    Replies: 8
    Last Post: 10-24-2005, 11:58 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts