Results 1 to 8 of 8

Turn signal FAILURE H2O

This is a discussion on Turn signal FAILURE H2O within the General Help forums, part of the LSx Technical Help Section category; alright i need help asap on this, because i live on a military base i have very strict standards pertaining ...

  1. #1
    Junior Member thefridge's Avatar
    Join Date
    Aug 2010
    Location
    Havelock nc
    Posts
    29

    black
    2002 Pontiac Trans am ws6

    Turn signal FAILURE H2O

    alright i need help asap on this, because i live on a military base i have very strict standards pertaining to lights, what happened is my front turn signals (right and left) keep blowing out, and i think its water from what i have heard, and the fact that when i took the right bulb out today it was cracked and filled with water, ive been reading and i guess leds are the way to go but im wondering do leds hook up to the stock bulb wire? if so is it simple plug in led, get light? i really need all the help i can on this, as soon as possable, maybe even a tutorial on how to install leds, or fix the water problem thanks in advance

  2. #2
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    this is one of the best threads on the subject and should help you out.
    The Saga of the Trans Am Parking light

  3. #3
    Member
    Join Date
    Aug 2005
    Location
    Tulsa,OK
    Age
    37
    Posts
    914

    Quick Silver
    2002 Z06

    If your lenses are cracked then you need to replace them first.

    After that check out our gaskets, with them and non cracked lenses you should have no more issues.


    Slow Passenger Window - Want Passenger Express Down - Tired of Replacing DayTime Running Light Bulbs

    Camaro Owners Click Here
    Firebird Owners Click Here

    Need instructions to replace your F-Body window motor?
    www.AutoTrix.net

  4. #4
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    get LEDS in there or the stock bulbs will keep cracking new lenses.....ask me how i know........

  5. #5
    Senior Member Schmalgar's Avatar
    Join Date
    Apr 2010
    Location
    Alpharetta, Ga
    Age
    45
    Posts
    1,060

    04 Cobra 'vert - M6 mysti
    02 WS6 coupe - A4 red

    Also slather dielectric grease into the sockets before replacing bulbs. That has helped me greatly. It used to be that anytime I hit rain or washed my car a bulb would blow. But they've been stable since the addition of the dielectric grease.

  6. #6
    Senior Member Schmalgar's Avatar
    Join Date
    Apr 2010
    Location
    Alpharetta, Ga
    Age
    45
    Posts
    1,060

    04 Cobra 'vert - M6 mysti
    02 WS6 coupe - A4 red

    Quote Originally Posted by gnomee View Post
    After that check out our gaskets, with them and non cracked lenses you should have no more issues.
    Interesting, didn't know such gaskets existed. At that price, I might order a set too, easy double protection with the grease...

  7. #7
    おれわCamaroがいじん! chaosinfinite's Avatar
    Join Date
    Apr 2007
    Location
    Washington D.C.
    Age
    31
    Posts
    198

    Black
    1998 Chevrolet Camaro SS

    I have had this same problem. Like one of the previous people said... check to see if your light housing is cracked first. Second of all, make sure in the back of the light there is some sort of ventilation for the water to evaporate too instead of just in your light housing. After I found out my first pair were cracked and kept making my bulbs go out, I bought a new set only to find out they were poor quality and had no ventilation which still made my bulbs burn out after I saw my whole light housing was filled with water. I bought a new 3rd pair from rksport.com and they have worked perfectly since then with no light outages.

  8. #8
    Member
    Join Date
    Aug 2005
    Location
    Tulsa,OK
    Age
    37
    Posts
    914

    Quick Silver
    2002 Z06

    From the factory there is a vent hole at the top which should allow moisture to evaporate.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Turn signal?
    By GrapeApeTA in forum General Help
    Replies: 15
    Last Post: 01-23-2011, 12:14 PM
  2. Turn Signal
    By edrvsqz1980 in forum Firebird / WS6
    Replies: 30
    Last Post: 11-15-2010, 06:58 PM
  3. Question: turn signal
    By SSMOKEshow in forum Camaro / SS
    Replies: 18
    Last Post: 06-09-2009, 04:18 PM
  4. Turn Signal
    By Z28boy2000 in forum Stereo and Electronics
    Replies: 1
    Last Post: 03-30-2009, 12:36 PM
  5. Turn signal help
    By Blksilvr in forum General Help
    Replies: 7
    Last Post: 08-08-2007, 05:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •