Results 1 to 6 of 6

transam turn signal problem

This is a discussion on transam turn signal problem within the General Help forums, part of the LSx Technical Help Section category; Ok so my drl only 1 side is on, turn signal for not working side doesnt work. doesnt work for ...

  1. #1
    Military Police FutureWS6's Avatar
    Join Date
    Mar 2007
    Location
    dallas
    Posts
    300

    Black
    1999 Trans Am

    transam turn signal problem

    Ok so my drl only 1 side is on, turn signal for not working side doesnt work. doesnt work for hazards. but works when i hit the lock or unlock button.....if its a flasher i bought one. but no idea where it goes

  2. #2
    Moderator 98TransAmWs-6's Avatar
    Join Date
    Apr 2010
    Location
    Fairfax, VA
    Posts
    3,596

    Black/ Silver
    98 TA WS6/ 01 C5 Corvette

    Have you checked the bulb itself to see if it is shorting out? I don't know where the flasher goes either but I would imagine some where close to the bulb.

  3. #3
    Auto Painter RyanJM's Avatar
    Join Date
    Dec 2007
    Location
    Houston, TX
    Age
    41
    Posts
    2,002

    White
    1998 Trans Am

    Flashers module is under the driver's side dash just drop the panel under the wheel and turn the working blinked on and listen to the clicking. Never heard of a flashergoing bad yet I.swapped I'm a electronic flasher for my leds but.my stock still worked fine, my sockets both rusted out and caused a lot of issues though. Not sure about.the drl though I disconnected mine a while ago I didn't like the look and heated up the housings and caused cracking.
    1998 Trans Am 85k miles.
    Bolt ons, MS3 113LSA cam, Circle D Stall, Tune, Modified WS6 style hood, Full Suspension, 6000k HID's, Clear Side Markers w/ Leds, Led 3rd Brake Light and 18" AR Staggered Killer Wheels w/ BFG KDW NT's.- Weekend Toy/DD
    02 Trailblazer -Sold
    09 Ram 1500 CC - Sold
    09 Cobalt SS/TC - Sold
    13 ram 1500 LoneStar CC 4x4 - Magnaflow, K&N,and more to come-DD/Toy

  4. #4
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Sounds like the classic TA turn signal/DRL problem. Bulb and socket are heat damaged, DRL lens or housing cracked and leaking water into them.
    What you might need is a new socket and bulb.

  5. #5
    Military Police FutureWS6's Avatar
    Join Date
    Mar 2007
    Location
    dallas
    Posts
    300

    Black
    1999 Trans Am

    but the light works. when i hit the lock and unlock on my remote

  6. #6
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    The front DRL/parking/turn signal lamp contains a bulb with 2 filaments. The DRL and Turn signal uses the brighter filament and the parking lights use the dim filament. The remote flashes the parking lights, not the turn signals.
    Most likely you have a bulb problem, but also check the socket for corrosion or heat damage.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. turn signal problem?
    By DMAN in forum General Help
    Replies: 6
    Last Post: 10-25-2010, 05:21 PM
  2. turn signal problem
    By Firebirdformula in forum Firebird / WS6
    Replies: 7
    Last Post: 06-07-2010, 05:55 PM
  3. Turn Signal problem
    By Camaroride32 in forum General Help
    Replies: 3
    Last Post: 04-16-2008, 04:23 PM
  4. Turn signal problem
    By {FzS}BlacKMagicK in forum General Help
    Replies: 10
    Last Post: 05-01-2007, 06:27 AM
  5. Turn Signal Problem
    By M.RedWS6 in forum Firebird / WS6
    Replies: 5
    Last Post: 11-25-2006, 11:02 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •