Results 1 to 12 of 12

Was told LF WSS but now ABS module?

This is a discussion on Was told LF WSS but now ABS module? within the General Help forums, part of the LSx Technical Help Section category; Last year i went to Pep Boys and had them run why the ABS INOP,BRAKE, and ASR OFF lights were ...

  1. #1
    Junior Member pdiddyz28's Avatar
    Join Date
    Sep 2009
    Location
    Boston,MA
    Age
    30
    Posts
    35

    navy blue
    1998 z28 m6

    Was told LF WSS but now ABS module?

    Last year i went to Pep Boys and had them run why the ABS INOP,BRAKE, and ASR OFF lights were on and it came back needing a left front wheel speed sensor (WSS).So i changed that today and the lights were all still on so my buddy hooked his scanner up to it and 13 or 14 codes came up all having to do with the indicator lights being on.As we were driving none of the sensors were registering any speeds to the computer and when we apply the brake pedal it wasn't registering that working either.we take it down a shop that we know with very knowledgeable guys and they said its the ABS module,we also checked all the fuses and grounds.they were all good.Also those 3 lights are off and on every once in a while so im lost.ANy ideas or comments would be MUCH appreciated....thanks guys!

  2. #2
    Member importhater81's Avatar
    Join Date
    Oct 2009
    Location
    chicagoland,Il
    Age
    36
    Posts
    333

    black
    02 ss camaro

    Did you clear the codes after you replaced the lf wss?
    Modules rarely ever fail from my experience...check your connections at the abs module and sensors.Backed out and spread terminals are prime candidates for codes like the ones you have.

  3. #3
    Junior Member pdiddyz28's Avatar
    Join Date
    Sep 2009
    Location
    Boston,MA
    Age
    30
    Posts
    35

    navy blue
    1998 z28 m6

    ya,we cleared the codes and they all came back up at once.

  4. #4
    Member importhater81's Avatar
    Join Date
    Oct 2009
    Location
    chicagoland,Il
    Age
    36
    Posts
    333

    black
    02 ss camaro

    Get a schematic check everything to the EBCM,power, ground, serial data and check the resistance of the wss's from the module to the sensors.

    It very well could be a bad ABS module,but I'd go over and double check everything before you replace it.Those modules are expensive!

  5. #5
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Can you list the codes that are stored in the abs computer?

  6. #6
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Strange, I had the exact same issue on my 92 GMC Typhoon. It was first a code for the right front wheel speed sensor. Replaced that and shortly after all the codes came on, and the ABS module ended up being the culprit after some diagnostics.

    Expensive to purchase, even at that time. If I had to do it all over again, and any of our 4th gens give me the same issues, it will be ABS delete time for me. I'm not going through that again.

  7. #7
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    You could always try to find a used ABS module if you really wanna keep it.

  8. #8
    Awaiting Activation
    Join Date
    Oct 2007
    Location
    NC
    Posts
    635

    SOM
    1998 T.A.

    Google Module Masters. They will rebuild it for you WAAAAAY cheaper than you will get a new one for. IIRC it is a dealer only part....

  9. #9
    Junior Member pdiddyz28's Avatar
    Join Date
    Sep 2009
    Location
    Boston,MA
    Age
    30
    Posts
    35

    navy blue
    1998 z28 m6

    Quote Originally Posted by SOMbitch View Post
    Google Module Masters. They will rebuild it for you WAAAAAY cheaper than you will get a new one for. IIRC it is a dealer only part....
    hey brother, good looks on this website.worst case if i cant figure it out,160 to rebuild isn't bad at all,thanks a lot.

  10. #10
    Member JRENIGAR's Avatar
    Join Date
    Oct 2009
    Location
    arkansas
    Posts
    371

    red
    99 camaro

    same problems here, subscribed...

  11. #11
    Awaiting Activation
    Join Date
    Oct 2007
    Location
    NC
    Posts
    635

    SOM
    1998 T.A.

    Quote Originally Posted by pdiddyz28 View Post
    hey brother, good looks on this website.worst case if i cant figure it out,160 to rebuild isn't bad at all,thanks a lot.
    Let us know how it turns out. Always glad to help out another gearhead

  12. #12
    rsg98Z28 rsg98Z28's Avatar
    Join Date
    Dec 2007
    Location
    Atlanta, GA
    Posts
    90

    Black
    1998 Camaro Z28 vert

    we send abs modules to Module Masters at work they do great work

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I could have told you that...
    By CaptainCaveMan in forum Political / Debate Forum
    Replies: 7
    Last Post: 03-02-2010, 03:16 AM
  2. Told dude in a 5th gen SS RS how it is.
    By TempleU_WS6 in forum Almost Anything Goes
    Replies: 24
    Last Post: 09-20-2009, 05:14 AM
  3. Question: How come no one told me to do this???
    By KING Z28 HAWK in forum External Engine
    Replies: 12
    Last Post: 08-09-2009, 09:48 PM
  4. For Sale: abs module,cruise module,water tem gauge
    By sammy burks in forum Parts For Sale / Trade
    Replies: 5
    Last Post: 06-02-2008, 06:38 AM
  5. It Told Me To
    By Ted_Dallas_WS6 in forum New Member Introductions
    Replies: 2
    Last Post: 05-31-2007, 12:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •