Results 1 to 13 of 13

throttle sticking help????

This is a discussion on throttle sticking help???? within the General Help forums, part of the LSx Technical Help Section category; I just took out my 99 SS since it has been in storage and drove it around and noticed when ...

  1. #1
    Dynamic duo naperws6's Avatar
    Join Date
    Apr 2006
    Location
    naperville
    Age
    40
    Posts
    396

    black
    02 HAWK aka the beast

    throttle sticking help????

    I just took out my 99 SS since it has been in storage and drove it around and noticed when I remove my foot off the throttle at around 40 mph the car does not slow down so I put the car in nuetral its a automatic and rpm is around 1900 rpm. When I stop at at a light or stop sign the car is at idle around 700 rpm which is normal. What sensor or part could it be? has anyone experienced this before?? I'm thinking IAC sensor but I don't want to buy it and it not fix problem. The car is bonestock except for a lid and k&n. any input would will be helpful thanks in advance.

  2. #2
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    well the throttle positioning sensor would be a better culprit then the IAC. However. drive the car a little more and see if the problem fixes itself. stored cars can do funny things for a little bit.

  3. #3
    Dynamic duo naperws6's Avatar
    Join Date
    Apr 2006
    Location
    naperville
    Age
    40
    Posts
    396

    black
    02 HAWK aka the beast

    Quote Originally Posted by shady milkman View Post
    well the throttle positioning sensor would be a better culprit then the IAC. However. drive the car a little more and see if the problem fixes itself. stored cars can do funny things for a little bit.
    I'm going to clean throttle body and and iac and drive the car more.

  4. #4
    SS Driver aerojt's Avatar
    Join Date
    Jul 2007
    Location
    Ohio
    Posts
    553

    Black
    1998 Camaro SS M6 #1871

    Sounds like you're driving a Camry....

  5. #5
    Dynamic duo naperws6's Avatar
    Join Date
    Apr 2006
    Location
    naperville
    Age
    40
    Posts
    396

    black
    02 HAWK aka the beast

    Quote Originally Posted by aerojt View Post
    Sounds like you're driving a Camry....
    lol throttle is not sticking it full throttle.

  6. #6
    Member Maro SS's Avatar
    Join Date
    Mar 2009
    Location
    Oldbridge
    Age
    28
    Posts
    303

    Black
    2001 Camaro SS

    Quote Originally Posted by aerojt View Post
    Sounds like you're driving a Camry....
    hahaha i was going to tell him to take it to toyota id lube the throttle cable or at least check the mecanism..

    same thing happened in my iroc and i put a spring on the throttle cable thing to pulll it back when i let off the gass.. quick fix for that car lol

  7. #7
    Dynamic duo naperws6's Avatar
    Join Date
    Apr 2006
    Location
    naperville
    Age
    40
    Posts
    396

    black
    02 HAWK aka the beast

    i took everyones advice and traded it in a Toyota.







































































    Just kidding I cleaned the IAC sensor and replaced the Throttle Postion Sensor and fixed the problem. Thank you for the great advice. The SS is like new runs like a champ.

  8. #8
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    Quote Originally Posted by naperws6 View Post
    i took everyones advice and traded it in a Toyota.

    Just kidding I cleaned the IAC sensor and replaced the Throttle Postion Sensor and fixed the problem. Thank you for the great advice. The SS is like new runs like a champ.

    so which one fixed it ? if you have your old one....you should install it and see if cleaning the iac worked or if it was the tps ..

  9. #9
    Dynamic duo naperws6's Avatar
    Join Date
    Apr 2006
    Location
    naperville
    Age
    40
    Posts
    396

    black
    02 HAWK aka the beast

    Quote Originally Posted by shady milkman View Post
    so which one fixed it ? if you have your old one....you should install it and see if cleaning the iac worked or if it was the tps ..
    Iac was not that dirty. I get cost at pepboys on parts thru the dealer I work for so for $22 I just replaced Throttle postion sensor which I think was the problem
    Last edited by naperws6; 03-16-2010 at 07:54 AM.

  10. #10
    LS WON camaro02sprspt's Avatar
    Join Date
    Sep 2009
    Location
    Winchester, VA
    Posts
    57

    Red
    2002 SS #5201

    my turds doing the same thing, did it few months ago then fixed itself, started again today, guess ima do some cleaning

  11. #11
    Member Badass WS6's Avatar
    Join Date
    Oct 2009
    Location
    A, A
    Posts
    375

    Pewter
    2002 Trans Am WS6

    Quote Originally Posted by camaro02sprspt View Post
    my turds doing the same thing, did it few months ago then fixed itself, started again today, guess ima do some cleaning

  12. #12
    Dynamic duo naperws6's Avatar
    Join Date
    Apr 2006
    Location
    naperville
    Age
    40
    Posts
    396

    black
    02 HAWK aka the beast

    Quote Originally Posted by camaro02sprspt View Post
    my turds doing the same thing, did it few months ago then fixed itself, started again today, guess ima do some cleaning
    Due the TPS sensor I bet that is the problem.

  13. #13
    LS WON camaro02sprspt's Avatar
    Join Date
    Sep 2009
    Location
    Winchester, VA
    Posts
    57

    Red
    2002 SS #5201

    ok thanks, im going to this weekend

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can a stuck tranny valve cause my throttle sticking???
    By TahoeTruk in forum General Help
    Replies: 13
    Last Post: 02-13-2016, 06:55 PM
  2. Throttle sticking/hanging
    By SpinsB in forum General Help
    Replies: 33
    Last Post: 08-12-2009, 08:33 AM
  3. Help: Throttle sticking
    By 2000dreambird in forum External Engine
    Replies: 3
    Last Post: 08-12-2009, 07:04 AM
  4. Replies: 17
    Last Post: 09-19-2006, 02:32 PM
  5. Throttle sticking from each shift, all RPM's
    By 981LEZ28 in forum General Help
    Replies: 6
    Last Post: 02-08-2006, 09:11 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •