Results 1 to 8 of 8

throttle body question

This is a discussion on throttle body question within the General Help forums, part of the LSx Technical Help Section category; I recently installed a 6.0 out of a 2007 3/4 ton suburban in ,my 2000 trans am and upgraded to ...

  1. #1
    Junior Member
    Join Date
    Feb 2011
    Location
    Iowa
    Posts
    6

    red
    2000 Trans Am LS1

    throttle body question

    I recently installed a 6.0 out of a 2007 3/4 ton suburban in ,my 2000 trans am and upgraded to an intake off of a 2013 corvette using the injectors out of corvette as well. i went with a 92mm throttle body and once we got everything going we have a starting problem with the car. I noticed the stock ls1 throttle body has a hole in it and my new throttle body does not. My question is has anyone ever ran into this problem and how you fixed it. Was wondering if drilling a hole in the new throttle body like the original would cure it? Any input will be greatly appreciated.

  2. #2
    Former Mopar Man 2002ssslp's Avatar
    Join Date
    Jun 2011
    Location
    Branchville, NJ
    Posts
    3,111

    Silver & Blue
    02 Camaro SS, 04 GTO

    I believe the hole in the TB blade is to help cold starts. Go for it.
    My ride is a 2002 Camaro SS SLP #3296 with 30k, LTH, 3" Y, CME, Frost tune, K&N, ported TB, Blackwing lid, Bellows, MSD, Denso Iridium, and 85mm MAF, Bilsteins, Eibach springs, SLP strut brace, Adj. Panhard, TA Girdle, UMI, Pro 5.0, Nitto NT555
    My wife has a 2004 GTO with the rare SAP, 18" wheels, K&N Cold Air System, MSD, Ported TB, Frost tune, Denso Iridium, Flowmaster cat-back, 3200 Yank, 75k

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Can you define "starting problem"? Does it crank and not fire? Fires and then dies?

  4. #4
    Former Mopar Man 2002ssslp's Avatar
    Join Date
    Jun 2011
    Location
    Branchville, NJ
    Posts
    3,111

    Silver & Blue
    02 Camaro SS, 04 GTO

    I think he is getting a sputter and stall situation. I always check the fuel pressure first.

  5. #5
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    Is it a drive by wire set up or do you still have a throttle cable? If a cable there should be a throttle stop you can adjust...much easier to undo than a hole. Probably just needs a tune to adjust the idle air tables.

  6. #6
    Member 1998 T/A's Avatar
    Join Date
    Aug 2008
    Location
    Huron Ohio
    Posts
    759

    Black
    2000 WS6 Trans AM

    I'm gonna ask an obvious question here...did you get it tuned????
    98' Trans AM RIP

    00' WS6/Black/Pacesetter LT's/Magnaflow Exhaust/SLP lid/Nick Williams 92mm TB/FAST 92 Intake/BMR Strut Tower Brace/BMR Rear LCA's/BMR Panhard Bar

  7. #7
    Junior Member
    Join Date
    Feb 2011
    Location
    Iowa
    Posts
    6

    red
    2000 Trans Am LS1

    thanks for all the responses. i had had it tuned but we found out it was just a piss poor job by a certain company I wont mention any names here and now. It goes in in a couple days to get a new tune done to it, and a dyno hit as well. I appreciate all the responses and sorry it took me so long to get back on here to update. I will check in again after the new tune and dyno run.

  8. #8
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Ok - thanks for letting us know and hope that solves your issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Throttle Body Question
    By TransAm11973 in forum General Help
    Replies: 8
    Last Post: 01-19-2009, 08:52 AM
  2. Question: Throttle body question
    By screamindemon in forum External Engine
    Replies: 4
    Last Post: 01-17-2009, 05:16 PM
  3. throttle body question
    By camaro_five0 in forum External Engine
    Replies: 10
    Last Post: 01-01-2007, 09:07 PM
  4. Throttle body question
    By blue02Z in forum External Engine
    Replies: 1
    Last Post: 05-28-2006, 06:01 PM
  5. Throttle Body question
    By SSzoe in forum External Engine
    Replies: 3
    Last Post: 02-21-2006, 08:51 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •