Page 2 of 2 FirstFirst 12
Results 21 to 37 of 37

temp and gas gauge keep jumping around

This is a discussion on temp and gas gauge keep jumping around within the General Help forums, part of the LSx Technical Help Section category; Originally Posted by ntymd8r I got a problem woth my fuel gauge, too. The gauge will read full at every ...

  1. #21
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by ntymd8r View Post
    I got a problem woth my fuel gauge, too. The gauge will read full at every fill up, but more times than not, it will slowly go up and down. It sometimes goes all the way down past empty for a few seconds/minutes. Any ideas as to what is causing this?

    Gauge sender issues like that are usually the result of buildup from sulfer deposits. Honestly, go get two (2) bottles of Chevron Techron Fuel System cleaner from the parts store. Run them in two (2) successive fill ups, following the instructions on the bottle, and I am fairly certain this will solve your problem. I am not a big advocate for additives and such, but this does work.

  2. #22
    Junior Member ntymd8r's Avatar
    Join Date
    Aug 2005
    Location
    Corona, CA
    Posts
    80

    Red
    2001 Chevrolet Camaro Z28

    Quote Originally Posted by pajeff02 View Post
    Gauge sender issues like that are usually the result of buildup from sulfer deposits. Honestly, go get two (2) bottles of Chevron Techron Fuel System cleaner from the parts store. Run them in two (2) successive fill ups, following the instructions on the bottle, and I am fairly certain this will solve your problem. I am not a big advocate for additives and such, but this does work.
    Where does the sulfer deposit build up, exactly? In the tank, in a line, on the sender unit it self? Sounds promising...so, you have actually done this in your car?

  3. #23
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    My first Ford Ranger has a sender issue and using Chevron Techron made it go away. Almost exactly what you described. I just dumped Chevron Techron in our '07 Suburan yesterday as preventative maintenance. Sulfer deposits build up on the sender -- it is essentially a winding of very tiny wire against which the float rod makes contact. As it travels up and down the resistance varies and this is what makes your gauge needle move. The sensor is dampened of course so that fuel slosh does not make your gauge bounce all over the place.

  4. #24
    Junior Member ntymd8r's Avatar
    Join Date
    Aug 2005
    Location
    Corona, CA
    Posts
    80

    Red
    2001 Chevrolet Camaro Z28

    Quote Originally Posted by pajeff02 View Post
    My first Ford Ranger has a sender issue and using Chevron Techron made it go away. Almost exactly what you described. I just dumped Chevron Techron in our '07 Suburan yesterday as preventative maintenance. Sulfer deposits build up on the sender -- it is essentially a winding of very tiny wire against which the float rod makes contact. As it travels up and down the resistance varies and this is what makes your gauge needle move. The sensor is dampened of course so that fuel slosh does not make your gauge bounce all over the place.
    Thanks for the info, I'll definitely try it over the weekend! I have only used Valvoline products in my Z. Do you know of any difference in additives of Techron compared to the Valvoline products?....and we're referring to a fuel sustem cleaner, right?

  5. #25
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Chevron, Exxon, and Shell, use techron in their fuels. Get yourself a couple tank fulls from one of those gas stations and you should be fine.
    As far as aditives go, I can't answer that as I never use off the shelf additives, and I also never let my tank go below 1/4.

  6. #26
    Junior Member ntymd8r's Avatar
    Join Date
    Aug 2005
    Location
    Corona, CA
    Posts
    80

    Red
    2001 Chevrolet Camaro Z28

    Quote Originally Posted by Smittro View Post
    Chevron, Exxon, and Shell, use techron in their fuels. Get yourself a couple tank fulls from one of those gas stations and you should be fine.
    As far as aditives go, I can't answer that as I never use off the shelf additives, and I also never let my tank go below 1/4.
    I am die hard Shell, so that's the only fuel I use. Differnce betwreen Chevron and Shell?

  7. #27
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by ntymd8r View Post
    I am die hard Shell, so that's the only fuel I use. Differnce betwreen Chevron and Shell?
    Then you probably have an eletrical issue. Here in PA. Chevron and Shell are two different fuel stations. I also see you're from Cali. so Exxon is'nt an option for you..
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  8. #28
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Chevron Techron is the only one I personally know of that works. Last I saw, Walmart had it with an instant coupon for $2.00 off at the register.

  9. #29
    Junior Member ntymd8r's Avatar
    Join Date
    Aug 2005
    Location
    Corona, CA
    Posts
    80

    Red
    2001 Chevrolet Camaro Z28

    Quote Originally Posted by pajeff02 View Post
    Chevron Techron is the only one I personally know of that works. Last I saw, Walmart had it with an instant coupon for $2.00 off at the register.
    I'll try the additive and post up the results.....thanks for the suggestions!

  10. #30
    Junior Member ntymd8r's Avatar
    Join Date
    Aug 2005
    Location
    Corona, CA
    Posts
    80

    Red
    2001 Chevrolet Camaro Z28

    Did some research and the census was Chevron w/ Techron (their formula) does some things to clean your engine while Shell w/Nitrogen (their formula) does other things. Since I've only used Shell, I'll switch over to Chevron for a few tanks to see if the fuel gauge fixes itself. Again, I'll post up the results.

  11. #31
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    The stuff I am talking about comes in a bottle -- not at the pump.

  12. #32
    Junior Member ntymd8r's Avatar
    Join Date
    Aug 2005
    Location
    Corona, CA
    Posts
    80

    Red
    2001 Chevrolet Camaro Z28

    So use it (the additive) with Shell gas or Chevron? Would that matter?

  13. #33
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Use it with whatever you would like.

  14. #34
    Junior Member ntymd8r's Avatar
    Join Date
    Aug 2005
    Location
    Corona, CA
    Posts
    80

    Red
    2001 Chevrolet Camaro Z28

    Thanks for your help!

  15. #35
    Junior Member ntymd8r's Avatar
    Join Date
    Aug 2005
    Location
    Corona, CA
    Posts
    80

    Red
    2001 Chevrolet Camaro Z28

    ....OK, filled her up on Saturday and added the Chevron w/Techron. Right away I noticed an improvement with the fuel gauge, not to mention my long/short fuel trims (zero's across the board on WOT), no knock retard (0 degress at WOT) and the O2's are between 960-980 mV at WOT.

    The needle jumped to full and stayed there until I got home, 30 miles, as it should (no jumping around). Went to work Sunday and the needle jumped to full again....very happy!

    When I started her on Monday night though (3/4's full), the needle slowly went up to 3/4, where it should be. It then suddenly jumped down past empty for several seconds and then back up. Is it still cleaning and learning how to act?

  16. #36
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    I'ma restate you likely have an electrical issue, 4th gen f-bodies are notorious for electrical problems.

    SHell fuel already has techron in it.. So dumping crap into your tank is'nt likely to fix anything..
    Last edited by Smittro; 11-27-2012 at 10:14 AM.

  17. #37
    NastySS NastySS's Avatar
    Join Date
    Jan 2006
    Location
    West Chester, PA
    Posts
    160

    Black
    2001 Camaro SS 1LE

    PLEASE, CHECK YOUR COMPUTER FOR TROUBLE CODES BEFORE YOU REPLACE ANYTHING. I had a problem with my fuel gauge jumping all around on my "Previous" 2001 Camaro SS, this past August. The computer put out a Trouble Code indicating a faulty sensor in the gas tank. I don't remember the exact code, as it was accidentally found while trying to diagnose an A/C Compressor problem. The computer does put out codes for electrical issues. It gave a code saying the power wire to my A/C Compressor was faulty and/or broken inside the wire casing, which was the case. I totaled the car before I could get to the Gas Needle issue.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Want to trade Tranny Temp gauge for Oil pressure gauge.
    By jrbonds in forum Parts Wanted / Trade
    Replies: 7
    Last Post: 07-29-2011, 09:47 AM
  2. Hooking up Oil pressure gauge,and Temp Gauge
    By BirdFlewLS1 in forum General Help
    Replies: 5
    Last Post: 01-15-2008, 07:15 AM
  3. Oil Pressure Gauge Jumping?
    By bwinch in forum Internal Engine
    Replies: 2
    Last Post: 10-27-2006, 02:47 PM
  4. My battery gauge is jumping around
    By cmaross01 in forum General Help
    Replies: 12
    Last Post: 09-08-2006, 05:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •