Results 1 to 18 of 18

Technical Information

This is a discussion on Technical Information within the General Help forums, part of the LSx Technical Help Section category; When I drive my car hard, my oil pressure takes a dive. Any suggestions?...

  1. #1
    Junior Member
    Join Date
    Oct 2009
    Location
    Ga
    Posts
    4

    white
    1998 camaro z28

    Technical Information

    When I drive my car hard, my oil pressure takes a dive. Any suggestions?

  2. #2
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    i'll be kind and move this thread even though you didn't read the RULES!!!

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Have you checked it with an aftermarket pressure gauge? What sort of numbers are you seeing on the gauge?

  4. #4
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    yeah, what kinda pressures are you seeing. Normally oil pressure should go up with rpm's and not down.

  5. #5
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    probably a bad/leaking sending unit

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    Quote Originally Posted by SeVeReDiStOrTiOn View Post
    probably a bad/leaking sending unit
    very good place to start. I would be careful though with the 98's....there has been some oil pump issues with that year.

  7. #7
    Junior Member
    Join Date
    Oct 2009
    Location
    Ga
    Posts
    4

    white
    1998 camaro z28

    the engine has been replaced with a 04 ls6 crate it now has 98k miles on it.the oil pressure gauge dips down to about 25 psi during desselaration after a hard run not during the run. oil pressure stays between 40 60psi during the run and normal driving

  8. #8
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by floorman1 View Post
    the engine has been replaced with a 04 ls6 crate it now has 98k miles on it.the oil pressure gauge dips down to about 25 psi during desselaration after a hard run not during the run. oil pressure stays between 40 60psi during the run and normal driving
    What is the guage reading at WOT?

  9. #9
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Mine does this as well.

    It is normally a little low on oil when it does.

  10. #10
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by Mr. Luos View Post
    Mine does this as well.

    It is normally a little low on oil when it does.
    Your not the guy that waits for the " Low Oil" Light to come are you

    At WOT my guage is almost pegged out, and I like it that way

  11. #11
    Junior Member
    Join Date
    Oct 2009
    Location
    Ga
    Posts
    4

    white
    1998 camaro z28

    Smile

    the gauge reads 40 to 60 at wot pressure only dips when u come to a stop or almost stopped no noise or other problems stills hauls ass at 12.56 in the quarter

  12. #12
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by floorman1 View Post
    the gauge reads 40 to 60 at wot pressure only dips when u come to a stop or almost stopped no noise or other problems stills hauls ass at 12.56 in the quarter
    If its reading 40 PSI at 6000 RPM, I would be weary.

  13. #13
    Junior Member
    Join Date
    Oct 2009
    Location
    Ga
    Posts
    4

    white
    1998 camaro z28

    Smile

    the gauge reads 40 to 60 at wot pressure only dips when u come to a stop or almost stopped no noise or other problems stills hauls ass at 12.56 in the quarter

  14. #14
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by floorman1 View Post
    the gauge reads 40 to 60 at wot pressure only dips when u come to a stop or almost stopped no noise or other problems stills hauls ass at 12.56 in the quarter

    As a general rule, you want 10 psi of oil pressure for every 1,000 rpm. Therefore, 40 psi at WOT does sound low and it is about 25-35 psi less than what our gauge reads when cranking on it (assuming it is accurate).

  15. #15
    I don't sell out! blackSS01's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    5,558

    Black
    2001 Camaro SS M6

    Quote Originally Posted by Hi-Po View Post
    Your not the guy that waits for the " Low Oil" Light to come are you

    At WOT my guage is almost pegged out, and I like it that way
    Mine is pegged at WOT

    I would start with all the little shit (IE Low oil, leaks, etc....) Hopefully its not the pump starting to go.
    ┌∩┐(◕_◕)┌∩┐

    Man: The Mods you are fighting,
    they are the biggest Men I have ever seen. I
    wouldn't want to fight them!

    Me: That is why no one will remember your name!

  16. #16
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Quote Originally Posted by Hi-Po View Post
    Your not the guy that waits for the " Low Oil" Light to come are you
    Never seen that light.
    As soon as I notice it loosing a little pressure at WOT I add a little oil.

    I see 40-45 at idle, near 70 at WOT.

  17. #17
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    I would verify with a mechanical gauge first....

  18. #18
    Senior Member casperss's Avatar
    Join Date
    Jul 2007
    Location
    Waco Ky.
    Age
    43
    Posts
    1,329

    White
    2001 SS #3504

    Quote Originally Posted by FORD RECOVERY EXPERT View Post
    I would verify with a mechanical gauge first....
    X2

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Technical Articles -- Any Requests?
    By pajeff02 in forum Firebird / WS6
    Replies: 39
    Last Post: 08-15-2011, 07:29 PM
  2. Question: Technical drawings LS7 or Cad Model
    By maestro69 in forum Internal Engine
    Replies: 0
    Last Post: 03-08-2008, 07:37 AM
  3. I need technical info!!! LS1-LS2
    By dvdslw in forum General Help
    Replies: 2
    Last Post: 08-19-2007, 12:36 PM
  4. Technical help posting pics
    By Huskerz1 in forum Almost Anything Goes
    Replies: 1
    Last Post: 03-07-2007, 12:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •