Results 1 to 3 of 3

TCS light always on after cam swap

This is a discussion on TCS light always on after cam swap within the General Help forums, part of the LSx Technical Help Section category; ISSUE HAS BEEN DISCOVERED! Brett at Fbody Central discovered broken wires on the map sensor - THIS CAUSED MY TCS ...

  1. #1
    Member mikeaford's Avatar
    Join Date
    Nov 2005
    Location
    Fredericksburg Va
    Age
    41
    Posts
    151

    Pewter
    01 Trans Am

    TCS light always on after cam swap

    ISSUE HAS BEEN DISCOVERED! Brett at Fbody Central discovered broken wires on the map sensor - THIS CAUSED MY TCS OFF LIGHT TO STAY ON! It would come on normally light on the switch then 2-3 seconds later it would disable itself till you turned the car on and off. Please after checking all the "obvious" stuff like fuses etc. Pull that plug and ensure all the wires are making a good conection. I saw a lot of people asking about this same issue and never really found an answer - hopefully this will fix your TCS light issues out there! Take care and cudos to Brett!

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Thanks for posting your solution.
    Might help out a fellow memeber
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Member mikeaford's Avatar
    Join Date
    Nov 2005
    Location
    Fredericksburg Va
    Age
    41
    Posts
    151

    Pewter
    01 Trans Am

    Too many people have helped me in the past I am always looking on here to try to help someone I consider it a "perk" of owning this fine beast. I'm a father of 3 with one on the way I'd never be able to afford this thing if I didn't do my work myself a good majority of the time. Best of luck to anyone out there.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. PORTED LS1 Heads/Comp Custom Grind Cam Made 450WHP 404WTQ FS
    By EliteZ in forum Parts For Sale / Trade
    Replies: 7
    Last Post: 03-23-2007, 09:55 AM
  2. lt4 Gasket kit for cam swap
    By bigjpyn in forum Parts For Sale / Trade
    Replies: 0
    Last Post: 03-21-2007, 07:51 PM
  3. Pics after the crash and cam swap
    By Phlash_riot in forum Firebird / WS6
    Replies: 11
    Last Post: 01-15-2007, 06:42 AM
  4. What could go wrong in a bad head and cam install?
    By importssuck in forum General Help
    Replies: 5
    Last Post: 08-23-2006, 12:12 AM
  5. Low coolant light
    By fredg369 in forum LT1
    Replies: 3
    Last Post: 09-29-2005, 05:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •