Page 2 of 2 FirstFirst 12
Results 21 to 23 of 23

Tach, TCS and shift issues

This is a discussion on Tach, TCS and shift issues within the General Help forums, part of the LSx Technical Help Section category; yes its attached to the right rear of the valve body...

  1. #21
    Junior Member
    Join Date
    Sep 2006
    Location
    s.e. ma
    Age
    63
    Posts
    22

    primer
    65 nova

    yes its attached to the right rear of the valve body

  2. #22
    Junior Member
    Join Date
    Mar 2006
    Location
    OC CA
    Posts
    46
    Quote Originally Posted by newtechnova View Post
    yes its attached to the right rear of the valve body
    Ugh, that figures. Assuming that's what happened, could the tach and TCS issues be related or do I have multiple unrelated issues?

  3. #23
    Junior Member
    Join Date
    Mar 2006
    Location
    OC CA
    Posts
    46
    So here's the latest.

    I brought the car to a dealership and after having it four days, they said the issue was the "BCM" and that they didn't see any sign of water so while "anything is possible," they don't think the pressure wash on the engine caused the problem. This is quite an expensive coincidence so I'm still sceptical, but it looks like I'm paying for this one.

    To top it off, they're telling me an O2 sensor has failed and is causing the check engine light to stay on, so I'll be spending more money on that.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •