Results 1 to 5 of 5

TA won't start.....garage queen

This is a discussion on TA won't start.....garage queen within the General Help forums, part of the LSx Technical Help Section category; What's up fellas? Longggg time no talk having some problems over here. I sat my TA last August, gonna let ...

  1. #1
    Senior Member Hurley711's Avatar
    Join Date
    Jul 2005
    Location
    Earth
    Age
    41
    Posts
    3,362

    414 RWHP 395 RWTQ
    00 Black Ram Air Trans Am

    TA won't start.....garage queen

    What's up fellas? Longggg time no talk having some problems over here. I sat my TA last August, gonna let her rest and pull her out when she reaches "classic" status and then enjoy her when I am older. I had the oil changed and spark plugs changed right before I sat her, and also a full tune. Every 4-5 days I would go out and start her up, let her get to op. temp and once a week I would driver her around the block a few times. Well 3 days ago I slacked whiel away on vacation and when I started it up it needed a jump. Now today I can't even jump start the car, when I turn the key over it just clicks repeatedly. Windows work radio works, trunk even popped for no reason once. Would this indicate the starter is bad???

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    I'd check the battery voltage first/have it load tested. My hatch popped once when the battery died.

  3. #3
    Senior Member Hurley711's Avatar
    Join Date
    Jul 2005
    Location
    Earth
    Age
    41
    Posts
    3,362

    414 RWHP 395 RWTQ
    00 Black Ram Air Trans Am

    Quote Originally Posted by 2001NBMZ28 View Post
    I'd check the battery voltage first/have it load tested. My hatch popped once when the battery died.
    OK cool thanks. I hope it is the battery much easier than a starter.

  4. #4
    Junior Member
    Join Date
    Apr 2008
    Location
    San Diego
    Posts
    21

    Black
    1999 Trans Am

    Sometimes if the battery is completely dead, you may have to connect to another car and let the other car run for a few minutes (charging your battery) before trying to start your car. This has worked for me a few times when the battery was completely drained.

  5. #5
    Member Frozen WS6's Avatar
    Join Date
    Jan 2006
    Location
    EagleRiver, Alaska
    Age
    39
    Posts
    612

    RED, BLACK
    2001 WS6, 1998 TA

    I would lean toward the battery also. With the electronics on these cars they need a good battery. I hadn't charged mine up all the way and it did almost the same thing. When I charge mine up all the way I have no problems. I park my car from september until april. I don't touch it. If it's lucky I may put the trickle charger on it in december. My car still has the original battery and 67,000 miles with no problems.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. March 2012 Chevy High Performance Garage - Garage
    By Ed Blown Vert in forum Camaro / SS
    Replies: 0
    Last Post: 01-24-2012, 05:10 PM
  2. July 2011 Chevy High Performance Garage - CHP Garage
    By Ed Blown Vert in forum Camaro / SS
    Replies: 0
    Last Post: 06-03-2011, 02:40 PM
  3. April 2011 Chevy High Performance Garage - CHP Garage
    By Ed Blown Vert in forum Camaro / SS
    Replies: 0
    Last Post: 03-12-2011, 12:00 AM
  4. For Sale: 2002 Camaro SS - Red - M6 - Garage Queen
    By Lucas'02SS in forum Vehicles For Sale / Trade
    Replies: 1
    Last Post: 10-30-2010, 12:36 PM
  5. Sad sad day for me. The Trans Am finally sits as garage queen...
    By Hurley711 in forum Almost Anything Goes
    Replies: 16
    Last Post: 08-05-2007, 09:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •