Results 1 to 4 of 4

T Top starting to rattle

This is a discussion on T Top starting to rattle within the General Help forums, part of the LSx Technical Help Section category; Over the past few weeks I've noticed a rattle/squeak sound coming from my passenger side when I'm driving. It goes ...

  1. #1
    Member Ripper415's Avatar
    Join Date
    Sep 2005
    Location
    NY
    Age
    32
    Posts
    378

    Pewter
    2002 Camaro SS

    T Top starting to rattle

    Over the past few weeks I've noticed a rattle/squeak sound coming from my passenger side when I'm driving. It goes away if I push on the passenger T top but the noise starts again as soon as I let go. I've taken it off and checked all the seals (they look fine) and put it back on and the noise just wont stop. Any tips?

  2. #2
    Member
    Join Date
    Oct 2006
    Location
    Springfield
    Age
    30
    Posts
    330

    Silver
    2004 SVT Cobra

    This happended on my TA when it passed 80,000. Do you have subframe connectors?

  3. #3
    Member Kup98ss's Avatar
    Join Date
    Apr 2007
    Location
    North Carolina
    Age
    38
    Posts
    604

    Arctic White
    2002 A4,WS6

    I have this happening on mine as well. I have sfc's and it didn't start until I put them in.

  4. #4
    Member red99ws6's Avatar
    Join Date
    Jul 2007
    Location
    tazewell, tennessee
    Age
    39
    Posts
    312

    red
    1999 Trans Am WS-6

    mine is doing it too. no sfc just stock car. my dash also cracked up the middle. i guess they put too much motor in these cars and not enough car

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Rattle In My ORY
    By TransAmFanatic in forum General Help
    Replies: 8
    Last Post: 08-28-2008, 08:03 PM
  2. rattle at 5 to 5,500 rpm
    By Justin93 in forum General Help
    Replies: 21
    Last Post: 08-18-2008, 03:50 PM
  3. 5.3 rattle rattle knock knock........ NOOO!!
    By crawdad369 in forum GM Trucks
    Replies: 5
    Last Post: 02-14-2008, 02:38 PM
  4. I have a rattle!
    By bluefields88 in forum General Help
    Replies: 5
    Last Post: 12-13-2007, 05:16 AM
  5. Rattle
    By wingnut in forum GTO
    Replies: 4
    Last Post: 03-15-2006, 06:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •