Results 1 to 15 of 15

Symptoms of bad maf sensor?

This is a discussion on Symptoms of bad maf sensor? within the General Help forums, part of the LSx Technical Help Section category; my 98 ss brought up the evaporative emissions code...unplugged the maf sensor and it seemed to make things alot better...what ...

  1. #1
    Junior Member
    Join Date
    Oct 2009
    Location
    alabama
    Posts
    8

    red
    1998 ss camaro m6

    Symptoms of bad maf sensor?

    my 98 ss brought up the evaporative emissions code...unplugged the maf sensor and it seemed to make things alot better...what does this mean?

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Age
    43
    Posts
    21,753

    98 Formula
    06 duramax

    your evap has no correlation to your maf. Any mods to the car? When was the last time you cleaned your maf sensor?

  3. #3
    Senior Member TransAm11973's Avatar
    Join Date
    Nov 2007
    Location
    in my Trans Am
    Posts
    2,630

    Black
    2000 Trans Am WS6

    you have a fuel system issue, with the evap canister system for the fuel tank

  4. #4
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,608

    Custom Swirly Black
    2001 WS6 M6

    What code number is it?

  5. #5
    Junior Member
    Join Date
    Oct 2009
    Location
    alabama
    Posts
    8

    red
    1998 ss camaro m6

    Never cleaned the maf...should i try that or just replace it?...and how would i find the exact problem with the evap system?

  6. #6
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    27
    Posts
    897

    Red
    1999 Trans Am

    Clean the maf a bottle of the stuff is 5 bucks at a auto store if that doesn't fix it continue to the next thing.

  7. #7
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,819

    1999 Formula WS6 M6
    2001 Silverado Z71

    Quote Originally Posted by LS1junkie18 View Post
    and how would i find the exact problem with the evap system?
    Post the code number and we'll tell you.

  8. #8
    PFM
    PFM is offline
    Member
    Join Date
    Mar 2007
    Location
    NC
    Posts
    421

    NBM
    1998Z28

    Are you sure you just don't have a bad gas tank cap. I know if its loose or not sealing correctly it will throw that code. A bad or dirty MAF usually causes motor surging and Idle problems on my car.

  9. #9
    Senior Member TransAm11973's Avatar
    Join Date
    Nov 2007
    Location
    in my Trans Am
    Posts
    2,630

    Black
    2000 Trans Am WS6

    does it say if its with the fuel system?
    maybe your MAF was dirty anyway.....

  10. #10
    Junior Member
    Join Date
    Oct 2009
    Location
    alabama
    Posts
    8

    red
    1998 ss camaro m6

    checked the codes today and its bringing up P0102, P0157, and P0449...low input and low voltage i believe...Thanks for any help.

  11. #11
    Junior Member
    Join Date
    Oct 2009
    Location
    alabama
    Posts
    8

    red
    1998 ss camaro m6

    Help with code p0157.

    1998 SS M6...brought up codes p0157 and p0102...any help with exactly wat the problem would be is appreciated.

  12. #12
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    From my manual:

    P0102= Mass air flow sensor circuit, low input
    P0157= O2 sensor curcuit, low voltage post converter right bank..
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  13. #13
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,431

    Black
    1999 TA WS.6

    P0102 is the the code that needs to be addressed first. This is an indication you MAF has failed. Is it a factory MAF or aftermarket?

    Check this thread out for P0157:

    Catalytic Converter Warranty
    6.0 - 5.3 Lingenfelter's - 230/236 - FAST 92/92 - Kooks - 4" exhaust - ecutout - 9" 4.11s
    416 RWHP 375 RWTQ on a Mustang Dyno - On old MAF Tune|Now SD by Frost

    Best 1320' ET - 11.91 | Best MPH - 119 | Best 60' - 1.65

  14. #14
    Junior Member
    Join Date
    Oct 2009
    Location
    alabama
    Posts
    8

    red
    1998 ss camaro m6

    Its factory maf

  15. #15
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    11,319

    Red
    02 35th LE Camaro SS

    You can usually do a quick check of the MAF by tapping on the flat portion of the sensor body with a screwdriver while the car is running. If the engine stumbles or stalls, the sensor is faulty.

    You can also check voltage with the ignition key turned to the on position, car not running. Check the voltage on terminal B ground (black/white) and terminal A (yellow). There should be between 4-6 volts .

    Last, you can check the battery voltage to the MAF with the ignition key turned to the on position, car not running across terminals B ground (black/white) and terminal C (pink). Should read 12 volts.

    This is from the Haynes manual for pre-1998 V8's.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 22
    Last Post: 03-25-2009, 12:00 PM
  2. 98 Ta Maf, Iat Sensor, New Lid???
    By Ls1Joe in forum External Engine
    Replies: 20
    Last Post: 04-14-2008, 12:49 PM
  3. Bad O2 Sensor NEED HELP!!!
    By TransAm11973 in forum General Help
    Replies: 14
    Last Post: 11-26-2007, 01:45 PM
  4. F/s: Co: New Slotted Rotors, Carbon Pads & New Maf Sensor
    By MAP1964 in forum Parts For Sale / Trade
    Replies: 4
    Last Post: 08-15-2006, 02:16 PM
  5. wtb: LS1 maf sensor ,stock !!!!
    By boostn87GN in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 08-12-2005, 08:07 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •