Results 1 to 5 of 5

suspension or tranny problem

This is a discussion on suspension or tranny problem within the General Help forums, part of the LSx Technical Help Section category; while driving today i heard this big bang from under the car thought i ran somethin over. looked in the ...

  1. #1
    Member jonj601's Avatar
    Join Date
    Sep 2005
    Location
    San Diego
    Age
    33
    Posts
    280

    pewter
    02 CAMARO SS

    suspension or tranny problem

    while driving today i heard this big bang from under the car thought i ran somethin over. looked in the rearview, didnt see anything. pulled into the next parking lot looked under the car nothing. it still does it leaving 1st gear and in reverse. thought it was the tranny, got the T56. but then it does while breaking. it is pretty loud. anyone with answers

  2. #2
    tattoo artist,esquire sic2001's Avatar
    Join Date
    Dec 2005
    Location
    Huntington Beach, California
    Age
    47
    Posts
    416

    navy blue metallic
    2001 trans am

    Lower control arms? Sub frame connetors? Mine banged pretty good when a sub frame connector bolt wasnt tight enough.

  3. #3
    Member jonj601's Avatar
    Join Date
    Sep 2005
    Location
    San Diego
    Age
    33
    Posts
    280

    pewter
    02 CAMARO SS

    right on i'll have to check those, damn it is irritating though.

  4. #4
    Simpsons Did it!! 98formy's Avatar
    Join Date
    Mar 2007
    Location
    Minnesota
    Age
    34
    Posts
    596

    83 Z28 new project
    98 Formula WS7-sold:(

    check the tranny mount also

  5. #5
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    32
    Posts
    3,675

    white
    2002 z28

    i have that same prob every now again too

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SLP Cold Air Package problem??
    By TNT in forum General Help
    Replies: 21
    Last Post: 04-26-2007, 04:27 PM
  2. Replies: 2
    Last Post: 08-16-2006, 06:17 PM
  3. Transmission problem :(
    By LSWONZ28 in forum Drivetrain
    Replies: 7
    Last Post: 02-24-2006, 05:56 PM
  4. blown tranny...where to now?
    By myk02k in forum Automatic Transmission
    Replies: 10
    Last Post: 02-09-2006, 04:08 PM
  5. List your suspension mod's and effects
    By uLs1a in forum Suspension and Handling
    Replies: 16
    Last Post: 12-12-2005, 08:42 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •